Condividi tramite


Le immagini PNG non vengono stampate correttamente in Word 2010 dopo la modifica dell'impostazione di ridimensionamento della visualizzazione del sistema in Windows 7

Questo articolo illustra un problema in cui le immagini PNG non vengono stampate correttamente in Word 2010 dopo la modifica dell'impostazione di ridimensionamento per la visualizzazione del sistema in Windows 7.

Si applica a: Windows 7 Service Pack 1
Numero KB originale: 3101023

Sintomi

Prendi in considerazione lo scenario seguente:

  • Si dispone di un computer basato su Windows 7 in cui è installato Microsoft Word 2010.
  • Si dispone di un documento di Word che contiene un'immagine PNG.
  • In Pannello di controllo, modifichi il ridimensionamento della visualizzazione di Windows dall'impostazione predefinita Più piccolo - 100% (impostazione predefinita) a Medio - 125%.
  • In Word si stampa il documento in un driver di stampante basato su XPS.

Dopo aver stampato il documento di Word, si noterà che i bordi dell'immagine PNG vengono tagliati sul riquadro di stampa.

Causa

Questo problema può verificarsi perché l'immagine PNG non contiene il blocco pHYs (dimensioni pixel fisiche) per specificare le dimensioni di ogni pixel nell'immagine.

Soluzione alternativa

Per risolvere il problema, seguire questa procedura:

  1. Avviare Word 2010.
  2. Fare clic con il pulsante destro del mouse sull'immagine PNG e quindi scegliere Formato immagine.
  3. Modificare le impostazioni del dispositivo di scorrimento Sharpen e Ammorbidimento o Luminosità e Contrasto .
  4. Fare clic su Chiudi per salvare le modifiche.
  5. Fare di nuovo clic con il pulsante destro del mouse sull'immagine PNG e quindi ripristinare le impostazioni del dispositivo di scorrimento nelle posizioni originali.
  6. Fare clic su Chiudi per salvare le modifiche.

Questa modifica nelle impostazioni dell'immagine aggiunge il blocco pHYs all'immagine PNG e lo consente di stampare correttamente.

Raccolta dei dati

Se è necessaria l'assistenza del supporto tecnico Microsoft, si consiglia di raccogliere le informazioni seguendo i passaggi indicati in Raccogliere informazioni utilizzando il TSS per i problemi relativi all'esperienza utente.