Nota
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare ad accedere o modificare le directory.
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare a modificare le directory.
Questo articolo fornisce una risoluzione per correggere l'errore "Server occupato" quando si tenta di analizzare un documento.
Si applica a: Windows 10 - tutte le edizioni
Numero KB originale: 2971655
Sintomi
Prendi in considerazione lo scenario seguente:
- Si esegue una versione a 64 bit (x64) di Windows 8.1, Windows 8 o Windows 7.
- Si esegue un'applicazione di analisi a 32 bit.
- Si usa uno scanner che usa l'interfaccia predefinita TWAIN 1.0.
- Si tenta di analizzare un documento.
In questo scenario viene richiesto un messaggio "What do you want to scan?". Nella finestra dei messaggi vengono visualizzate anche le opzioni per configurare lo scanner. Dopo alcuni secondi, viene visualizzato il messaggio di errore seguente:
Server occupato
Causa
Questo problema si verifica perché un'applicazione di analisi a 32 bit è in esecuzione in una versione a 64 bit di Windows. In questo caso, i driver per lo scanner vengono caricati durante un processo di Wiawow64.exe separato. Il messaggio "Cosa vuoi analizzare?" fa parte del processo wiawow64. Il messaggio di errore è causato da una chiamata OLE dall'applicazione di analisi a 32 bit. Questo problema si verifica perché la chiamata OLE ha un valore di timeout che scade mentre l'applicazione di analisi è in attesa dell'input dell'utente nella finestra "What do you want to scan?".
Risoluzione
Per risolvere questo problema, è consigliabile contattare il fornitore dell'applicazione di analisi per aggiornare l'applicazione.
Ulteriori informazioni
Se si è uno sviluppatore, vedere le informazioni seguenti:
Quando chiami AfxOleInit(); funzione, il parametro m_nTimeout è impostato su un valore predefinito di 8 secondi. Per disabilitare il timeout della chiamata OLE, è necessario aggiungere la riga seguente dopo aver chiamato AfxOleInit(); funzione:
AfxOleGetMessageFilter()->EnableNotRespondingDialog(FALSE);
Raccolta dei dati
Se è necessaria l'assistenza del supporto tecnico Microsoft, si consiglia di raccogliere le informazioni seguendo i passaggi indicati in Raccogliere informazioni utilizzando il TSS per i problemi relativi all'esperienza utente.