Condividi tramite


Errore "Timeout dell'operazione" durante la creazione di una partizione tramite la console di gestione disco o DiskPart.exe

Questo articolo consente di correggere l'errore "Timeout dell'operazione" durante la creazione di una partizione tramite la console di gestione disco o DiskPart.exe.

Si applica a: Windows Server 2012 R2, Windows Server 2008 R2 Service Pack 1
Numero KB originale: 2826890

Sintomi

  • Quando si tenta di creare un nuovo volume in Gestione disco (diskmgmt.msc), è possibile che venga visualizzato il messaggio di errore seguente:

    Impossibile completare l'operazione perché la visualizzazione della console gestione disco non è aggiornata. Aggiornare la visualizzazione usando l'attività di aggiornamento. Se il problema persiste, chiudere la console gestione disco, riavviare Gestione disco o riavviare il computer.

  • Se si tenta di creare una nuova partizione usando Diskpart.exe, è possibile che venga visualizzato un messaggio di errore simile ai seguenti:

    Errore del servizio disco virtuale:
    L'operazione ha raggiunto il timeout.

    Diskpart ha fatto riferimento a un oggetto che non è aggiornato.
    Aggiornare l'oggetto usando il comando RESCAN.
    Se il problema persiste, uscire da DiskPart, riavviare DiskPart o riavviare il computer.

  • Inoltre, è possibile che venga visualizzata una finestra popup con le informazioni seguenti:

    Trovato nuovo hardware
    Windows deve installare il software driver per il dispositivo sconosciuto

Causa

Questi problemi si verificano se la cartella volume.inf non è presente %Systemroot%\inf .

Risoluzione

Per risolvere il problema, seguire questa procedura:

  1. Aprire un Prompt dei comandi con privilegi elevati. A tale scopo, fare clic su Start, scegliere Tutti i programmi, Accessori, fare clic con il pulsante destro del mouse su Prompt dei comandi e quindi scegliere Esegui come amministratore.

  2. Al prompt dei comandi digitare il comando seguente e quindi premere INVIO: sfc /verifyonly

  3. Se il comando precedente restituisce i problemi rilevati, digitare il comando seguente e quindi premere INVIO. Consenti il completamento dell'operazione di comando:
    sfc /scannow

  4. Aprire Esplora risorse e quindi passare alla %Systemroot%\inf cartella

  5. Verificare se il file volume.inf è stato sostituito. Se il file non viene sostituito, è necessario copiare volume.inf da un altro computer che esegue la stessa versione di Windows, la stessa versione di Service Pack e la stessa architettura della CPU.

Raccolta dei dati

Se è necessaria l'assistenza del supporto tecnico Microsoft, si consiglia di raccogliere le informazioni seguendo i passaggi indicati in Raccogliere informazioni utilizzando TSS per le questioni relative alla distribuzione.