Condividi tramite


Le applicazioni non riescono a trovare un nuovo dispositivo di scansione dopo la disconnessione di un altro dispositivo

Questo articolo consente di risolvere l'errore che si verifica quando un'applicazione non trova un dispositivo di analisi se tale scanner è connesso dopo la disconnessione di un altro scanner.

Versione originale del prodotto: Windows 10, Windows 8.1
Numero KB originale: 4537086

Sintomi

Prendi in considerazione lo scenario seguente:

  1. Si connette un dispositivo di analisi di servizi Web nei dispositivi (WSD) a un computer basato su Windows.
  2. Disconnettere lo scanner WSD.
  3. Si connette un dispositivo di scansione diverso, ad esempio uno scanner USB, al computer.
  4. Si avvia un'applicazione che usa il nuovo scanner. In questo scenario, l'applicazione potrebbe non comportarsi correttamente. Ad esempio, l'applicazione potrebbe non trovare il nuovo scanner. Quando si verifica questo problema, il driver dello scanner potrebbe riscontrare un errore WIA_ERROR_OFFLINE quando chiama il IStiDevice::LockDevice metodo .

Note

Questo problema è applicabile per le versioni di Windows 10 fino a 19H2 (ovvero Windows 10 versione 1909). Il problema è stato risolto nella versione 20H1 (Windows 10 versione 2004)

Causa

Questo problema si verifica se si verifica un errore nel servizio "Windows Image Acquisition (WIA)" quando il servizio inizializza lo scanner WSD. Se il processo di inizializzazione ha esito positivo senza errori, questo problema non si verifica.

Soluzione alternativa

Per risolvere questo problema, provare uno dei metodi seguenti:

  • Disinstallare il dispositivo scanner connesso (ad esempio, usando Gestione dispositivi) e quindi riconnettere lo scanner.
  • Arrestare il servizio "Windows Image Acquisition (WIA)" e quindi riavviare il servizio.
  • Riavviare il computer mentre lo scanner è connesso.

Ulteriori informazioni

Per altre informazioni sugli errori che possono verificarsi in un'applicazione o un driver dello scanner WIA, vedere Codici di errore.