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Questo articolo consente di correggere l'errore "accesso negato" in un controller di dominio quando si tenta di replicare il servizio directory di Active Directory.
Numero KB originale: 895085
Importante
In questo articolo sono contenute informazioni relative alla modifica del Registro di sistema. Prima di modificare il Registro di sistema, assicurarsi di eseguirne il backup e verificare di sapere come ripristinarlo in caso di problemi. Per informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero di articolo seguente per visualizzare l'articolo della Microsoft Knowledge Base: 256986 Descrizione del Registro di sistema di Microsoft Windows
Sintomi
Quando si tenta di replicare il servizio directory di Active Directory in un controller di dominio che esegue Microsoft Windows Server 2003 con Service Pack 1 (SP1) o una versione x64 di Microsoft Windows Server 2003, viene visualizzato il messaggio di errore seguente nel controller di dominio di destinazione:
accesso negato
Causa
Questo problema si verifica quando il valore della voce del Registro di sistema RestrictRemoteClients è 2.
Windows Server 2003 SP1 e versioni basate su x64 delle impostazioni di Windows Server 2003 read remote procedure call (RPC) da questa voce. Se la voce ha un valore pari a 2, il traffico RPC deve essere autenticato. Pertanto, la replica di Active Directory non riesce. Possono essere interessati anche altri servizi RPC nel controller di dominio.
Risoluzione
Avviso
If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
Per risolvere questo problema, abilitare la porta 135 in Windows Firewall e quindi usare uno dei metodi seguenti:
- Impostare il valore della voce del Registro di sistema RestrictRemoteClients su 0 o 1.
- Disabilitare l'oggetto Criteri di gruppo Restrizioni per i client RPC non autenticati.
A tale scopo, eseguire la procedura seguente.
Note
Per impostazione predefinita, la porta 135 è bloccata in Windows Server 2003 SP1 e nelle versioni basate su x64 di Windows Server 2003.
Fare clic su Start, scegliere Esegui, digitare firewall.cpl e quindi fare clic su OK.
Fare clic sulla scheda Eccezioni e quindi su Aggiungi porta.
Nella casella Nome digitare un nome per la porta.
Ad esempio, digitare TCP 135.
Nella casella Numero porta digitare 135.
Fare clic su TCP e quindi su OK.
La nuova porta viene visualizzata nella scheda Eccezioni .
Fare clic per selezionare la casella di controllo accanto alla nuova porta e quindi fare clic su OK.
Fare clic su Avvio, fare clic su Esegui, digitareregedit, quindi fare clic suOK. Fare clic su Start, scegliere Esegui, digitare regedit e quindi fare clic su OK.
Usa uno dei seguenti metodi:
Impostare il valore della voce del Registro di sistema RestrictRemoteClients su 0 o 1. A tale scopo, effettuare i passaggi seguenti:
Individuare e selezionare la seguente sottochiave del Registro di sistema:
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Rpc
Nel riquadro destro fare clic sulla voce RestrictRemoteClients.
Note
Se questa voce non esiste, seguire questa procedura:
- Scegliere Nuovo dal menu Modifica, quindi fare clic su Valore DWORD.
- Digitare RestrictRemoteClients e quindi premere INVIO.
Scegliere Modifica dal menu Modifica.
Nella casella Dati valore digitare 0 o 1 e quindi fare clic su OK.
Chiudere l'editor del Registro di sistema.
Utilizzare Editor oggetti Criteri di gruppo per disabilitare l'oggetto Criteri di gruppo Restrizioni per i client RPC non autenticati. A tale scopo, effettuare i passaggi seguenti:
- Fare clic sul pulsante Start, scegliere Esegui, digitare gpedit.msc e quindi fare clic su OK.
- Nell'albero della console fare doppio clic su Configurazione computer, fare doppio clic su Modelli amministrativi, fare doppio clic su Sistemae quindi su Chiamata routine remota.
- Fare doppio clic su Restrizioni per i client RPC non autenticati, fare clic su Disabilita e quindi su OK.
- Uscire dall'Editor oggetti Criteri di gruppo.
Stato
Microsoft ha confermato che questo problema si verifica nei prodotti elencati nella sezione "Si applica a".
Ulteriori informazioni
Per altre informazioni sulla voce del Registro di sistema RestrictRemoteClients, visitare il seguente sito Web Microsoft: RestrictRemoteClients chiave del Registro di sistema abilitata
Supporto tecnico per le edizioni di Windows x64
Il produttore dell'hardware fornisce supporto tecnico e assistenza per le edizioni di Microsoft Windows x64. Il produttore dell'hardware fornisce supporto perché un'edizione di Windows x64 è stata inclusa nell'hardware. Il produttore dell'hardware potrebbe aver personalizzato l'installazione di Windows x64 Edition con componenti univoci. quali specifici driver di periferica o impostazioni facoltative, per ottimizzare le prestazioni dell'hardware. Microsoft fornirà assistenza ragionevole se hai bisogno di assistenza tecnica per l'edizione di Windows x64. ma potrebbe essere necessario contattare direttamente il produttore dell'hardware, in quanto soggetto più qualificato per fornire supporto per il software preinstallato nell'hardware.