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Questo articolo fornisce una soluzione a un problema per cui i client non possono aggiungere o accedere al dominio.
Si applica a: Windows Server 2003
Numero KB originale: 912023
Sintomi
Si consideri il seguente scenario. Un computer client basato su Microsoft Windows XP viene aggiunto a un dominio di Microsoft Windows Server 2003. Inoltre, Windows Server 2003 Service Pack 1 (SP1) viene installato nel controller di dominio di autenticazione. In questo scenario si verificano i sintomi seguenti:
- Non è possibile connettersi a Internet.
- Non è possibile aggiungere o accedere al dominio. Pertanto, il controller di dominio è in modalità blocco IPsec.
Quando si avvia il componente servizi IPSEC nel controller di dominio, è possibile che venga visualizzato un messaggio di errore simile al seguente:
Non è possibile trovare il file specificato.
Inoltre, gli eventi seguenti possono essere registrati nel log di sistema del server:
Tipo di evento: Errore
Origine evento: IPSEC
Categoria evento: Nessuna
ID evento: 4292
Date: <DateTime>
Ora: <DateTime>
Utente: N/D
Computer: <ComputerName>
Descrizione:
Il driver IPSec è entrato in modalità Blocco. IPSec eliminerà tutto il traffico di rete TCP/IP in ingresso e in uscita non consentito dalle esenzioni dei criteri IPSec in fase di avvio.
Tipo di evento: Errore
Origine evento: Service Control Manager
Categoria evento: Nessuna
ID evento: 7023
Date: <DateTime>
Ora: <DateTime>
Utente: N/D
Computer: <ComputerName>
Descrizione:
Il servizio servizi IPSEC terminato con l'errore seguente: Il sistema non riesce a trovare il file specificato
Causa
Questo problema può verificarsi se la chiave del Registro di sistema IPSec\Policy\Local viene eliminata o quando è presente un file danneggiato nell'archivio criteri. Il file può diventare danneggiato se si verifica un'interruzione quando i criteri vengono scritti sul disco.
Risoluzione
Importante
In questa sezione, metodo o attività viene illustrata la procedura per modificare il Registro di sistema. Se, tuttavia, si modifica il Registro di sistema in modo errato, possono verificarsi gravi problemi. Pertanto, assicurarsi di osservare attentamente la procedura seguente. Per una maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. Successivamente, è possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e il ripristino del Registro di sistema, vedi Come eseguire il backup e il ripristino del Registro di sistema in Windows.
Per risolvere il problema, seguire questa procedura:
Eliminare la sottochiave del Registro di sistema dei criteri locali. A tale scopo, effettuare i passaggi seguenti:
Fare clic su Start, scegliere Esegui, digitare regedit nella casella Apri e quindi fare clic su OK.
Nell'editor del Registro di sistema individuare e quindi fare clic sulla sottochiave seguente:
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\IPSec\Policy\Local
Scegliere Elimina dal menu Modifica.
Fare clic su Sì per confermare che si desidera eliminare la sottochiave.
Chiudere l'editor del Registro di sistema.
Ricompilare un nuovo archivio criteri locale. A tale scopo, fare clic su Start, fare clic su Esegui, digitare regsvr32 polstore.dll nella casella Apri e quindi fare clic su OK.
Verificare che il componente Servizi IPSEC sia impostato su automatico e quindi riavviare il controller di dominio.
Soluzione alternativa
Per risolvere temporaneamente questo problema, disabilitare il componente Servizi IPSEC e quindi riavviare il controller di dominio.