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"w32tm /resync" ha esito negativo con "Il computer non è stato risincronizzato perché non sono disponibili dati di ora".

Questo articolo fornisce diverse possibili soluzioni a un errore che può verificarsi quando si esegue il comando per sincronizzare l'ora w32tm /resync con un'origine ora.

Si applica a: Windows Server (tutte le versioni supportate)
Numero KB originale: 929276

Sintomi

Il computer presenta problemi di sincronizzazione dell'ora. Se si esegue una risincronizzazione manuale eseguendo w32tm /resync, viene restituito l'errore seguente: Il computer non è stato risincronizzato perché non sono disponibili dati di ora.

C:\Windows\system32>w32tm /resync /rediscover
Sending resync command to local computer
The computer did not resync because no time data was available

È anche possibile visualizzare gli eventi seguenti:

Nome registro: sistema
Origine: Microsoft-Windows-Time-Service
Data: 24-04-2019 22:35:55
ID evento: 129
Categoria attività: nessuna
Livello: Avviso
Parole chiave:
Utente: SERVIZIO LOCALE
Computer: MEM1.fabrikam.com
Descrizione: NtpClient non è riuscito a impostare un peer di dominio da usare come origine temporale a causa dell'errore di individuazione. NtpClient tenterà di nuovo in 15 minuti e raddoppierà l'intervallo successivo. Errore: la voce non viene trovata. (0x800706E1)

Nome registro: sistema
Origine: Microsoft-Windows-Time-Service
Data: 24-04-2019 23:45:32
ID evento: 134
Categoria attività: nessuna
Livello: Avviso
Parole chiave:
Utente: SERVIZIO LOCALE
Computer: MEM1.fabrikam.com
Descrizione: NtpClient non è riuscito a impostare un peer manuale da usare come origine temporale a causa di un errore di risoluzione DNS in 'time.windows.com,0x9'. NtpClient tenterà di nuovo in 15 minuti e raddoppierà l'intervallo successivo. Errore: nessun host di questo tipo è noto. (0x80072AF9)

Causa

Questo errore si verifica in genere quando il client invia una richiesta NTP ma non ottiene una risposta NTP appropriata in cambio. Esistono più scenari che possono causare questo problema.

Scenario 1

Il client NTP non riesce a trovare il server NTP. Ciò potrebbe essere dovuto a un errore di risoluzione dei nomi (DNS) o a causa di un errore di ortografia dell'indirizzo nome/IP definito nella chiave del Registro di sistema NTPServer.

Scenario 2

La porta UDP 123 è bloccata. Potrebbe trovarsi in Windows Firewall locale o in un firewall non Microsoft.

Scenario 3

Il server NTP di destinazione con cui il client sta provando a sincronizzare l'ora non è pubblicitario come server NTP.

Risoluzione

Risoluzione per lo scenario 1

  1. Controllare l'ortografia e l'accuratezza del valore definito nella chiave del Registro di sistema NTPServer. Chiedere al cliente di verificare che sia un server valido, con il nome o l'indirizzo IP corretto.
  2. Controllare DNS. Assicurarsi che i server DNS appropriati siano definiti in grado di risolvere il server NTP di destinazione.
  3. Usare le tracce di rete per un'idea migliore di ciò che accade con la risoluzione dei nomi.

In definitiva, questo scenario potrebbe finire come Scenario 2 o Scenario 3.

Risoluzione per lo scenario 2

Raccogliere tracce di rete per esaminare il traffico della porta UDP 123. Eseguire questa operazione avviando un'acquisizione, quindi eseguendo un oggetto w32tm /resync /rediscover.

  1. Se non vengono inviati pacchetti UDP 123 (richiesta NTP), è probabile che la porta UDP 123 sia bloccata in Windows Firewall locale.
  2. Se vengono visualizzati pacchetti di porta UDP 123 (richiesta NTP) inviati ma nessuna risposta, è probabile che la porta UDP 123 sia bloccata in un firewall non Microsoft.

Se questa operazione viene convalidata e la porta UDP 123 non è bloccata, prendere in considerazione lo scenario 3.

Risoluzione per lo scenario 3

  1. Se il cliente sta tentando di eseguire la sincronizzazione con un controller di dominio (tramite NT5DS, NTP o AllSync), esaminare la gerarchia ora di Windows. A partire dal PDC, controllare i controller di dominio per assicurarsi che ricevano tutto il tempo dalla rispettiva origine. È possibile usare w32tm /monitor per un rapido controllo dello stato su tutti i controller di dominio.

  2. Se i controller di dominio sincronizzano correttamente l'ora dall'origine, verificare e assicurarsi che i controller di dominio annuncino come controller di dominio eseguendo un .dcdiag /test:Advertising

  3. Infine, nei controller di dominio verificare che le chiavi del Registro di sistema w32time seguenti siano configurate come segue (in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time):

    • In tutti i controller di dominio: \TimeProviders\NtpServer – Enabled=1
    • Nel PDC: \Config – AnnounceFlags = 5
    • Nei controller di dominio membri: \Config – AnnounceFlags = 10