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Risolvere l'errore di replica del controller di dominio 1727- La chiamata alla procedura remota non è riuscita e non è stata eseguita

Questo articolo risolve il messaggio di errore "La chiamata alla procedura remota non è riuscita e non è stata eseguita". Questo errore si verifica durante la replica del controller di dominio in Windows Server.

Si applica a: Windows Server (tutte le versioni supportate)
Numero KB originale: 4019721

Sintomi

Questo errore di replica di Active Directory (AD) viene visualizzato in uno o più dei formati seguenti:

  • Decimale: 1727
  • Hex: 0x6bf
  • Simbolico: RPC_S_CALL_FAILED_DNE
  • Messaggio di errore: la chiamata di procedura remota non è riuscita e non è stata eseguita.

Causa

Questo problema si verifica a causa di uno dei motivi seguenti:

  • Problema di connettività di rete tra i due controller di dominio. Per altre informazioni, vedere le sezioni seguenti.
  • Problema di prestazioni indotto dal carico nel partner di replica. Questo problema è meno comune ed è spesso temporaneo. Per altre informazioni, vedere le sezioni seguenti.

Informazioni sul problema di connettività di rete

Questo problema si verifica quando il partner di replica del controller di dominio non riesce a completare la connessione RPC al servizio RPC (DRSR UUID E3514235-4B06-11D1-AB04-00C04FC2DCD2). In particolare, il partner di replica può eseguire l'associazione al mapper dell'endpoint RPC, ma non può completare l'associazione RPC DRSR.

Le possibili cause radice includono:

  • firewall
  • router
  • Ottimizzatori WAN
  • altri dispositivi di rete intermedi
  • driver di filtro di rete

Informazioni sul problema di prestazioni

Questo problema si verifica quando si verifica una delle condizioni seguenti:

  • Il server viene registrato di nuovo e non risponde al protocollo TCP ACK o al messaggio di risposta. Quindi, il mittente abbandona la sessione TCP.
  • La rete è troppo lenta o inaffidabile. Non può recapitare il protocollo TCP ACK o il messaggio di risposta.

Risoluzione

Per risolvere questo problema, determinare eventuali modifiche recenti che potrebbero influire sulla rete tra i due controller di dominio e annullare tali modifiche, se possibile. Se non sono state apportate modifiche recenti, è necessario esaminare completamente la connettività di rete RPC tra i due controller di dominio. A tale scopo, seguire i passaggi generali per la risoluzione dei problemi o i passaggi dettagliati per la risoluzione dei problemi.

Passaggi generali per la risoluzione dei problemi

  1. Acquisire un'acquisizione di rete a doppio lato mentre si riproduce il problema. A tale scopo, effettuare i passaggi seguenti:

    1. Avviare un'acquisizione di rete in entrambi i controller di dominio.
    2. Avviare manualmente la replica tra i due controller di dominio.
    3. Arrestare entrambi i lati della traccia quando viene visualizzato l'errore.
  2. Esaminare la conversazione RPC tra i due controller di dominio. Determinare se esiste mai un caso in cui il messaggio inviato dal controller di dominio del richiedente non incorre in una risposta dal partner di replica.

Note

Occasionalmente, è presente una risposta parziale che include l'ACK TCP piggy-back per il messaggio di richiesta. Ma il traffico è stato modificato o la risposta non arriva effettivamente al controller di dominio del richiedente. Di conseguenza, lo stack TCP non riceve un ACK.

Passaggi dettagliati per la risoluzione dei problemi

Avviare un'acquisizione di rete in entrambi i controller di dominio prima di eseguire i passaggi seguenti per testare la connettività del controller di dominio.

Testare la connettività del controller di dominio di origine dal controller di dominio di destinazione

Seguire questa procedura nel controller di dominio di destinazione:

  1. Verificare se il controller di dominio di origine è in ascolto sulla porta TCP 135. A tale scopo, eseguire il PortQry.exe -n -e 135 comando .

    Se lo stato della porta è FILTRATO, è probabile che l'errore di replica di AD abbia esito negativo e restituisca l'errore 1722. Provare a risolvere l'errore 1722 e quindi verificare se la replica di Active Directory ha esito positivo. Se il problema persiste, riavviare i passaggi dettagliati per la risoluzione dei problemi.

    Se lo stato non è FILTRATO, i comandi restituiscono il database del mapper dell'endpoint RPC. Cercare MS NT Directory DRS Interface per trovare la porta di intervallo superiore nel database del mapper dell'endpoint su cui il controller di dominio di origine è in ascolto per la replica di Active Directory. È possibile ottenere una o più voci. Prendere nota delle porte per ncacn_ip_tcp.

    Ad esempio, si ottiene un elemento simile all'esempio seguente, che presenta due porte di intervallo superiore 49159 e 49160:

    UUID: e3514235-4b06-11d1-ab04-00c04fc2dcd2 MS NT Directory DRS Interface ncacn_ip_tcp:2012dc[49159] 1UUID: e3514235-4b06-11d1-ab04-00c04fc2dcd2 MS NT Directory DRS Interface ncacn_ip_tcp:2012dc[49160]

    Note

    Le porte di intervallo superiore sono specifiche del controller di dominio e vengono assegnate dinamicamente. Tuttavia, un amministratore può impostare come hardcoded la porta usata per la replica di Active Directory usando il valore del Registro di sistema seguente.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Parameters
    Valore del Registro di sistema: porta TCP/IP
    Tipo di valore: REG_DWORD
    Dati valore: (porta disponibile)

  2. Testare la connettività della porta TCP alle porte di intervallo superiore note. A tale scopo, eseguire il comando seguente:

    PortQry.exe -n <SourceDC> -e <Upper_Range_Port_Number>
    

    Ad esempio, si eseguono i comandi seguenti:

    PortQry.exe -n 2012dc -e 49159
    PortQry.exe -n 2012dc -e 49160
    

    Se lo stato della porta è FILTRATO, esaminare la traccia di rete acquisita per determinare dove è bloccato il pacchetto.

  3. Testare IL DNS. Verificare che il controller di dominio di destinazione possa risolvere i record CNAME e HOST del controller di dominio di origine. Verificare che l'indirizzo IP risolto sia l'indirizzo IP effettivo del controller di dominio di origine. Se DNS punta a un indirizzo IP precedente o non valido, viene eseguito un tentativo di connessione RPC a un controller di dominio di origine non corretto.

Testare la connettività del controller di dominio di destinazione dal controller di dominio di origine

Ripetere il passaggio da 1 a 3 nel controller di dominio di origine.

Raccolta dei dati

Se è necessaria assistenza dal supporto tecnico Microsoft, è consigliabile raccogliere le informazioni seguendo i passaggi indicati in Raccogliere informazioni usando TSS per i problemi di replica di Active Directory.