Nota
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare ad accedere o modificare le directory.
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare a modificare le directory.
Questo articolo fornisce una soluzione a un problema per cui i file non possono essere aperti e registrati come danneggiati nei volumi deduplicati.
Numero KB originale: 3066174
Sintomi
Gli utenti non possono più aprire file in un volume abilitato per la deduplicazione creato con la compressione NTFS abilitata nella radice del volume. Inoltre, il processo di pulitura della deduplicazione dati può registrare un evento nel registro eventi per segnalare il danneggiamento del volume di file che non è in grado di ripristinare.
Causa
Questo problema si verifica perché i metadati di deduplicazione archiviati nella radice del volume compresso vengono danneggiati quando un processo scrive sul posto in un file nel volume deduplicato. I metadati di deduplicazione archiviati nella radice del volume compresso si trovano nella cartella SVI (System Volume Information).
La duplicazione non è supportata nei volumi con compressione abilitata nella radice quando viene creato il volume. Tuttavia, la deduplicazione nelle cartelle compresse è supportata e funziona come previsto.
Risoluzione
Per risolvere questo problema, non abilitare la deduplicazione dei dati in un volume NTFS con compressione a livello di volume abilitata.
Sfortunatamente, non è possibile ripristinare i dati già danneggiati nei volumi compressi esistenti con deduplicazione abilitata. I file che sono già stati danneggiati devono essere ripristinati dai backup, se disponibili.
Per decomprimere la cartella dei metadati di deduplicazione in modo che le azioni di scrittura nei file deduplicati in questo volume non siano più danneggiate, seguire questa procedura.
Note
Nei comandi di esempio, <X> è un volume creato come compresso e con Deduplicazione dati abilitata.
Scaricare lo strumento PsExec dal seguente sito Web Di Windows Sysinternals: PsExec v2.2
Note
Lo strumento PsExec consente agli utenti di eseguire processi con diritti utente "SYSTEM". Questo è necessario per accedere alla cartella dei metadati di Deduplicazione dati protetta che si trova nella cartella System Volume Information.
Bloccare l'accesso ai dati per gli utenti nel volume interessato. A tale scopo, eseguire il comando disable-dedupvolume di Windows PowerShell seguente:
disable-dedupvolume X: -dataaccess
Note
- Questo comando smonta e quindi rimonta il volume senza il filtro di deduplicazione dati associato. Ciò impedisce agli utenti di accedere a qualsiasi file deduplicato.
- L'azione di smontaggio invalida eventuali handle di file aperti in questo volume.
Usare PsExec per eseguire Cmd.exe come utente "SYSTEM". A tale scopo, utilizzare il seguente comando:
Psexec.exe -i -s cmd
Note
La finestra del prompt dei comandi verrà ora aperta con diritti utente "SYSTEM" assegnati.
Attenzione
L'account "SYSTEM" è un account utente con un livello di accesso molto superiore rispetto a un account amministratore. Gli utenti devono prestare attenzione a eseguire solo i passaggi menzionati nell'articolo mentre eseguono l'account "SYSTEM". Gli utenti devono prestare particolare attenzione a non modificare gli elenchi di controllo di accesso o assumere la proprietà della cartella System Volume Information.
Nella finestra del prompt dei comandi PsExec individuare la cartella System Volume Information del volume interessato.
Verificare che la cartella dei metadati di deduplicazione del volume sia attualmente compressa.
Decomprimere la cartella dei metadati di deduplicazione del volume.
Nella finestra del prompt dei comandi di PsExec eseguire il comando seguente:
X:\System Volume Information>compact /s:Dedup
L'output includerà il seguente messaggio di riepilogo:
Di file M all'interno di N directory
<X> sono compressi e <Y> non sono compressi.Se <X> è maggiore di zero (0), andare al passaggio 8. In caso contrario, andare al passaggio 11 perché la cartella dei metadati di deduplicazione non è compressa.
Nella finestra del prompt dei comandi di PsExec eseguire il comando seguente:
X:\System Volume Information>compact /u /s:Dedup
Attendere che la cartella dei metadati di deduplicazione sia decompressa. Il processo funziona su un file alla volta e può essere lento.
Note
Il tempo richiesto da questo processo è proporzionale alla quantità di dati presenti nel volume. Per i volumi che contengono terabyte di dati, il completamento di questo processo può richiedere diverse ore. Al termine, il comando viene chiuso e viene generato il messaggio di stato seguente:
N file all'interno delle directory M non sono stati compressi.Nella finestra del prompt dei comandi di PsExec eseguire il comando "display compression state" seguente per verificare che nella cartella dei metadati di Deduplicazione dati non siano presenti file compressi.
X:\System Volume Information>compact /s:Dedup
Chiudere la finestra del prompt dei comandi di PsExec.
Riabilitare l'accesso ai dati per gli utenti nel volume interessato. A tale scopo, utilizzare il seguente comando:
Enable-DedupVolume X: -DataAccess
Note
- Questo comando smonta e quindi rimonta il volume con il filtro di deduplicazione dati associato. Gli utenti potranno ora accedere ai file deduplicati.
- L'azione di smontaggio invalida eventuali handle di file aperti in questo volume.
Note
Per evitare che si verifichino danneggiamenti simili, eseguire questa procedura su tutti i volumi abilitati per la deduplicazione creati come compressi.