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Le zone DNS non caricano e vengono registrati l'ID evento 4000 e 4007

Questo articolo risolve un problema per cui gli ID evento 4000 e 4007 vengono registrati quando le zone DNS non vengono caricate nella console DNS.

Numero KB originale: 2751452

Sintomi

Uno dei server DNS nell'ambiente inizia a mostrare un problema che indica che le zone non vengono caricate nella console DNS. E gli ID evento 4000 e 4007 vengono registrati nei registri eventi DNS:

ID evento 4000:

The DNS server was unable to open Active Directory. This DNS server is configured to obtain and use information from the directory for this zone and is unable to load the zone without it. Check that the Active Directory is functioning properly and reload the zone. The event data is the error code.

ID evento 4007:

The DNS server was unable to open zone \<zone> in the Active Directory from the application directory partition \<partition name>. This DNS server is configured to obtain and use information from the directory for this zone and is unable to load the zone without it. Check that the Active Directory is functioning properly and reload the zone. The event data is the error code.

Inoltre, quando si tenta di aprire la console DNS si ottiene un popup che dà Accesso negato.

Si noti che il servizio server DNS è operativo.

Quando si tenta di eseguire qualsiasi operazione nelle zone integrate di ACTIVE Directory tramite DNSCMD, viene visualizzato il messaggio di errore Accesso negato .

Causa

Questo problema si verifica quando quel determinato server DC/DNS ha perso il proprio canale protetto con se stesso o PDC.

Questo problema può verificarsi anche in un singolo ambiente del controller di dominio in cui il server DC/DNS contiene tutti i ruoli FSMO e punta a se stesso come server DNS primario.

Risoluzione

Nel caso in cui nell'ambiente sia presente un altro controller di dominio/server DNS, configurare il server che riscontra il problema in modo che punti ad altri server DNS attivi nelle proprietà TCP/IP.

  1. Arrestare il servizio KDC nel controller di dominio che riscontra il problema.

  2. Eseguire il comando seguente con diritti elevati:

    netdom resetpwd /server:<PDC.domain.com> /userd:<Domain\domain_admin> /passwordd:*
    

    Richiederà la password dell'account amministratore di dominio usato, immetterlo.

  3. Dopo l'esecuzione del comando, riavviare il server.

Le zone DNS dovrebbero essere caricate ora.

Se è l'unico controller di dominio nell'ambiente e non sono disponibili altri server DNS, seguire la stessa procedura, ma sostituire PDC.Domain.com con il proprio indirizzo IP del server (poiché si tratta del PDC).