Condividi tramite


Lo spooler della stampante può arrestarsi in modo casuale in un computer Windows Server in cui è installata una stampante HP

Questo articolo fornisce una soluzione a un problema a causa del quale lo spooler della stampante si arresta in modo casuale in un computer Windows Server in cui è installata una stampante HP.

Numero KB originale: 947477

Sintomi

In un computer basato su Windows Server in cui è installata una stampante HP, lo spooler della stampante potrebbe arrestarsi in modo casuale.

Causa

Questo problema si verifica a causa di uno dei file seguenti:

  • Hpbmmon.dll (HP Master Monitor)
  • Hpzpi4wm.dll (processore di stampa HP)
  • Hpzpp4wm.dll (processore di stampa HP)
  • HPtcpMon.dll (monitor porta TCP HP)

Risoluzione

Per risolvere il problema, contattare il produttore di terze parti per assistenza.

Importante

In questa sezione, metodo o attività viene illustrata la procedura per modificare il Registro di sistema. Se, tuttavia, si modifica il Registro di sistema in modo errato, possono verificarsi gravi problemi. Pertanto, assicurarsi di osservare attentamente la procedura seguente. Per una maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. Successivamente, è possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e il ripristino del Registro di sistema, vedi Come eseguire il backup e il ripristino del Registro di sistema in Windows.

Soluzione alternativa per il problema causato da Hpbmmon.dll

Per risolvere questo problema, rimuovere HP Master Monitor. A tale scopo, effettuare i passaggi seguenti:

  1. Avviare l'editor del Registro di sistema.

  2. Individuare e quindi fare clic sulla sottochiave HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\HP Master Monitordel Registro di sistema.

  3. Scegliere Esporta dal menu File.

  4. Nella casella Nome file digitare HPprinter e quindi fare clic su Salva.

    Note

    Per ripristinare questa sottochiave del Registro di sistema, fare doppio clic sul file HPprinter.reg salvato in questo passaggio.

  5. Fare clic con il pulsante destro del mouse sulla voce del Registro di sistema di HP Master Monitor e quindi scegliere Elimina.

  6. Fare clic su .

  7. Chiudere l'editor del Registro di sistema e riavviare il computer.

  8. Rinominare il file Hpbmmon.dll in Hpbmmon.old. Il file si trova nel percorso C:\WINDOWS\system32\Hpbmmon.dll file.

Soluzione alternativa per il problema causato da Hpzpi4wm.dll o Hpzpp4wm.dll

Note

Se questa stampante non funziona con WinPrint, la procedura seguente potrebbe non funzionare. In questo caso, contattare HP per aggiornare il processore di stampa HPZPP4WM alla versione più recente.

  1. Fare clic sul pulsante Start e quindi scegliere Pannello di controllo.
  2. Fare doppio clic su Stampanti e fax.
  3. Fare clic con il pulsante destro del mouse sulla stampante che si desidera utilizzare e quindi scegliere Proprietà.
  4. Fare clic sulla scheda Avanzate e quindi su Processore di stampa.
  5. Fare clic su WinPrint nella casella Processore di stampa, fare clic su RAW nella casella Tipo di dati predefinito e quindi fare clic su OK due volte.
  6. Rinominare il file Hpzpi4wm.dll in Hpzpi4wm.old. Il file si trova nel percorso: C:\WINDOWS\system32\spool\drivers\w32x86\3\Hpzpi4wm.dll.
  7. Rinominare il file Hpzpp4wm.dll in Hpzpp4wm.old. Il file si trova nel percorso: C:\WINDOWS\system32\spool\PRTPROCS\W32X86\Hpzpp4wm.dll.

Soluzione alternativa per il problema causato da HPtcpMon.dll

  1. Avviare l'editor del Registro di sistema.

  2. Individuare e selezionare la sottochiave del Registro di sistema: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\HP Standard TCP/IP Port

  3. Scegliere Esporta dal menu File.

  4. Nella casella Nome file digitare HPprinter e quindi fare clic su Salva.

    Note

    Per ripristinare questa sottochiave del Registro di sistema, fare doppio clic sul file HPprinter.reg salvato in questo passaggio.

  5. Fare clic con il pulsante destro del mouse sulla voce del Registro di sistema PORTA TCP/IP Standard HP e quindi scegliere Elimina.

  6. Fare clic su .

  7. Individuare e quindi fare clic sulla sottochiave HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\Standard TCP/IP Portdel Registro di sistema.

  8. Fare doppio clic su Driver e quindi verificare che il valore della casella Dati valore sia tcpmon.dll.

    Note

    Se la voce del Registro di sistema driver non esiste o il relativo valore non è tcpmon.dll, creare la voce del Registro di sistema del driver e quindi impostarne il valore su tcpmon.dll. A tale scopo, effettuare i passaggi seguenti:

    1. Scegliere Nuovo dal menu Modifica e quindi fare clic su Valore stringa.
    2. Digitare Driver e quindi premere INVIO.
    3. Fare clic con il pulsante destro del mouse su Driver e quindi scegliere Modifica.
    4. Nella casella Dati valore digitare tcpmon.dll e quindi fare clic su OK.
  9. Chiudere l'editor del Registro di sistema e riavviare il computer.

  10. Rinominare il file HPtcpMon.dll in HPtcpMon.old. Il file si trova nel percorso: C:\WINDOWS\system32\HPTcpMon.dll.

Ulteriori informazioni

I prodotti di terzi citati in questo articolo sono prodotti da società indipendenti da Microsoft. Microsoft non rilascia alcuna garanzia implicita o esplicita relativa alle prestazioni o all'affidabilità di tali prodotti