Nota
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare ad accedere o modificare le directory.
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare a modificare le directory.
Questo articolo fornisce una soluzione a un problema per cui l'elenco delle stampanti sarà vuoto quando si visualizzano le stampanti in un server remoto tramite Print Management Console (PMC).
Numero KB originale: 2253813
Sintomi
Quando si visualizzano le stampanti in un server remoto tramite Print Management Console (PMC), l'elenco delle stampanti sarà vuoto, ma l'elenco di driver e/o porte potrebbe essere visualizzato correttamente.
Il ping dell'FQDN del client (ad esempio, client.subdomain.domain.com
) dal server di stampa genera un errore di risoluzione dei nomi.
Causa
Il sistema client (il sistema che esegue PMC) non dispone di un record DNS A (ricerca diretta) o il record non è corretto.
Risoluzione
Aggiungere un record DNS A per il sistema che esegue PMC o correggere il record esistente.
Ulteriori informazioni
In una traccia di rete è possibile visualizzare quanto segue request / response
. Il motivo per cui ciò può essere presente o meno nella traccia di rete è dovuto al fatto che se la risoluzione dei nomi è stata tentata in precedenza, la risposta verrà memorizzata nella cache nel server. Per cancellare la cache, usare ipconfig /flushdns
e quindi acquisire la traccia.
RpcRemoteFindFirstPrinterChangeNotificationEx Request, Local Machine =
\\servername.company.com
, Printer Local = nnnnnn
RpcRemoteFindFirstPrinterChangeNotificationEx Response, Status = RPC_S_SERVER_UNAVAILABLE
In una traccia di rete dal server di stampa potrebbe essere visualizzata una query DNS avviata e una risposta ricevuta:
DNS:QueryId = 0xB19B, QUERY (query Standard), Query per
servername.company.com
il tipo Host Addr nella classe Internet
DNS:QueryId = 0xB19B, QUERY (query standard), Risposta - Errore del nome
Note
La risoluzione breve dei nomi per il nome client può funzionare, tramite gli elenchi di ricerca del suffisso DNS (se il record DNS si trova nel dominio errato) o WINS. Provare a cercare il nome di dominio completo del client nel server di stampa. Internamente, lo spooler usa il nome di dominio completo per richiamare il client, quindi se il nome di dominio completo non viene risolto, il callback avrà esito negativo.