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Il tasto bloc maiuscole inverte in modo imprevisto i caratteri in una sessione desktop remoto in un computer basato su Windows Server 2012

Questo articolo fornisce una soluzione a un problema a causa del quale lo stato della chiave di blocco maiuscole attivato da un'applicazione in un computer remoto non viene sincronizzato con il computer client.

Numero KB originale: 3120433

Sintomi

Si supponga di connettersi a un computer remoto in una sessione desktop remoto. Se un'applicazione, ad esempio winword.exe o osk.exe, modifica lo stato della chiave di blocco maiuscole, questa modifica non verrà sincronizzata con il computer client.

Ad esempio, in una sessione desktop remoto, quando si apre Microsoft Word, digitare h, attivare Bloc maiuscole premendo la tastiera e quindi digitare ELLO, la parola è hELLO. Premere quindi INVIO. In questo caso, l'hELLO in Word verrà corretto automaticamente in Hello e il blocco maiuscole viene disattivato nella sessione desktop remoto. Tuttavia, sulla tastiera fisica del client, la luce Bloc maiuscole è ancora attiva e si trova ancora nello stato Bloc maiuscole. Non è sincronizzato con lo stato della chiave di blocco della sessione desktop remoto.

Note

La funzionalità di Word che attiva questo problema è denominata utilizzo accidentale corretto della chiaveLOCK CAP nelle opzioni di correzione automatica.

In una sessione desktop remoto in un computer basato su Windows Server 2008 R2, se si eseguono gli stessi passaggi, il tasto Bloc maiuscole sulla tastiera fisica del client disattiva anche lo stato, che viene sincronizzato con la sessione desktop remoto.

Causa

Questo problema si verifica perché Windows Server 2012 e Windows Server 2012 R2 usano il dispositivo da tastiera desktop remoto per gestire gli input della tastiera nelle sessioni desktop remoto.

Risoluzione

Per rendere di nuovo la sincronizzazione della chiave di blocco del client e della sessione desktop remoto, è necessario ridurre al minimo la finestra della sessione desktop remoto o fare clic sul mouse all'esterno della finestra della sessione desktop remoto e quindi fare di nuovo clic su di esso.

Per app Office licazioni, è possibile disabilitare l'utilizzo accidentale corretto della chiave LOCK cAPs nelle opzioni di correzione automatica per risolvere il problema. Ad esempio, seguire questa procedura per Word 2016.

  1. Avviare Word 2016, selezionare FILE e quindi opzioni.
  2. Selezionare Correzione.
  3. Selezionare il pulsante Opzioni correzione automatica.
  4. Deselezionare la casella di controllo Correggere l'utilizzo accidentale della chiave LOCK CAPs.
  5. Seleziona OK.