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Questo articolo fornisce informazioni utili per risolvere un problema a causa del quale il query user
comando non esegue query sulle informazioni da un server remoto.
Numero KB originale: 235567
Sintomi
Quando si usa il comando utente di query per ottenere informazioni da un server remoto, segnala che l'utente non esiste.
Ad esempio:
query user username /server:remoteserver
Potrebbe essere visualizzato anche l'errore seguente:
Nessun utente esiste per il nome utente
Causa
Questo problema si verifica quando si usa il query user
comando e si specifica un nome utente. Il comando Query presuppone che sia locale e che esamini solo il server locale per l'utente.
L'uso query user /SERVER:REMOTESERVER
di segnala queste informazioni, ma elenca tutti gli utenti attualmente connessi al server remoto.
Risoluzione
Per risolvere questo problema, ottenere il Service Pack più recente per Windows NT Server 4.0, Terminal Server Edition.
Soluzione alternativa
Per risolvere questo problema, usare uno dei metodi seguenti:
Eseguire una query sul server remoto e non digitare il nome utente. Questo comando elenca tutti gli utenti in tale server.
query user / server:remoteserver
Per ottenere un elenco con un singolo utente, è possibile inviare l'output del comando precedente tramite find:
query user / server:remoteserver | find "username"
Creare un file batch per eseguire una query per un singolo utente.
Batch File Name: Q.bat
Digitare il testo seguente nel file batch e quindi salvare il file:query user / server :%1 | find "%2"
Digitare quanto segue al prompt dei comandi:q remoteserver username
Note
REMOTESERVER e USERNAME sono i rispettivi server e utente su cui si sta tentando di eseguire una query.
Stato
Microsoft ha confermato che si tratta di un problema in Microsoft Windows NT Server versioni 4.0, 4.0 SP, Terminal Server Edition.
Questo problema è stato corretto per la prima volta in Windows NT Server 4.0, Terminal Server Edition, Service Pack 5.