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Questo articolo fornisce una soluzione alternativa per un problema per cui non è possibile installare un driver VMWare in un server che esegue Windows Server 2008 R2 e che dispone del servizio Telnet Server installato.
Si applica a: Windows Server 2008 R2 Service Pack 1
Numero KB originale: 3066752
Sintomi
Prendi in considerazione lo scenario seguente:
- In un computer che esegue Windows Server 2008 R2, si aggiunge una scheda Ethernet a un ambiente VMWare vSphere.
- Il servizio Telnet Server è installato.
- Nello snap-in Servizi di Microsoft Management Console (MMC) si configura il servizio Telnet Server per l'avvio manuale o automatico.
- Nello snap-in Servizi configurare il servizio Telnet Server per l'accesso tramite l'account di sistema locale. Inoltre, non selezionare la casella di controllo Consenti al servizio di interagire con desktop .
In questo scenario, quando si tenta di installare il driver tramite Gestione dispositivi, il tentativo ha esito negativo e viene visualizzato il messaggio di errore seguente:
Windows ha trovato il software driver per il dispositivo ma ha rilevato un errore durante il tentativo di installarlo.
Dopo che si verifica l'errore di installazione, si tenta di installare un'altra scheda Ethernet disponibile dall'elenco Impostazioni macchina virtuale. Ad esempio, si seleziona Intel E1000. Tuttavia, anche il secondo driver non viene installato. Inoltre, una voce di log simile alla seguente viene registrata in Setupapi.dev.log in %windir%/inf/:
dvi: {Servizio Plug and Play: Installazione del dispositivo per PCI\VEN_15AD&DEV_07B0&SUBSYS_07B015AD&REV_01\FF565000B37984FE00}
ump: Creazione del processo di installazione: DrvInst.exe <DateTime>
ump: Processo di installazione del server chiuso con codice 0xc0000142 <DateTime>
ump: {Plug and Play Service: Device Install exit(c0000142)}
ndv: Installazione del dispositivo non riuscita per il nuovo dispositivo... installazione del driver NULL.
dvi: {Servizio Plug and Play: Installazione del dispositivo per PCI\VEN_15AD&DEV_07B0&SUBSYS_07B015AD&REV_01\FF565000B37984FE00}
Causa
Questo problema si verifica perché il servizio Telnet Server apporta alcune modifiche alle autorizzazioni correlate alla sicurezza durante l'inizializzazione alla stazione finestra in cui è in esecuzione. Se si configura il servizio Telnet Server per l'esecuzione usando l'account di sistema locale senza la possibilità di interagire con il desktop, il servizio viene avviato in un'altra stazione finestra. Ciò può causare conflitti con altri processi eseguiti anche con l'account di sistema locale e che non interagiscono con il desktop, ad esempio il processo di installazione per un nuovo driver di dispositivo.
Soluzione alternativa
Per risolvere questo problema, non eseguire il servizio Telnet Server nell'account di sistema locale. È consigliabile lasciare il servizio Telnet Server da eseguire con l'account del servizio locale predefinito.
Se il problema non viene temporaneamente risolto, verificare che sia installata la versione più recente di VMWare Tools. Se non è possibile aggiornare o disinstallare gli strumenti VMWare, seguire questa procedura:
Ottenere i file di installazione per la versione più recente di VMWare Tools.
Fare clic su Start, digitare cmd nella casella Avvia ricerca e quindi fare clic su OK.
Nota
Verrà visualizzata una finestra del prompt dei comandi.
Al prompt dei comandi modificare l'unità nell'unità CD-ROM, ad esempio unità D.
Digitare
setup /c
e quindi premere INVIO per forzare la rimozione di tutte le voci del Registro di sistema ed eliminare le versioni precedenti di VMware Tools.Nota
Per i sistemi operativi guest a 64 bit, digitare invece setup64 /c.
Installare la versione più recente di VMWare Tools.
Verificare che l'impostazione di accesso al servizio Telnet sia impostata correttamente.
Riavviare il server.
Raccolta dati
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