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Errore "Accesso negato" quando si usa l'Utilità di pianificazione

Quando si usa Utilità di pianificazione, viene visualizzato il messaggio di errore seguente:

Accesso negato. L'account utente non dispone delle autorizzazioni per eseguire questa attività.

Causa

Il problema si verifica a causa di uno dei motivi seguenti:

  • L'account utente usato per eseguire l'attività non dispone dei privilegi amministrativi necessari.
  • Le autorizzazioni per la cartella C:\Windows\System32\Tasks sono state modificate.
  • L'attività è configurata per l'esecuzione con un set specifico di credenziali che differiscono dall'account utente corrente.

Nota

Se ci si connette a un host remoto usando mmc.exe con lo snap-in dell'Utilità di pianificazione o la console taskschd.msc usando un account normale, si prevede che venga visualizzato un errore di accesso negato. Solo gli account che fanno parte del gruppo Administrators locale o del gruppo Domain Administrators possono gestire in remoto un sistema. Per motivi di sicurezza, un utente non amministratore non può visualizzare o gestire un'attività utilità di pianificazione di Windows creata da un altro utente. Per altre informazioni, vedere Novità dell'Utilità di pianificazione.

Risoluzione

Per risolvere questo problema, utilizzare uno dei seguenti metodi.

Eseguire l'Utilità di pianificazione come amministratore

Fare clic con il pulsante destro del mouse su Utilità di pianificazione e selezionare Esegui come amministratore. Questo approccio può spesso risolvere i problemi di accesso.

Controllare le autorizzazioni dell'account utente

Assicurarsi che l'account utente in uso disponga delle autorizzazioni necessarie per eseguire l'attività. Potrebbe essere necessario aggiungere l'account utente al gruppo Administrators.

Modificare le proprietà delle attività

  1. Aprire Utilità di pianificazione, trovare l'attività che causa il problema, fare clic con il pulsante destro del mouse e selezionare Proprietà.
  2. Passare alla scheda Generale e selezionare Esegui con privilegi più elevati.

Controllare le impostazioni di Criteri di gruppo

  1. Aprire l'Editor Criteri di gruppo digitando gpedit.msc nella casella Esegui .
  2. Passare a Configurazione>computer Impostazioni di Windows Impostazioni>di sicurezza Criteri>>locali Assegnazione diritti utente.
  3. Assicurarsi che l'account utente disponga del diritto Di accesso come processo batch .

Reinizializzazione manuale delle attività

  1. Esportare l'attività problematica in un file XML prima di eliminarla. A tale scopo, eseguire il comando seguente:

    Export-ScheduledTask -TaskName "<task_name>" -FilePath "<backup_xml_file_path>"
    
  2. Reimportare l'attività dopo le correzioni del Registro di sistema/file:

    Register-ScheduledTask -Xml (Get-Content "<backup_xml_file_path>" | Out-String) -TaskName "<task_name>"