Nota
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare ad accedere o modificare le directory.
L'accesso a questa pagina richiede l'autorizzazione. È possibile provare a modificare le directory.
Questo articolo fornisce informazioni utili per risolvere un problema a causa del quale il caricamento del profilo ha esito negativo quando il file ntuser.dat o usrclass.dat è definito in sola lettura oppure l'utente del profilo non dispone delle autorizzazioni appropriate per questi due file .dat.
Numero KB originale: 3048895
Sintomi
Dopo aver installato l'aggiornamento in Vulnerabilità nel servizio profili utente di Windows, è possibile consentire l'elevazione dei privilegi: 13 gennaio 2015 (MS15-003), si verificano i problemi seguenti:
I profili non vengono caricati quando gli utenti accedono a un computer per la prima volta. In alternativa, si accede a un computer in cui i criteri eliminano il profilo memorizzato nella cache dopo un intervallo di date al momento della disconnessione.
Note
Gli accessi che usano profili utente obbligatori o VDI (Virtual Desktop Infrastructure) possono essere interessati anche.
I profili non vengono caricati quando gli utenti accedono usando i profili utente memorizzati nella cache.
I servizi non vengono avviati a causa di errori di caricamento del profilo. I servizi interessati includono, ma non sono limitati ai seguenti:
- Servizio locale
- Network Service (Servizio di rete)
- MSSQL
Quando si verifica questo problema, vengono registrati eventi correlati. Visualizzare gli eventi registrati Visualizzatore eventi.
Monitoraggio processi può indicare che un'operazione CreateFile non riesce con un risultato DI ACCESSO NEGATO al percorso seguente, a seconda del modo in cui l'accesso ai file è vincolato:< unità>:\documents & settings\<username>\local settings\Application Data\Microsoft\Windows\UsrClasss.dat.
Lo screenshot di Monitoraggio processi è disponibile qui:
Vedere Dettagli dell'errore visualizzato in Monitoraggio processi.
Causa
L'aggiornamento 3021674 aggiunge i controlli per l'accesso alle Ntuser.dat e ai file di Usrclass.dat.
Risoluzione
Per risolvere il problema, seguire questa procedura:
Controllare se il flag READ ONLY è impostato su NTUSER. DAT o USERCLASS. File DAT per il profilo che non viene caricato.
I nuovi profili utente sono derivati da C:\users\default\ durante gli accessi all'account per la prima volta. Se i profili non vengono caricati con firme corrispondenti a quelle descritte nella sezione "Sintomi", verificare se il bit di sola lettura è abilitato in NTUSER. DAT e USRCLASS. File DAT nella directory del profilo per gli utenti o gli account del servizio in questione.
NTUSER. DAT in Windows Vista e versioni successive di Windows si trova in C:\users\default\ntuser.dat. I sistemi operativi precedenti hanno altri percorsi, ad esempio C:\Documents and Settings\<username>\ntuser.dat.
The USRCLASS. Il file DAT si trova in genere lungo un percorso come C:\Documents and Settings<user_name>\Local Settings\Application Data\Microsoft\Windows\UsrClass.dat o C:\Users<user_name>\AppData\Local\Microsoft\Windows.
In Esplora risorse fare clic con il pulsante destro del mouse su NTUSER. File DAT o USRCLASS per l'utente predefinito pertinente o il profilo utente memorizzato nella cache. La casella di controllo Sola lettura deve essere deselezionata. Se questa casella di controllo è selezionata, causerà errori di caricamento del profilo.
Controllare l'impostazione delle autorizzazioni del file system NTFS in NTUSER. DAT o USERCLASS. File DAT nella directory del profilo memorizzato nella cache che non viene caricato.
Nello screenshot seguente l'utente di test, CONTOSO/testUser, ha il controllo completo su NTUSER. DAT (non visualizzato) e USRCLASS.DAT. Tutti gli utenti non sono elencati nel gruppo Editor ACL.
ACLS del file system NTFS nei file DAT | ACLS del file system NTFS avanzato nei file DAT |
---|---|
![]() |
![]() |
Stato
Microsoft ha confermato che questo problema si verifica nei prodotti elencati nella sezione "Si applica a".
Ulteriori informazioni
Eventi registrati in Visualizzatore eventi
Nome log | Mittente dell'evento | ID evento | Testo del messaggio di evento |
---|---|---|---|
Applicazione | Servizio Profili utente Microsoft-Windows | 1542 | Windows non può caricare il file del Registro di sistema delle classi. DETTAGLI - Errore non specificato Die Klassenregistrierungsdatei kann nicht geladen werden. DETAIL - Unbekannter Fehler |
Applicazione | Gestione controllo servizi | 7005 | La chiamata a LoadUserProfile non è riuscita con l'errore seguente: Impossibile trovare il file specificato. |
Applicazione | Gestione controllo servizi | 7024 | Il servizio SQL Server (MSSQLSERVER) terminato con un errore specifico del servizio 2148081668 (0x80092004). |
Applicazione | Userenv | 1500 | Impossibile accedere a Windows perché non è possibile caricare il profilo. Verificare di essere connessi alla rete o che la rete funzioni correttamente. Se il problema persiste, contattare l'amministratore di rete. DETAIL: il sistema non riesce a trovare il file specificato. |
Applicazione | Userenv | 1502 | Windows non può caricare il profilo archiviato in locale. Le possibili cause di questo errore includono diritti di sicurezza insufficienti o un profilo locale danneggiato. Se il problema persiste, contattare l'amministratore di rete. |
Dettagli dell'errore visualizzato in Monitoraggio processi
Dettagli di ProMonIl messaggio seguente viene visualizzato in Monitoraggio processi:
Accesso desiderato: Generic Read/Write, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: H, ShareMode: Read, Write, AllocationSize: n/a, Impersonating: <SID>
Lo screenshot seguente mostra i dettagli di Monitoraggio processi: