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Questo articolo illustra come correggere l'errore "Impossibile verificare le credenziali" che si verifica quando si tenta di accedere a Windows con Windows Hello for Business (WHFB).
Si applica a: Windows 10, Windows 11
Numero KB originale: 4519735
Sintomo
Quando si tenta di accedere a un dispositivo Windows 10 o Windows 11 usando un certificato WHFB o un trust della chiave, l'accesso ha esito negativo con uno dei messaggi di errore seguenti:
Impossibile verificare le credenziali
Si è verificato un problema e il PIN non è disponibile (stato: 0xc00000bb, substatus:0x0). Fare clic per configurare di nuovo il PIN.
Causa
Questo problema si verifica perché il certificato dell'autorità di certificazione (CA) emittente non è presente nell'archivio NTAuth del controller di dominio e del computer client.
Quando si usa WHFB, il controller di dominio deve convalidare il certificato inviato dal computer client. Durante la convalida, controlla il servizio Centro distribuzione chiavi (KDC) nel controller di dominio per verificare se è in grado di trovare il certificato CA emittente nella chiave del Registro di sistema NTAuth. La chiave del Registro di sistema NTAuth individua in HKLM\Software\Microsoft\EnterpriseCertificates\NTAuth\Certificates
.
Note
La chiave del Registro di sistema EnterpriseCertificates è una posizione in Active Directory. Durante un aggiornamento di Criteri di gruppo, questi certificati vengono importati nel Registro di sistema da tutti i computer client, i membri e i controller di dominio nella foresta.
Come identificare il problema
- Aprire lo snap-in Autorità di certificazione.
- Fare clic con il pulsante destro del mouse sul server CA emittente e scegliere Proprietà.
- Passare alla scheda Generale e selezionare i certificati correnti se sono presenti più certificati e quindi selezionare Visualizza certificato.
- Passare alla scheda Dettagli e scorrere verso il basso fino all'attributo Identificazione personale .
- Annotare l'identificazione personale del certificato CA emittente.
- Aprire il Registro di sistema nel controller di dominio e passare a
HKLM\Software\Microsoft\EnterpriseCertificates\NTAuth\Certificates
. - Verificare se nella chiave del Registro di sistema precedente è presente una cartella con il valore di identificazione personale.
Risoluzione
Aprire lo snap-in Autorità di certificazione.
Fare clic con il pulsante destro del mouse sul server CA emittente e scegliere Proprietà.
Passare alla scheda Generale e selezionare i certificati correnti se sono presenti più certificati e quindi selezionare Visualizza certificato.
Esportare il certificato usando l'opzione Copia in file . E salvarlo come file, ad esempio IssuingCA.cer.
Accedere usando le credenziali di amministratore dell'organizzazione in un controller di dominio ed eseguire il comando seguente:
certutil -dspublish -f IssuingCA.cer NTAuthCA certutil -enterprise -addstore NTAuth IssuingCA.cer
Eseguire
gpupdate /force
e verificare che l'identificazione personale della CA emittente venga creata in questo hive del Registro di sistema,HKLM\Software\Microsoft\EnterpriseCertificates\NTAuth\Certificates
.Attendere il completamento della replica di Active Directory.
Eseguire
gpupdate /force
anche nei computer client e assicurarsi che l'identificazione personale del certificato CA emittente venga creata nei computer client.