Librerie necessarie

Elenco di file con estensione lib necessari per compilare varie applicazioni TAPI 3, a partire dal 1/22/01:

  • Advapi32.lib
  • Amstrmid.lib (GUID ActiveMovie)
  • Kernel32.lib
  • Mdhcpid.lib (GUID multicast)
  • Ole32.lib (COM)
  • Oleaut32.lib (Automazione COM)
  • Rendid.lib (GUID rendezvous)
  • Rpcndr.lib
  • Rpcns4.lib
  • Rpcrt4.lib
  • GUID (SDPblbid.lib) (GUID del descrittore di sessione)
  • Strmiids.lib
  • User32.lib
  • Uuid.lib
  • Wldap32.lib
  • Ws2_32.lib

Se si usa Microsoft Visual Studio, potrebbe essere necessario aggiornare la versione. In particolare, Link.exe deve contenere una data di 3/19/98 o successiva.

Le definizioni del compilatore devono includere _WIN32_WINNT impostate su almeno 0x500 e _WIN32_DCOM.