エラー SSPR_009のトラブルシューティング: 同期Microsoft Entra管理者がクラウドからパスワードをリセットできない

この記事では、Microsoft Entra管理者ロールを持つ同期されたユーザーがパスワードのリセットに失敗したときに発生するパスワード リセット エラーのトラブルシューティング方法について説明します。

このシナリオは、ユーザーが でサインイン ページhttps://login.microsoftonline.comにアクセスし、[アカウントにアクセスできません]、[パスワードを忘れた場合]、または [今すぐリセット] を選択した後に発生します。 次に、ブラウザーは、 のセルフサービス パスワード リセット (SSPR) ページ https://passwordreset.microsoftonline.com にユーザーをリダイレクトして、SSPR プロセスを開始します。 このプロセスでは、ユーザーが "captcha" コードを入力する必要があります。 操作が成功した場合、パスワード ライトバックはユーザーのパスワード リセット要求をオンプレミスの Active Directory ドメインに送信します。 同時に、SSPR は新しいパスワードをMicrosoft Entra IDに設定します。 操作が失敗した場合は、代わりに "SSPR_009" エラーが返されます。 エラーが発生した場合は、この記事を使用して問題を解決してください。

現象

同期されたユーザーが captcha コードを入力してパスワードのリセットに失敗すると、ブラウザーに次のエラー メッセージが表示されます。

organizationに対してパスワードのリセットが有効になっていないため、自分のパスワードをリセットできません。

SSPR_009: organizationがパスワード リセットを有効にしていません。 管理者の場合は、「 パスワード リセットを有効にする方法」 の記事から詳細情報を取得できます。 管理者でない場合は、管理者に連絡するときにこの情報を提供できます。

注:

このシナリオは、Microsoft Entra管理者ロールが割り当てられているMicrosoft Entraユーザーに対してのみ発生します。 パスワードの変更またはリセット フローは、標準アカウントで想定どおりに機能します。

原因

管理者向けの SSPR は、テナントで有効になっていません。 SSPR for Administrators (SSPR-A) は、SSPR の最初の実装でした。 SSPR for Users (SSPR-U) が導入された後、ユーザーは 2 つの個別の構成を持つことができます。

古い SSPR-A 実装は、Microsoft Entra アカウントにグローバル管理者や課金管理者などの管理者ロールがある場合に使用されます。 ただし、Azure portalの SSPR 管理は SSPR-U 専用です。 そのため、テナントで SSPR-A が有効になっていない可能性があります。

ソリューション

次のように Set-MsolCompanySettings PowerShell コマンドレットを実行して、テナントで SSPR-A を有効にします。

Set-MsolCompanySettings -SelfServePasswordResetEnabled $true

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