Microsoft Entra接続をアップグレードするときにエラーが発生する: 同期サービスをインストールできません

元の製品バージョン: Office 365 Identity Management、Microsoft Entra ID
元の KB 番号: 4054462

現象

Connect Microsoft Entraアップグレードしようとすると、次のエラー メッセージが表示されます。

Azure Active Directory Sync からのアップグレード中にエラーが発生しました。同期サービスをアップグレードできません。 詳細については、イベント ログを参照してください。

詳細なイベント ログは次のようになります。

Date/Time[ 12] [INFO ] ServiceControllerProvider: StartService status: Running Date/Time[ 12] [ERROR] Error during sync engine upgrade. System.Exception: 同期サービスをアップグレードできません。 詳細については、イベント ログを参照してください。 >--- Microsoft.Azure.ActiveDirectory.Client.Framework.ProcessExecutionFailedException: msi パッケージ 'Synchronization Service.msi' のインストール中にエラーが発生しました。 完全なログは、'C:\ProgramData\AADConnect\Synchronization Service_Install-DateTime.log' で使用できます。

アクション startTime: DetectServiceAccount。 CustomAction DetectServiceAccount は、実際のエラー コード 1603 を返しました (サンドボックス内で翻訳が行われる場合、これは 100% 正確ではない可能性があります) Action endedTime: DetectServiceAccount。 戻り値 3。 action endedTime: INSTALL。 戻り値 3。 MSI (秒) (14:AC)時間: 注: 1: 1708 MSI (s) (14:AC)時間: 製品: Microsoft Entra接続同期サービス -- インストール操作に失敗しました。 MSI (s) (14:AC)Time: Windows インストーラーによって製品がインストールされました。 製品名: 同期サービスMicrosoft Entra接続します。 製品バージョン: 1.1.614.0。 製品言語: 1033。 製造元: Microsoft Corporation。 インストールの成功またはエラーの状態: 1603。 MSI (秒) (14:AC)時間: パッケージ/ファイルのクリーンを延期します(存在する MSI (14:AC)時間: MainEngineThread から 1603 MSI (秒) (14:80)時間: RESTART MANAGER: セッションが終了しました。

原因

基になるサービス アカウントは、Domain\SamAccountName ではなくユーザー プリンシパル名 (UPN) を使用して構成されました。

解決方法

この問題を解決するには、次の手順を実行します。

  1. Microsoft Entra Connect サーバーでサービス コンソールを起動します。
  2. Microsoft Azure AD同期サービスを見つけて、サービスを右クリックします。
  3. [ プロパティ] を選択し、[ ログオン] を選択します。
  4. UPN を使用するのではなく、Domain\SamAccountName を使用してアカウントを設定します。
  5. [ 適用] を選択し 、[OK] を選択します

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