Microsoft Flow にサインインできず、"認証に失敗しました" というエラーが表示される
この記事では、Microsoft Flow にサインインしようとしたときに 認証失敗 エラーが発生する問題の解決策について説明します。
適用先:Power Automate
元の KB 番号: 4316891
現象
Microsoft Flow にサインインしようとすると、次のような 認証失敗 エラー メッセージが表示されます。
メッセージ内の URL は、次のようになります。
https://flow.microsoft.com/AuthenticationFailed/?message=AADSTS50001%3a+Resource+%27https%3a%2f%2fservice.flow.microsoft.com%2f%27+is+disabled
この URL は、テナントがこの問題の影響を受けるかどうかを示します。
原因
この問題は、テナントで最後の Flow ライセンス (または Flow を含む Office ライセンス) の有効期限が切れた場合に発生します。 この状況では、Azure Active Directory (Azure AD) で Flow サービスが無効になります。
この動作はほとんどのアプリケーションに適していますが、関連するライセンスがテナント内に存在する場合は、Flow へのアクセスもブロックされます。ただし、Flow はライセンスなしで無料で使用できます。
ライセンスの有効期限が切れたため、アクセスが自動的に無効になっているアプリケーションの一覧からフローが除外されるようになりました。 ただし、既に無効になっているテナントは無効でない状態に戻りません。 このような場合、Flow へのアクセスはブロックされたままになります。
解決方法
この問題を解決するには、次の手順に従います。
注:
これらの手順は、テナント管理者のみが実行できます。
Azure portal) を開き、サインインします。
ナビゲーション バーで、Azure Active Directory 設定を開きます。
エンタープライズ アプリケーションのすべてのアプリケーション>に移動します。
フィルター入力に 7df0a125-d3be-4c96-aa54-591f83ff541c を貼り付けます。
注:
これは、Flow サービスのアプリケーション ID です。 [表示] ボックスの一覧で [すべてのアプリケーション] を選択する必要がある場合があります。
Microsoft Flow Service を選択し、[プロパティ] を選択します。
[ ユーザーのサインインを有効にする ] オプションが [はい] に設定されていることを確認します。
[保存] を選択します。
これで、すべてのユーザーがフロー ポータルにもう一度サインインできるようになります。
詳細情報
詳細については、またはこれらの手順に関する問題について Flow チームに問い合わせるには、「 既知の問題: ログインの問題」を参照してください。