Microsoft Flow にサインインできません。"認証に失敗しました" というエラーが表示される

この記事では、Microsoft Flow へのサインイン時に 認証に失敗した エラーが発生する問題の解決策について説明します。

適用先:Power Automate
元の KB 番号: 4316891

現象

Microsoft Flow にサインインしようとすると、次のような 認証に失敗した エラー メッセージが表示されます。

Flow にサインインするときのエラー ページのスクリーンショット。

メッセージ内の URL は次のようになります。

https://flow.microsoft.com/AuthenticationFailed/?message=AADSTS50001%3a+Resource+%27https%3a%2f%2fservice.flow.microsoft.com%2f%27+is+disabled

この URL は、テナントがこの問題の影響を受けるかどうかを示します。

原因

この問題は、最後の Flow ライセンス (または Flow を含む Office ライセンス) がテナントで期限切れになったときに発生します。 この状況では、フロー サービスはMicrosoft Entra IDで無効になります。

この動作はほとんどのアプリケーションに適していますが、Flow はライセンスなしで無料で使用できますが、関連するライセンスがテナントに存在する場合にも Flow へのアクセスをブロックします。

ライセンスが期限切れのため、アクセスが自動的に無効になっているアプリケーションの一覧からフローが除外されるようになりました。 ただし、既に無効になっているテナントは、無効になっていない状態に戻されません。 このような場合、Flow へのアクセスはブロックされたままです。

解決方法

この問題を解決するには、次の手順に従います。

注:

これらの手順は、テナント管理者のみが実行できます。

  1. Azure portal) を開き、サインインします。

  2. ナビゲーション バーで、[Microsoft Entra設定] を開きます。

    ナビゲーション バーの [Microsoft Entra設定] アイコンのスクリーンショット。

  3. [エンタープライズ アプリケーション] [すべてのアプリケーション] > に移動します。

    [エンタープライズ アプリケーション] 項目を選択した後、[すべてのアプリケーション] 項目を選択するスクリーンショット。

  4. 7df0a125-d3be-4c96-aa54-591f83ff541c をフィルター入力に貼り付けます。

    注:

    これは Flow サービスのアプリケーション ID です。 [表示] ボックスの一覧で [すべてのアプリケーション] を選択する必要がある場合があります。

    7df0a125-d3be-4c96-aa54-591f83ff541c をフィルター入力に貼り付けるスクリーンショット。

  5. [ Microsoft Flow Service] を選択し、[プロパティ] を選択 します

  6. [ ユーザーがサインインできるようにする ] オプションが [ はい] に設定されていることを確認します。

    [ユーザーのサインインが有効] フィールドが [はい] に設定されていることをチェックするスクリーンショット。

  7. [保存] を選択します。

これで、すべてのユーザーが Flow ポータルに再度サインインできるようになります。

詳細

詳細については、またはフロー チームに問い合わせて、これらの手順に関する問題については、「 既知の問題: ログインの問題」を参照してください。