ドメイン資格情報を使用したSQL Server サービスの開始に失敗する

この記事では、スタートアップ アカウントに必要なアクセス許可がない場合SQL Server起動に失敗する問題について説明します。

元の製品バージョン: SQL Server
元の KB 番号: 3006856

現象

SQL Server サービスを開始または再起動しようとすると失敗し、次のメッセージがSQL Serverエラー ログに記録されます。

<Time stamp> spid9s Error: 17182, Severity: 16, State: 1.

<Time stamp> spid9s TDSSNIClient initialization failed with error 0xffffffff, status code 0x80. Reason: Unable to initialize SSL support.

<Time stamp> spid9s Error: 17182, Severity: 16, State: 1.

<Time stamp> spid9s TDSSNIClient initialization failed with error 0xffffffff, status code 0x1. Reason: Initialization failed with an infrastructure error. Check for previous errors.

<Time stamp> spid9s Error: 17826, Severity: 18, State: 3. Time stamp spid9s Could not start the network library because of an internal error in the network library. To determine the cause, review the errors immediately preceding this one in the error log.

<Time stamp> spid9s Error: 17120, Severity: 16, State: 1. Time stamp spid9s SQL Server could not spawn FRunCommunicationsManager thread. Check the SQL Server error log and the Windows event logs for information about possible related problems.

注:

この問題は、ドメイン アカウントで実行されるSQL Server インスタンスでのみ発生します。

原因

この問題は、SQL Service アカウントに付与される通常のアクセス許可がないために発生します。 存在する必要があるSQL Serverスタートアップ アカウントのユーザー権限は次のとおりです。

  • プロセスのメモリ クォータを調整 します (SeIncreaseQuotaPrivilege)。

  • 走査チェックをバイパス します (SeChangeNotifyPrivilege)。

  • サービスとしてログオンします (SeServiceLogonRight)。

  • プロセス レベルのトークン (SeAssignPrimaryTokenPrivilege) を置き換えます。

詳細については、「 サービスのアクセス許可」を参照してください。

解決方法

この問題を解決するには、ローカル セキュリティ ポリシー MMC スナップインの [ユーザー権利の割り当て] ウィンドウを使用して、不足しているアクセス許可を SQL Service ドメイン アカウントに付与します。