BITS サービスを開始しようとする場合2147944102"サービス固有のエラー コード -2147944102" エラー メッセージ

この記事では、バックグラウンド インテリジェント転送サービス (BITS) サービスを2147944102発生するエラー の解決方法について説明します。

適用対象:  Windows Server 2012R2
元の KB 番号:   326460

現象

ターミナル サービスがインストールされている Windows 2000 ベースのコンピューターで BITS サービスを開始すると、次のような現象が発生する可能性があります。

  • 次のいずれかのエラー メッセージが表示されます。

    Windowsコンピューターでバックグラウンド インテリジェント転送サービスを開始できません。 詳細については、「System Event Log」を参照してください。 Microsoft 以外のサービスの場合は、サービス ベンダーに問い合わせ、サービス固有のエラー コード -2147023194。

    または

    サービス固有のエラーが発生しました:-2147944102。

  • 次のイベントは、イベント ビューアーのシステム ログWindows NT記録されます。

    イベントの種類: エラー
    イベント ソース: Service Control Manager
    イベント カテゴリ: なし
    イベント ID: 7024
    ユーザー: N/A
    説明: バックグラウンド インテリジェント転送サービス サービスは、サービス固有のエラー メッセージで終了2147944102。

原因

この動作は、ターミナル サービス サービスが無効になっている場合に発生することがあります。

既定では、ターミナル サービス コンポーネントがインストールされている場合、ターミナル サービス サービスのスタートアップの種類は [自動] に設定されます。 管理者がサービスのスタートアップの種類を [無効] に変更しても、BITS サービスは開始されません。

解決方法

この問題を解決するには、Microsoft 2000 の最新のサービス Windows入手します。

回避策

この問題を回避するには、(状況に応じて) 次のいずれかの方法を使用します。

方法 1: ターミナル サービスを自動的に開始する構成

ターミナル サービス サービスを自動的に開始する構成するには、次の手順を実行します。

  1. [スタート] ボタンをクリックし、[設定] をポイントして、[コントロール パネル] をクリックします。
  2. [管理ツール] をダブルクリック し、[サービス] を ダブルクリックします
  3. 右側のウィンドウで、[ターミナル サービス] を右 クリックし、[プロパティ] を クリックします
  4. [General] タブをクリックします。
  5. [スタートアップの 種類] ボックスで、[自動]をクリックし**、[OK] をクリックします**。

方法 2: ターミナル サービスの削除

ターミナル サービスが必要ない場合、またはサーバーで使用されていない場合は、ターミナル サービスを削除します。 これを行うには、次の手順を実行します。

  1. [スタート] ボタンをクリックし、[設定] をポイントして、[コントロール パネル] をクリックします。
  2. [プログラムの 追加と削除] をダブルクリックします
  3. [Windows コンポーネントの追加と削除] をクリックします。
  4. [コンポーネント のWindows] で、[ターミナル サービス] チェックボックスをオフにし、[次へ] を クリックします
  5. [コンポーネント ウィザードの完了Windows] ページで、[完了] を クリックします
  6. [プログラムの 追加と削除] ウィンドウで 、[閉じる] を クリックします

状態

Microsoft は、この記事の冒頭に記載されている Microsoft 製品の問題を確認しました。 この問題は、Microsoft Windows 2000 Service Pack 4 で最初に修正されました。

詳細

この記事の「現象」セクションに記載されている問題は、Microsoft Software Update Services (SUS) 1.0 または自動更新 2.2 クライアントをターミナル サービスがインストールされた Windows 2000 Server ベースのコンピューターにインストールした後にも発生する可能性があります。