Change Tracking と Inventory に関する問題のトラブルシューティング
重要
Log Analytics エージェントを使用した変更履歴とインベントリは、2024 年 8 月 31 日に廃止され、2025 年 2 月 1 日まで限られた範囲でサポートされます。 新しいサポート エージェントとして Azure Monitoring Agent を使用することをお勧めします。 Log Analytics を使用する変更履歴とインベントリから Azure Monitoring Agent バージョンを使用した変更履歴とインベントリへの移行については、こちらのガイダンスに従ってください。
この記事では、Azure Automation の Change Tracking とインベントリの問題のトラブルシューティングを行い、解決する方法について説明します。 Change Tracking とインベントリの一般的な情報については、「変更履歴とインベントリの概要」を参照してください。
一般エラー
シナリオ:マシンが違うアカウントに既に登録されている
問題
次のエラー メッセージが表示されます。
Unable to Register Machine for Change Tracking, Registration Failed with Exception System.InvalidOperationException: {"Message":"Machine is already registered to a different account."}
原因
マシンが既に Change Tracking 用の別のワークスペースにデプロイされています。
解決方法
マシンが適切なワークスペースにレポートしていることを確認します。 これを確認する方法については、「Azure Monitor へのエージェント接続を確認する」を参照してください。 このワークスペースが Azure Automation アカウントにリンクされていることも確認します。 確認するには、自分の Automation アカウントに移動して、[関連リソース] の [リンクされたワークスペース] を選択します。
Automation アカウントにリンクされた Log Analytics ワークスペースにマシンが表示されることを確認します。 Log Analytics ワークスペースで、次のクエリを実行します。
Heartbeat | summarize by Computer, Solutions
クエリ結果にマシンが表示されない場合は、最近チェックインされていません。 ローカルの構成に問題がある可能性があります。 Log Analytics エージェントを再インストールする必要があります。
コンピューターがクエリ結果に一覧表示されている場合は、Solutions プロパティの下に changeTracking が一覧表示されていることを確認します。 これにより、変更履歴とインベントリに登録されていることを確認できます。 そうでない場合は、スコープ構成に問題がないかどうかを確認します。 スコープの構成では、変更履歴とインベントリ用に構成されるマシンが決定されます。 ターゲット コンピューターのスコープ構成を構成するには、「Automation アカウントで変更履歴とインベントリを有効にする」を参照してください。
ワークスペースで、次のクエリを実行します。
Operation | where OperationCategory == 'Data Collection Status' | sort by TimeGenerated desc
Data collection stopped due to daily limit of free data reached. Ingestion status = OverQuota
という結果が表示される場合、ワークスペースに定義されたクォータに達したため、データの保存が停止されています。 ワークスペースで、[使用量と推定コスト] に移動します。 より多くのデータを使用できる新しい価格レベル を選択するか、[日次上限] をクリックして上限を削除します。
問題が解決しない場合は、「Windows Hybrid Runbook Worker をデプロイする」の手順に従って、Windows 用のハイブリッド worker を再インストールしてください。 Linux の場合は、「Linux Hybrid Runbook Worker を展開する」の手順に従います。
Windows
シナリオ: Windows マシンに変更履歴とインベントリのレコードが表示されない
問題
Windows マシンで Change Tracking とインベントリが有効であるのに、この機能の結果が表示されません。
原因
このエラーには次の原因が考えられます。
- Windows 用 Azure Log Analytics エージェントが実行されていないません。
- Automation アカウントに戻る通信がブロックされています。
- Change Tracking と Inventory 用の管理パックがダウンロードされていません。
- 有効になっている VM の複製元が、Windows 用の Log Analytics エージェントがインストールされた状態でシステム準備 (sysprep) を使用して準備されなかった複製マシンである可能性があります。
解決方法
Log Analytics エージェント マシン上で C:\Program Files\Microsoft Monitoring Agent\Agent\Tools に移動し、次のコマンドを実行します。
net stop healthservice
StopTracing.cmd
StartTracing.cmd VER
net start healthservice
それでもサポートが必要な場合は、診断情報を収集して、サポートにお問い合わせください。
Note
既定では、Log Analytics エージェントによってエラー トレースが有効になります。 前の例のように詳細なエラー メッセージを有効にするには、VER
パラメーターを使用します。 情報トレースの場合は、StartTracing.cmd
を呼び出すときに INF
を使用します。
Windows 用 Log Analytics エージェントが実行されていない
Windows 用 Log Analytics エージェント (HealthService.exe) がマシン上で実行されていることを確認します。
Automation アカウントへの通信がブロックされる
マシン上でイベント ビューアーをチェックして、changetracking
という単語が含まれているイベントを探します。
Change Tracking とインベントリを動作させるために許可する必要があるアドレスとポートについては、「ネットワークを構成する」を参照してください。
管理パックがダウンロードされていない
Change Tracking とインベントリの次の管理パックがローカルにインストールされていることを確認します。
Microsoft.IntelligencePacks.ChangeTrackingDirectAgent.*
Microsoft.IntelligencePacks.InventoryChangeTracking.*
Microsoft.IntelligencePacks.SingletonInventoryCollection.*
sysprep されていない複製マシンの VM
複製されたイメージを使用する場合は、まずイメージを sysprep し、次に Windows 用 Log Analytics エージェントをインストールします。
Linux
シナリオ: Linux マシン上に変更履歴とインベントリの結果がない
問題
Linux マシンで Change Tracking とインベントリが有効であるのに、この機能の結果が表示されません。
原因
この問題には次のような原因が考えられます。
- Linux 用 Log Analytics エージェントが実行されていません。
- Linux 用 Log Analytics エージェントが正しく構成されていません。
- ファイルの整合性の監視 (FIM) の競合があります。
解決方法
Linux 用 Log Analytics エージェントが実行されていない
Linux 用 Log Analytics エージェント (omsagent) のデーモンがマシン上で実行されていることを確認します。 自分の Automation アカウントにリンクされた Log Analytics ワークスペースで、次のクエリを実行します。
Heartbeat
| summarize by Computer, Solutions
クエリ結果にマシンが表示されない場合は、最近チェックインされていません。 ローカルの構成に問題がある可能性があるため、エージェントを再インストールする必要があります。 インストールと構成の詳細については、「Log Analytics エージェントを使用してログ データを収集する」を参照してください。
マシンがクエリ結果に表示される場合は、スコープの構成を確認します。 「Azure Monitor での監視ソリューションのターゲット設定」を参照してください。
この問題のトラブルシューティングについて詳しくは、「問題: Linux データが表示されない」をご参照ください。
Linux 用 Log Analytics エージェントが正しく構成されていない
Linux 用 Log Analytics エージェントは、OMS Log Collector ツールを使用したログおよびコマンド ライン出力収集用に正しく構成されていない可能性があります。 「変更履歴とインベントリの概要」を参照してください。
FIM の競合
Microsoft Defender for Cloud の FIM 機能で、Linux ファイルの整合性が正しく検証されていない可能性があります。 FIM が動作し、Linux ファイル監視用に正しく構成されていることを確認します。 「変更履歴とインベントリの概要」を参照してください。
次のステップ
該当する問題がここにない場合、または問題を解決できない場合は、追加のサポートを受けるために、次のいずれかのチャネルをお試しください。
- Azure フォーラムを通じて Azure エキスパートから回答を得ることができます。
- @AzureSupport (カスタマー エクスペリエンスを向上させるための Microsoft Azure の公式アカウント) に連絡する。 Azure サポートにより、Azure コミュニティの回答、サポート、エキスパートと結び付けられます。
- Azure サポート インシデントを送信する。 その場合は、Azure サポートのサイトに移動して、[サポートの要求] をクリックします。