モバイル デバイスは、Exchange Onlineで削除された後、予期したとおりに検疫されません
元の KB 番号: 4090814
現象
Microsoft Exchange Onlineでは、一部のモバイル デバイスは予期したとおりに検疫されません。
たとえば、次のようなシナリオについて考えてみます。
Microsoft 365 テナントでは、Exchange ActiveSyncアクセス設定が [検疫] に構成されています。後でブロックするか許可するかを決定します。 検疫されたデバイスは 許可されます。 デバイスが許可されている場合、
Get-CASMailbox
コマンドレットには、 パラメーターと パラメーターに許可されたデバイスとブロックされたデバイスがActiveSyncAllowedDeviceIDs
ActiveSyncBlockedDeviceIDs
表示されます。その後、デバイスを削除します。 これを行うには、次のいずれかの方法を使用します。
方法 1
- Exchange 管理 Center >の受信者メールボックスを>見つけます。
- [ モバイル デバイス] の右側にある [ 詳細の表示] を選択し、すべてのモバイル デバイスの一覧からデバイスを削除します。
方法 2
PowerShell コマンドレットを使用します
Remove-MobileDevice
。デバイスが削除されると、ユーザーは同じデバイスを追加または構成しようとします。
このシナリオでは、デバイスは検疫されず、接続が許可されます。 Microsoft 365 Exchange 管理センターでは、ユーザーのモバイル デバイスの詳細にアクセス許可の状態が表示されGet-MobileDevice
、パラメーター値が [許可] であることがコマンドレットにDeviceAccessState
示されます。 これは予想される結果ではありません。 代わりに、デバイスが検疫されることを想定しています。
原因
デバイスが削除されると (Microsoft 365 Exchange 管理 センターから、またはコマンドレットを使用して PowerShell を使用Remove-MobileDevice
して)ActiveSyncAllowedDeviceIDs
、 パラメーターと ActiveSyncBlockedDeviceIDs
パラメーターはクリアされません。 そのため、ユーザーが以前に削除されたデバイスを使用して接続しようとすると、デバイス ID がパラメーターに ActiveSyncAllowedDeviceIDs
設定されたままになるため、デバイスは検疫されず、接続が許可されます。
回避策
デバイスが接続されないようにするには、デバイスを削除した後に ActiveSyncAllowedDeviceIDs
、 パラメーターと ActiveSyncBlockedDeviceIDs
パラメーターを $null に設定します。 たとえば、次のコマンドレットを実行します。
Set-CASMailbox joe@contoso.com -ActiveSyncAllowedDeviceIDs $null
これらのパラメーターが $null に設定されている場合、デバイスは接続しようとすると検疫されます。
さらにヘルプが必要ですか? Microsoft コミュニティを参照してください。