次の方法で共有


Microsoft 365 デスクトップ アプリケーションにサインインできない

現象

セキュリティ ソフトウェアがインストールされているデバイスでは、Microsoft 365 デスクトップ アプリケーションにサインインしようとすると、次のいずれかの問題が発生する可能性があります。

  • サインイン プロンプトが断続的に表示されます。

  • サインイン ウィンドウに空の認証画面が表示されます。

    空の認証画面のスクリーンショット。

  • サインイン ウィンドウが認証でスタックしています。

    認証でスタックするサインイン ウィンドウのスクリーンショット。

  • Outlook デスクトップ クライアントには、"接続しようとしています..." というメッセージが表示されます。

  • Teams デスクトップ クライアントには、"接続できませんでした。 サインインすると、もう一度やり直します。

  • イベント ビューアー開いた場合は、Windows ログ>アプリケーションに移動し、中央のウィンドウの上部にあるテーブルの "ソース" 列に "AppModel-State" エントリに表示される詳細をチェックすると、警告またはエラー コード-2147xxxxxxで終わる次のいずれかのイベント メッセージが表示されます。

    • パッケージのアプリケーション設定を読み込めませんでした

    • 操作の状態の場所の修復 設定エラーが発生したパッケージ Microsoft.AAD.BrokerPlugin_cw5n1h2txyewyに対して初期化する

    • エラーが発生したパッケージ Microsoft.AAD.BrokerPlugin_cw5n1h2txyewyに対する操作 LocalSettings の修復

    • パッケージに対する LocalSettings 操作Microsoft.AAD.BrokerPlugin_cw5n1h2txyewyヒット エラーのため、修復がトリガーされました

    • パッケージMicrosoft.AAD.BrokerPlugin_cw5n1h2txyewyヒット エラーに対する操作の設定初期化のため、状態の場所の修復Microsoft.AAD.BrokerPlugin_cw5n1h2txyewyトリガーされました

      ソース エントリ appmodel-state でフィルター処理された結果と、2147 で始まるエラー コードを含むイベント メッセージを示すイベント ビューアーのスクリーンショット。

原因

デバイス上のセキュリティ ソフトウェアは、ネットワーク通信が以前の通信状態を確立または維持するのを妨げている。 この問題は、セキュリティ ソフトウェアの既存または古い Windows フィルタリング プラットフォーム (WFP) ドライバーが原因で発生する可能性があります。 さらに、セキュリティ ソフトウェアによって Web アカウント マネージャー (WAM) プラグインの実行が妨げられる場合や、デバイスでのアクティビティの副作用としてプラグインが削除される可能性があります。

イベント ビューアーに [現象] セクションに一覧表示されているイベント メッセージが表示される場合、メッセージは WAM プラグインが壊れているか改ざんされていることを示します。

注:

  • WAM プラグインは、サインイン セッションを確立および更新するために Microsoft 365 アプリによって使用されます。 プラグインは、ユーザー プロファイルのコンテキスト内にインストールされます。 つまり、1 人のユーザーに問題が発生する可能性がありますが、同じデバイス上の別のユーザーは発生しない可能性があります。 そのため、軽減策と診断は、デバイス レベルまたは管理者レベルではなく、影響を受けるユーザーのコンテキスト内で行う必要があります。
  • セキュリティ ソフトウェア スキャン アクティビティのためにプラグインが破損、改ざん、またはユーザー プロファイルから削除された場合は、バックグラウンドの PowerShell スクリプトまたはログオン スクリプトを使用して、プラグインを繰り返しインストールグループ ポリシー試すことができます。 このアクションは、次のウイルス対策スキャンまで問題を一時的に軽減する可能性があります。

解決方法

重要

問題が原因で WAM プラグインが破損または改ざんされた場合は、次の手順の手順 3 に進み、WAM プラグインを再インストールします。問題が再発した場合は、セキュリティ ソフトウェアと WFP ドライバー ベンダーと連携して、手順 5 に記載されている適切な除外を構成します。

その他の問題を解決するには、デバイスで次の手順を実行します。

  1. 管理者アカウントを使用してサインインし、セキュリティ ソフトウェアと、デバイスからスタンドアロンまたは古い WFP ドライバーを一時的にアンインストールします。

  2. 影響を受けるユーザーの資格情報を使用してサインインし、WAM プラグインがインストールされ、ユーザーのプロファイルで正常に実行できるかどうかをチェックします。

    1. Windows PowerShell コマンドレットを実行します。

      Get-AppxPackage Microsoft.AAD.BrokerPlugin
      Get-AppxPackage Microsoft.Windows.CloudExperienceHost 
      
    2. いずれかのコマンドレットが何も返さない場合は、手順 3 に進みます。 それ以外の場合は、コマンド プロンプトで次のコマンドを実行します。

      explorer.exe shell:appsFolder\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy!App
      explorer.exe shell:appsFolder\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy!App
      

      [職場または学校アカウント] または [Microsoft アカウント] ウィンドウが開かない場合は、手順 3 に進みます。 そうでない場合は、手順 4 に進みます。

  3. 手順 2 が成功しない場合は、WAM プラグインを再インストールします。これを行うには、次の PowerShell コマンドレットを実行します。

    Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown
    Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown
    
  4. 48 時間監視します。 問題が再発した場合は、Microsoft サポートにお問い合わせください。 そうでない場合は、手順 5 に進みます。

    注:

    トラブルシューティングのために、問題を再現するときに プロセス モニター からデータを収集することをお勧めします。 これは、次の操作を行うかどうかを判断するのに役立ちます。

    • サードパーティ製モジュールは WAM プラグインと共に読み込まれています。
    • サード パーティ製モジュールは、ファイルまたはレジストリのロックを保持し、サインイン プロセスを妨げている。
    • 古い WFP またはセキュリティ ソフトウェア ドライバーがシステムにインストールされています。
  5. 管理者アカウントを使用してサインインし、手順 1 でアンインストールしたセキュリティ ソフトウェアとスタンドアロン WFP ドライバーを再インストールします。 次に、セキュリティ ソフトウェアと WFP ドライバー ベンダーと連携して、セキュリティ ソフトウェアと WFP ドライバーで次のパッケージ、フォルダー、およびプロセスの除外を構成します。

    除外するファミリ名をパッケージ化する

    • Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
    • Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy

    除外するフォルダーの場所

    • %windir%\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
    • %localappdata%\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
    • %windir%\SystemApps\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy
    • %localappdata%\Packages\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy
    • %localappdata%\Microsoft\TokenBroker
    • %localappdata%\Microsoft\OneAuth
    • %localappdata%\Microsoft\IdentityCache

    除外するプロセス

    • %windir%\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\Microsoft.AAD.BrokerPlugin.exe
    • %windir%\System32\backgroundTaskHost.exe 次のパッケージ名を指定します。
      • Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
      • Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy
    • %windir%\System32\svchost.exe NT サービス TokenBroker を TokenBroker.dll として読み込む