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電子情報開示 (Standard) の検索エラーを解決する

Microsoft Purview eDiscovery (Standard) での検索に関連する問題またはエラーが発生した場合は、操作を再試行して一時的な問題を除外します。 問題が解決しない場合は、次の一覧から該当する説明を選択します。

これらの解決策が検索の問題に適用されない場合は、Microsoft サポートにお問い合わせください。 問題に応じて、サポート ケースを作成する前に 、Get-ComplianceSearch または Get-ComplianceSearchAction PowerShell コマンドレットを使用して出力を収集します。 Microsoft サポート必要になる可能性があるその他の診断情報については、「電子情報開示の診断情報を収集する」を参照してください。

電子情報開示の保留の問題については、「 電子情報開示 (Standard)の保留エラーを解決する」を参照してください。

検索の問題: 推定検索結果とダウンロードされた検索結果の違い

現象

ダウンロードした電子情報開示検索結果フォルダーのエクスポートの概要<タイムスタンプ>.csv ファイルに検索結果の統計情報を表示すると、推定およびダウンロードされた検索結果の統計情報が異なることがあります。 推定検索結果の統計情報は、Microsoft Purview コンプライアンス ポータルの検索の詳細ウィンドウと電子情報開示エクスポート ツールにも表示されます。

原因

検索結果の見積もりは、検索クエリの条件を満たす項目の実際の数ではなく、見積もりです。 推定検索結果とダウンロードされた検索結果が異なる理由の詳細については、「 推定された電子情報開示検索結果と実際の電子情報開示検索結果の違い」を参照してください。

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検索エラー: "場所があいまいです"

現象

電子情報開示検索を実行すると、検索は失敗し、次のエラー メッセージが返されます。

コンプライアンス検索には、次の無効な場所: <メールボックス識別子>が含まれています。 場所 <メールボックス識別子> があいまいです。

原因

エラー メッセージで指定された場所が無効です。 無効な場所ごとのメールボックス識別子は、Exchange Online Protection (EOP) 内の重複または競合するオブジェクトによって使用されます。

解決方法

無効な場所ごとに、次の手順に従います。

  1. セキュリティ/コンプライアンス PowerShell に接続します

  2. メールボックス識別子を使用する重複または競合するオブジェクトを検索します。 これを行うには、次の Get-Recipient コマンドを実行します。

    Get-Recipient -Identity "<mailbox identifier from error message>"
    
  3. 重複または競合しているオブジェクトを削除します。

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検索エラー: "受信者が見つかりません"

現象

電子情報開示検索が失敗し、"受信者が見つかりません" というエラー メッセージが返されます。

原因

Exchange Online Protection (EOP) での同期の遅延のため、電子情報開示検索で受信者のいずれかが見つかりません。

解決方法

  1. セキュリティ/コンプライアンス PowerShell に接続します

  2. Get-Recipient コマンドレットを使用して、検索クエリの受信者が EOP で同期されているかどうかを確認します。 次のコマンドを実行します。

    Get-Recipient -Identity "<user identifier>" | FL
    
  3. コマンドが受信者のユーザー オブジェクトを返さない場合は、同期が完了するまで 30 分待ってから再確認します。

  4. 受信者が EOP で同期されていることを確認したら、検索を再試行します。

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検索エラー: CS007

現象

電子情報開示検索が失敗し、エラー コードがCS007返されます。

原因

次のいずれかの問題が発生すると、このエラーが発生する可能性があります。

  • 一時的な問題

  • システムが処理するために多すぎる結果を返す検索クエリ。 たとえば、複数のワイルドカードを使用するクエリでは、大きな結果セットを返すことができます。

解決方法

検索を再試行します。 それでも検索が失敗する場合は、検索を小さな検索に分割します。 たとえば、日付範囲を使用するか、検索場所の数を制限して、より小さな結果セットを返します。

検索エラー: "内部サーバー エラー (500) が発生しました"

現象

電子情報開示検索が失敗し、"内部サーバー エラー (500) が発生しました" というエラー メッセージが返されます。

原因

このエラーの原因となる問題は次のとおりです。

  • システムが処理するために多すぎる結果を返す検索クエリ。 たとえば、複数のワイルドカードを使用するクエリでは、大きな結果セットを返すことができます。

  • その他の検索エラー。 これらのエラーをチェックするには、次のコマンドを実行して検索に関する情報を取得し、出力でエラー メッセージを探します。

    Get-ComplianceSearch -Identity <search name> | FL ResultDetails
    

解決方法

検索を再試行します。 それでも検索が失敗する場合は、検索を小さな検索に分割します。 たとえば、日付範囲を使用するか、検索場所の数を制限して、より小さな結果セットを返します。

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検索またはエクスポートエラー: "現在実行中のorganizationのジョブの最大数"

現象

電子情報開示検索結果検索またはエクスポートしようとすると、操作が失敗し、次のエラー メッセージが表示されます。

organizationのジョブの最大数が現在実行されているため、要求を開始できません。

原因

organizationが最大 50 個の同時実行ジョブに達しました。 エクスポート ジョブは通常、検索ジョブよりも完了に時間がかかるため、エクスポート ジョブがクォータを満たす可能性が高くなります。

解決方法

現在実行中のエクスポート ジョブを確認するには、次の手順に従います。

注:

次の手順を使用するには、電子情報開示マネージャーの役割グループのメンバーであり、そのグループの電子情報開示管理者である必要があります。 organizationで電子情報開示管理者を表示または割り当てる方法の詳細については、「電子情報開示のアクセス許可の割り当てGet-eDiscoveryCaseAdmin、および Add-eDiscoveryCaseAdmin」を参照してください。

  1. セキュリティ/コンプライアンス PowerShell に接続します

  2. 次のスクリプトを実行します。

    $date = Get-Date
    $exports = @(Get-ComplianceSearchAction -Export -ResultSize Unlimited)
    $cases = Get-ComplianceCase | ?{$_.status -like "Active"}
    $i = 1
    foreach ($case in $cases) {
      $exports += Get-ComplianceSearchAction -Export -Case $case.Name
      Write-Host "Processing case $($i) of $($cases.Count)"
      $i++
    }
    $inProgressExports = $exports | ?{$_.Results -eq $null -or (!$_.Results.Contains("Export status: Completed") -and !$_.Results.Contains("Export status: none"))}
    $inProgressExportsSince = $inProgressExports | ?{$_.JobStartTime -ge $date.AddDays(-7)} | Sort-Object JobStartTime -Descending
    Write-Host "In-progress export jobs:"
    $inProgressExports | Format-Table Name,JobStartTime,JobEndTime,Status | More
    Write-Host "In-progress export jobs started in the last 7 days:"
    $inProgressExportsSince | Format-Table Name,JobStartTime,JobEndTime,Status | More
    

エラーを解決するには、次の手順を使用します。

  1. 実行中のジョブの数を減らします。 次の方法のいずれかまたは両方を使用します。

    • 1 つ以上の実行中のジョブが完了するまで待ちます。

    • Remove-ComplianceSearchAction PowerShell コマンドレットを使用して、不要になった 1 つ以上の実行中のジョブを削除します。

  2. 検索またはエクスポート操作を再試行します。

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エクスポートの問題: エクスポートがストールしているようです

現象

電子情報開示の検索結果をエクスポートしようとすると、エクスポートが完了せず、ストールしているように見えます。

原因

一時的な問題により、エクスポート プロセスが停止する可能性があります。

解決方法

エクスポートを再起動します。

注:

7 日以上前に生成された検索結果のエクスポートを再開することはできません。 代わりに、検索を再実行し、エクスポートを開始します。

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エクスポート エラー: "アイテムが移動または削除されました" または "タイムアウトのためアイテムを取得できません"

現象

電子情報開示検索結果をダウンロードすると、ダウンロードしたエクスポート フォルダーのエクスポート警告と Errors.csv ファイルに次のエラーが表示されます。

  • FailedToExportItem_Microsoft.Exchange.EDiscovery.Export.ExportException: 'FailedToExportItem' というエラーの種類でエクスポートに失敗しました。 メッセージ: アイテムが移動または削除されました。

  • FailedToExportItem_Microsoft.Exchange.EDiscovery.Export.ExportException: 'FailedToExportItem' というエラーの種類でエクスポートに失敗しました。 メッセージ: 複数回再試行した後にタイムアウトが発生したため、項目を取得できません。

原因

これらの "FailedToExportItem" エラー メッセージは、システムがすべての検索結果項目をエクスポートしなかったことを示します。 エクスポートされていない項目は、メールボックスのアーカイブ中にシステムが作成した一時的なバックアップです。 電子情報開示では一時的なバックアップ項目を検索できますが、これらの項目はエクスポートできません。

解決方法

システムが一時バックアップに関連付けられている元のメールボックス アイテムを取得してエクスポートするまで待ちます。

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エクスポート エラー: "状態コード 500 で要求が失敗しました" または "500 内部サーバー エラー"

現象

電子情報開示検索結果をエクスポートまたはダウンロードしようとすると、次のいずれかのエラー メッセージが表示されます。

  • 状態コード 500 で要求が失敗しました

  • 500 個の内部サーバー エラー

原因

この問題は、次のいずれかの理由で発生する可能性があります。

原因 1

エクスポート ロールがありません。 エクスポート ロールは、電子情報開示マネージャー役割グループのメンバーに自動的に割り当てられます。 エクスポート ロールは、組織管理役割グループのメンバーに自動的に割り当てられません。

原因 2

このエラーは、検索結果をエクスポートした管理者でない場合に、エクスポートされた検索結果をダウンロードしようとしたときに発生します。

原因 3

ユーザー アカウントのアクセス許可フィルターは、検索およびエクスポートできるメールボックス、ストレージの場所、またはコンテンツを制限します。

原因 4

検索のエクスポート可能なデータの量が 2 TB を超えています。 1 回の検索でエクスポート可能なデータの最大量は 2 TB です。 エクスポート可能なデータ サイズを確認するには、次のコマンドを実行します。

Get-ComplianceSearch -Identity <search name> | FL Size,SuccessResults,SearchStatistics

解決方法

該当する原因に対応する解決策を選択します。

解決方法 1

組織の管理役割グループのメンバーである場合は、 電子情報開示マネージャーの役割グループに自分を追加します。 これを行うには、Microsoft Purview コンプライアンス ポータルの [アクセス許可] ページで、または Add-eDiscoveryCaseAdmin PowerShell コマンドレットを使用します。

解決方法 2

エクスポートを作成した管理者に、ダウンロードを完了するように依頼します。 その管理者を見つけるには、次のコマンドを実行します。

Get-ComplianceSearchAction -Export -Case <case name> | FL Name,CreatedBy

解決策 3

検索およびエクスポートするメールボックスとストレージの場所に対して、アクセス許可フィルターによってこれらのアクションが妨げるかどうかをチェックします。 必要に応じて、管理者にアクセス許可フィルターの構成を依頼します。

解決策 4

検索を小さな検索に分割して、ダウンロード サイズを小さくします。 たとえば、日付範囲を使用するか、検索場所の数を制限して、より小さな結果セットを返します。

検索、エクスポート、またはプレビューロールが指定された管理者アカウントに割り当てられているかどうかをチェックするには、Microsoft 365 管理センターで次のテストを実行します。 次の手順を使用するには、 グローバル 管理者または コンプライアンス 管理者のアクセス許可が必要です。

注:

この診断は、GCC High または DoD 環境や、21Vianet が運営する Microsoft 365 では利用できません。

  1. Microsoft 365 管理センターで、[テストの実行: 電子情報開示 RBAC チェック] ボタンを選択して、関連するテストを設定します。

  2. [診断の実行] セクションで、検索、エクスポート、またはプレビュー タスクを実行しようとしているユーザーの UPN または電子メール アドレスを入力します。

  3. [ テストの実行] を選択します

  4. ユーザーに必要な電子情報開示ロールが割り当てられない場合は、それらのロールを割り当てて、ユーザーが目的のタスクを実行できるようにします。

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エクスポート エラー: "ファイルが存在しないためにエクスポートされませんでした" または "ファイルが見つかりません"

現象

電子情報開示の検索結果をダウンロードすると、次のいずれかのエラー メッセージが [警告のエクスポート] および [Errors.csv]、[スキップされた Items.csv]、またはダウンロードしたエクスポート フォルダー内のtrace.log ファイルに表示されます。

  • このファイルは存在しなくなったため、エクスポートされませんでした。 ファイルは、インデックスにまだ一覧表示されているため、推定検索結果の数に含まれていました。 ファイルは最終的にインデックスから削除され、今後エラーは発生しません。

  • コンテンツをダウンロードするFailedToExportItem_Failed。 追加の診断情報: Microsoft.Office.Compliance.EDiscovery.ExportWorker.Exceptions.ContentDownloadTemporaryFailure: ドキュメントの種類のコンテンツ <ドキュメント ID> からダウンロードできませんでした。 関連付け ID: <関連付け ID>。 ServerErrorCode: -2147024894 ---> Microsoft.SharePoint.Client.ServerException: ファイルが見つかりません。 microsoft.SharePoint.Client.ClientRequest.ProcessResponseStream(Stream responseStream) at Microsoft.SharePoint.Client.ClientRequest.ProcessResponse() --- 内部例外スタック トレースの終了---

原因

電子情報開示検索にMicrosoft Office SharePoint OnlineまたはMicrosoft OneDrive for Businessの場所が含まれている場合、このエラー メッセージが表示されることがあります。 電子情報開示は、SharePoint Online インデックスを使用して、両方の場所のファイルを識別します。 このエラーは、検索が完了した後、ただし、システムが SharePoint Online インデックスを更新する前に、ユーザーが検索結果内のファイルの名前を変更、移動、または削除した場合に発生します。 ファイルの名前が変更、移動、または削除されたかどうかをチェックするには、該当する SharePoint Online またはOneDrive for Business場所でファイルを探します。

解決方法

この問題を解決するには、「サイト、ライブラリ、またはリストのクロールとインデックス再作成を手動で要求する」で提供されている手順のいずれかを使用して、SharePoint Online または OneDrive for Businessの場所のインデックスを再作成します。 名前を変更または移動したファイルを検索結果に含める場合は、電子情報開示検索を再実行します。

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ダウンロードのエクスポートに関する問題: エクスポートされた検索結果のダウンロードが遅い

現象

電子情報開示検索結果をダウンロードすると、ダウンロードに予想以上の時間がかかります。

原因

ダウンロード速度が低下する可能性がある問題は次のとおりです。

  • 大量のエクスポート データ。 ダウンロード サイズを確認するには、次のコマンドを実行します。

    Get-ComplianceSearch -Identity <search name> | FL Size,SuccessResults,SearchStatistics
    
  • メールボックス サーバーに対する通常より高い負荷。

  • その他のダウンロード エラー。 これらのエラーをチェックするには:

    • 次のコマンドを実行して、進行中のエクスポートに関する情報を取得します。 コマンド出力でエラー メッセージを探します。

      Get-ComplianceSearchAction | FL Results
      
    • ダウンロードしたエクスポート フォルダー内の trace.log ファイルでエラー メッセージを探します。

解決方法

ダウンロード サイズを小さくするには、検索を小さな検索に分割します。 たとえば、日付範囲を使用するか、検索場所の数を制限して、より小さな結果セットを返します。

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ダウンロードのエクスポートの問題: 電子情報開示エクスポート ツールでファイルがダウンロードされない

現象

電子情報開示エクスポート ツールを実行して 、電子情報開示検索結果をダウンロードします。 ただし、操作が完了すると、ツール ウィンドウの [推定合計] フィールドに、ファイルがダウンロードされなかったことが示されます。

原因

この問題は、次のいずれかの理由で発生する可能性があります。

  • 対象のコンピューター上のウイルス対策ソフトウェアは、ダウンロードをブロックします。

  • ローカル ドライブではないダウンロード ドライブを選択します。

  • 次のいずれかの保存先フォルダーを選択します。

    • 別の電子情報開示エクスポートのダウンロード フォルダー。

    • 別の電子情報開示エクスポートのダウンロード フォルダーの親フォルダー。 エクスポート ツールはメタデータ ファイルを親フォルダーに保存するため、さまざまなダウンロードのメタデータ ファイルが互いに競合する可能性があります。

解決方法

問題が解決されるまで、指定された順序で次の各方法を試してください。

  1. 対象のコンピューターでウイルス対策スキャナーを一時停止し、ダウンロードを再試行します。

  2. ローカル ドライブにダウンロードします。 必要に応じて、別のクライアント コンピューターにダウンロードします。

  3. 電子情報開示の同時エクスポートと競合しない宛先フォルダーを選択します。

  4. 圧縮フォルダーへのエクスポートを無効にし、Exchange コンテンツの重複除去を無効にします。 この手順で問題が解決した場合、原因はウイルス対策ソフトウェアがダウンロードをブロックしているか、リモート ドライブにダウンロードしようとした可能性があります。

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ダウンロード エラーのエクスポート: "フォルダーであるため、検索結果がダウンロードされませんでした"

現象

電子情報開示検索結果をダウンロードすると、ダウンロードしたエクスポート フォルダーのスキップされた Items.csv ファイルに次のエラー メッセージが表示されます。

この検索結果は、単独ではダウンロードできないフォルダーまたはその他の成果物であるため、ダウンロードされませんでした。フォルダーまたはライブラリ内のアイテムはダウンロードされます。

原因

検索にMicrosoft Office SharePoint OnlineまたはMicrosoft OneDrive for Businessの場所が含まれている場合、このエラー メッセージが表示されることがあります。 スキップされた Items.csv ファイルには、検索結果内のすべてのフォルダーとその他のスキップされた項目が一覧表示されます。 通常、エラー メッセージは、ダウンロード可能な項目ではないため、フォルダー パスの横に表示されます。

解決方法

解決は必要ありません。 エラー メッセージは無視しても問題ありません。

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エクスポート のダウンロード エラー: "ファイル 'ExportData.db' にアクセスできません"

現象

電子情報開示エクスポート ツールを実行して 電子情報開示検索結果をダウンロードしますが、ダウンロードが停止するか、0 バイトのファイルが生成されます。 ダウンロードしたエクスポート フォルダーの trace.log ファイルに次のエラー メッセージが表示されます。

ヒット許容エラーが発生し、再試行されます。プロセスは別のプロセスで使用されているため、ファイル 'ExportData.db' にアクセスできません。

原因

この問題は、次の場合に発生する可能性があります。

  • 対象のコンピューター上のウイルス対策ソフトウェアは、ダウンロードをブロックします。

  • ローカル ドライブではないダウンロード ドライブを選択します。

  • 次のいずれかの保存先フォルダーを選択します。

    • 別の電子情報開示エクスポートのダウンロード フォルダー。

    • 別の電子情報開示エクスポートのダウンロード フォルダーの親フォルダー。 エクスポート ツールはメタデータ ファイルを親フォルダーに保存するため、さまざまなダウンロードのメタデータ ファイルが競合する可能性があります。

解決方法

エラーが解決されるまで、指定された順序で次の各メソッドを試してください。

  1. 対象のコンピューターでウイルス対策スキャナーを一時停止し、ダウンロードを再試行します。

  2. ローカル ドライブにダウンロードします。 必要に応じて、別のクライアント コンピューターにダウンロードします。

  3. 電子情報開示の同時エクスポートと競合しない宛先フォルダーを選択します。

  4. 圧縮フォルダーへのエクスポートを無効にし、Exchange コンテンツの重複除去を無効にします。 この手順で問題が解決した場合、原因はウイルス対策ソフトウェアがダウンロードをブロックしているか、リモート ドライブにダウンロードしようとした可能性があります。

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