Office をインストールしようとすると、"Windows インストーラー サービスにアクセスできませんでした"

現象

Microsoft Office をインストールしようとすると、次のようなエラー メッセージが表示されることがあります。

"Windows インストーラー サービスにアクセスできませんでした。

原因

この問題は、Windows インストーラー ファイルが破損しているか見つからない場合に発生する可能性があります。

解決方法

この問題を解決するには、以下のいずれかの方法を使用します。

方法 1: Msconfig ツールを使用して、インストーラー サービスが実行されていることを確認する

  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。 (この手順のスクリーン ショットを次に示します)。

    [スタート] を選択し、[実行] を選択して Msconfig ツールを起動します。

  2. [ 開く ] ボックスに「msconfig」と入力し、[OK] をクリック します。 (この手順のスクリーン ショットを次に示します)。

    [実行] ダイアログ ボックスの [開く] ボックスに「msconfig」と入力します。

  3. [サービス] タブで、[Windows インストーラー] の横にある [チェック] ボックスをクリックして選択します。 (この手順のスクリーン ショットを次に示します)。

    [システム構成ユーティリティ] ダイアログ ボックスの [サービス] タブの [Windows インストーラー] オプションを選択します。

  4. [ OK] をクリックし、[ 再起動 ] をクリックしてコンピューターを再起動します。 (この手順のスクリーン ショットを次に示します)。

    [システム構成] ダイアログ ボックスの [再起動] ボタンを選択して、コンピューターを再起動します。

  5. Office をもう一度インストールします。 プロダクト キーの入力を求められたら、プロダクト キーを入力し、[ 次へ] をクリックします。

Office がインストールされ、プログラムの起動時にプロダクト キーの入力を求めるメッセージは表示されません。

方法 2: Windows インストーラーを再登録する

重要

このセクション、方法、またはタスクには、レジストリの編集方法が記載されています。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 レジストリを変更する際には十分に注意してください。 保護を強化するため、レジストリを変更する前にレジストリをバックアップします。 こうしておけば、問題が発生した場合にレジストリを復元できます。 レジストリをバックアップおよび復元する方法の詳細については、「Windows でレジストリをバックアップおよび復元する方法」を参照してください。

メモ Microsoft Windows には複数のバージョンがあるため、お使いのコンピューターでは次の手順が異なる場合があります。 この場合、製品のマニュアルを参照のうえ、手順を実行するようにしてください。

Windows インストーラーを再登録するには、次の手順に従います。

メモ 次の手順を完了できない場合は、方法 3 に移動します。

  1. [ スタート] をクリックし、[ 検索] をクリックします。 (この手順のスクリーン ショットを次に示します)。

    [スタート] を選択し、[検索] を選択して、検索オプションを選択して検索結果を操作できるウィンドウを開きます。

  2. [ すべてのファイルとフォルダー] をクリックします。 (この手順のスクリーン ショットを次に示します)。

    [検索] を選択した後、[すべてのファイルとフォルダー] オプションを選択します。

  3. [ ファイル名 ] ボックスに「Msiexec.exe」と入力し、[ 検索] をクリックします。 (この手順のスクリーン ショットを次に示します)。

    [ファイル名] ボックスに「Msiexec.exe」と入力し、[検索] を選択します。

  4. 検索が完了したら、Msiexec.exe ファイルの場所を書き留めます。 ファイルの場所は、C:\Windows\System32 の例のようになります (この手順のスクリーン ショットを次に示します)。

    検索が完了したら、Msiexec.exe ファイルの場所を書き留めます。

  5. [ ファイル ] メニューの [ 閉じる ] をクリックして、[ 検索 ] ダイアログ ボックスを閉じます。 (この手順のスクリーン ショットを次に示します)。

    [ファイル] メニューの [閉じる] を選択して、[検索結果] ダイアログ ボックスを閉じます。

  6. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。 (この手順のスクリーン ショットを次に示します)。

    [スタート] を選択し、[実行] を選択します。

  7. [名前] ボックスに「regedit」と入力し、[OK] をクリックします。 (この手順のスクリーン ショットを次に示します)。

    [開く] ボックスに「regedit」と入力し、[OK] を選択します。

  8. 次のレジストリ キーを見つけてクリックします。

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSIServer (この手順のスクリーン ショットを次に示します)。

    MSIServer レジストリ キーを見つけて選択します。

  9. [レジストリ エディター] ウィンドウの右側のウィンドウで、[ImagePath] をダブルクリックします。 (この手順のスクリーン ショットを次に示します)。

    [レジストリ エディター] ウィンドウの右側のウィンドウで、[イメージ パス] をダブルクリックします。

  10. 表示される [ 文字列の編集 ] ダイアログ ボックスで、[ 値データ ] ボックスの文字列に、手順 4 で決定した Msiexec.exe ファイルの正しいパスが含まれていることを確認します。

    メモ 次に示す正しいパスの例を示します。 ここで、ドライブ は Windows がインストールされているドライブです。

    drive:\Windows\System32\msiexec.exe /V

    [値データ] ボックスに正しいパスが含まれていない場合は、パスを修正するために変更を加え、[OK] をクリックして [文字列の編集] ダイアログ ボックスを閉じます。 (この手順のスクリーン ショットを次に示します)。

    [値データ] ボックスに正しいパスが含まれていない場合は、パスを修正し、[OK] を選択して [文字列の編集] ダイアログ ボックスを閉じます。

  11. [ファイル] メニューの [レジストリ エディターの終了] をクリックして、レジストリ エディターを終了します。 (この手順のスクリーン ショットを次に示します)。

    [ファイル] メニューの [終了] を選択してレジストリ エディターを終了します。

  12. コンピューターをセーフ モードで起動し、Msiexec.exe ファイルを登録します。 これを行うには、次の手順を実行します。

    1. コンピューターをシャットダウンし、コンピューターを再起動します。

    2. コンピューターを再起動し、キーボードの F8 キーを押します。 複数のオペレーティング システムで起動するように構成されているコンピューターで、[ ブート] メニュー が表示されたら F8 キーを押します。

    3. 方向キーを使用して セーフ モードを選択し、Enter キーを押します。

    4. [ブート] メニューが再び表示され、下部に "セーフ モード" という単語が青で表示される場合は、起動するインストールを選択し、Enter キーを押します。

    5. コンピューターにログオンします。

    6. [ スタート] をクリックし、[ 実行] をクリックし、[ 開く ] ボックスに「msiexec /regserver」と入力し、[OK] をクリック します。 (この手順のスクリーン ショットを次に示します)。

      [スタート] を選択し、[実行] を選択し、[開く] ボックスに「msiexec /regserver」と入力し、[OK] を選択します。

  13. コンピューターをシャットダウンし、コンピューターを正常に再起動します。

それでも Microsoft Office を正常にインストールできず、「現象」セクションに記載されているメッセージのようなエラー メッセージが表示される場合は、方法 3 に進みます。

方法 3: Microsoft サポート技術情報の記事に記載されているメソッドを試319624

次の Microsoft サポート技術情報の記事に記載されているメソッドを試してください。

319624 アプリケーションのインストール時に "Windows インストーラー サービスにアクセスできませんでした" というエラー メッセージが表示される

方法 4: Windows インストーラーを再インストールする

メモこの方法は、Microsoft Windows 95、Microsoft Windows 98、Microsoft Windows ミレニアム エディション (Me)、Microsoft Windows NT 4.0 に適用されます。 Microsoft Windows 2000、Microsoft Windows XP、Microsoft Windows Server 2003 の場合は、最新のサービス パックを再適用するか、オペレーティング システムを修復します。

Windows インストーラーを再インストールするには、次の手順に従います。

  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。 (この手順のスクリーン ショットを次に示します)。

    [スタート] を選択し、[実行] を選択します。

  2. [ 開く ] ボックスに「cmd」と入力し、[OK] をクリック します。 (この手順のスクリーン ショットを次に示します)。

    [実行] ダイアログ ボックスに「cmd」と入力するスクリーンショット。

  3. コマンド プロンプトで、次の行を入力します。 各行を入力するたびに Enter キーを押します。

    cd %windir%\system32

    (この手順のスクリーン ショットを次に示します)。

    コマンド プロンプトで cd %windir%\system32 を実行します。

    ren msi.dll msi.old

    (この手順のスクリーン ショットを次に示します)。

    コマンド プロンプトで、msi.old msi.dll ren を実行します。

    ren msiexec.exe msiexec.old

    (この手順のスクリーン ショットを次に示します)。

    コマンド プロンプトで、msiexec.old msiexec.exe ren を実行します。

    ren msihnd.dll msihnd.old

    (この手順のスクリーン ショットを次に示します)。

    コマンド プロンプトで、msihnd.old msihnd.dll ren を実行します。

  4. コマンド プロンプトで「exit」と入力し、Enter キーを押します。 (この手順のスクリーン ショットを次に示します)。

    コマンド プロンプトで「exit」と入力し、Enter キーを押します。

  5. コンピューターを再起動します。

  6. Windows インストーラー ファイルを最新バージョンに更新します。 これを行うには、次のいずれかの Microsoft Web サイトにアクセスし、Windows インストーラー 2.0 をダウンロードしてインストールします。

    メモ Windows インストーラー 2.0 は、Microsoft Windows XP に含まれています。 Windows XP を使用している場合は、この手順を実行する必要はありません。

  7. Windows インストーラーのインストールが完了したら、Microsoft Office をインストールする前に、コンピューターを正常にシャットダウンして再起動します。

詳細情報

セーフ モードで Windows を再起動する方法の詳細については、「 高度なスタートアップ オプション (セーフ モードを含む)」を参照してください。