Office 文書を開こうとすると、エラー メッセージが表示される
現象
[適用対象] セクションに記載されている Microsoft Office プログラムでファイルを開こうとすると、次のいずれかのエラー メッセージが表示されます。
ファイル名が無効です。
ファイルにアクセスできませんでした。
入力したパス 'filename' が長すぎます。 パスを短くしてください。
filename が見つかりませんでした。 ファイル名とパス名を確認してください。
DDE エラーが発生し、長すぎるため、エラーの説明を表示できません。 ファイル名またはパスが長い場合は、ファイルの名前を変更するか、別のフォルダーにコピーしてみてください。
注:
この問題は、マップされたドライブ、UNC パス、または URL (Web アドレス) からファイルを開くときに発生します。
原因
この問題は、Office 製品でのファイルの作成と保存に関する文字制限が原因で発生します。 この問題は、開くか保存するファイルのパスが次の条件を満たしている場合に発生します。
Microsoft Word、Microsoft PowerPoint、Microsoft Access: パスの長さとファイル名の合計 (ファイル名拡張子を含む) が 259 文字を超えています。
Microsoft Excel: パスの長さとファイル名の合計 (ファイル名拡張子を含む) が 218 文字を超えています。
注:
この制限には、ドライブを表す 3 文字、フォルダー名の文字、フォルダー名の間の円記号、ファイル名自体の文字が含まれます。
回避策
この問題を回避するには、次の回避策のいずれかを試してください。
回避策 1: 文字数を減らす
- ファイルの名前を短くするように名前を変更します。
- ファイルを含む 1 つ以上のフォルダーの名前を変更して、名前を短くします。
- パス名が短いフォルダーにファイルを移動します。
回避策 2: 手動でアクセス、開く、修復する
Word、Excel、または PowerPoint を起動します。
[ファイル] タブで [開く]、[参照] の順に選択して、破損したファイルを見つけます。
ファイルを選択し、ウィンドウの下部にある [開く] メニューを選択して、[開いて修復する] を選択します。
このオプションを選択すると、ファイルの破損が修復され、ファイルが開きます。 ドキュメント、ブック、またはプレゼンテーションを修復した後は、問題が正常に解決されたことを確認することが重要です。 これを行うには、ファイルの作業を開始し、すべてが正常に動作していることを確認します。
回避策 3: ファイル形式を変更して再保存する
破損したファイルを別のファイル形式で保存し、元の形式に戻すことで、破損したファイルを修復できる場合があります。 この例では、Word を使用します。
手順 1: ファイルを別の形式に保存する
Word を起動します。
[ファイル] メニューの [開く] を選択し、破損したファイルを見つけて開きます。
[ファイル] メニューで [名前を付けて保存]、[参照] の順に選択します。
保存するファイルの場所に移動します。
[ファイルの種類] ボックスの一覧で、目的のファイル形式を選択します。 たとえば、[リッチ テキスト形式 (*rtf)] を選択します。
[保存] を選択し、[ファイル]、[閉じる] の順に選択します。
手順 2: ファイルを Word 文書として再保存する
[ファイル]、[開く] の順に選択します。
リッチ テキスト ファイルとして保存されている新しいファイルを選択し、[開く] を選択します。
[ファイル]、[名前を付けて保存] の順に選択します。
[ファイルの種類] ボックスの一覧で、[Word 文書] をクリックします。
ファイルの名前を変更し、[保存] を選択します。
文書がデバイスで正しく機能することを確認するには、これを 1 回だけ実行する必要があります。 ただし、ファイルを新しいドキュメントとして保存すると、別のファイルが作成されます。 混乱を避けるために、新しいファイルに独自の名前を付け、破損したバージョンをアーカイブまたは削除してください。 これにより、再フォーマットされていない元のファイルを誤って再度開くことはありません。
回避策 4: 認識されないファイル形式を開く
原因としてファイルの破損を除外できる場合は、ファイルの関連付けと認識されないファイル形式を確認します。 デバイス上でファイルが作成されたデバイスが、デバイスに存在しない使用済みソフトウェアで作成されたため、ファイルが開かない場合があります。
たとえば、Word では、メール メッセージに添付されている PDF ファイルを表示します。 ただし、PDF ビューアーはインストールされていません。 したがって、デバイスは、ファイルを表示するために開くプログラムがわからない。 この場合、インストールしたプログラムと一致するようにファイルの形式を変更できます。
添付ファイルをコンピューターに保存します。 これを行うには、メッセージの添付ファイルの横にある下矢印を選択し、[名前を付けて保存] を選択し、目的の場所に移動して、[保存] を選択します。
[ファイル] メニューで [開く]、[参照] の順に選択してファイルを見つけます。
ファイルを右クリックし、[プログラムから開く] をポイントして、別のプログラムを選択してファイルを開きます。
目的のプログラムが一覧にない場合は、[別のアプリを選択] を選択して別のプログラムを見つけます。
注:
これが機能し、選択したプログラムでこの種類のファイルを常に開く場合は、[常にこのアプリを使って .docx ファイルを開く] (例) チェック ボックスをオンにします。
ファイル形式とその管理方法の詳細については、「ファイル形式について」を参照してください。
回避策 5: 一部のディスク領域をクリアする
ハード ディスクの空き領域が不足している場合は、新しいファイルを開いたり、ファイルをデバイスに保存したりできない場合があります。 ディスクがいっぱいである場合は、一時的で重複した不要なアイテムによって領域の多くが使用されています。 ハード ディスク上の領域を解放する最も高速で簡単な方法は、Windows に含まれているディスク クリーンアップ アプリを使用することです。
[検索] を選択し、「ディスクのクリーンアップ」と入力します。
結果の一覧で、[ディスクのクリーンアップ] を選択します。
ダイアログ ボックスが開き、不要なファイルを削除するオプションが表示されます。 デバイスから削除するアイテムの各カテゴリの横にあるチェック ボックスをオンにし、[OK] を選択します。 この一覧の内容はすべて安全に削除できます。
メッセージが表示されたら、不要なファイルを完全に削除することを確認します。
次のファイルの種類は、ディスクのクリーンアップの一覧に表示されるリムーバブル アイテムの例です。
- Windows Update: Windows Update からダウンロードされた最近のファイル (現在インストールされている更新プログラムのバージョンは削除されません)
- ダウンロードしたプログラム ファイル: 不要なプログラム ファイル。多くの場合、プログラムのインストールに関連します
- インターネット一時ファイル: Web ブラウザーが Web サイトにアクセスしたときに自動的に保存されるファイル
- Windows エラー報告: システムによって作成されたエラー 報告ファイル
- ごみ箱: 手動で削除していないごみ箱に格納されているすべてのファイル
- 一時ファイル: プログラムまたは Web ブラウザーによって作成されるその他の一時ファイル
- ユーザー ファイル履歴: 閲覧履歴を記録するファイル (アクセスした Web サイト、検索結果など)
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