Outlook 2010、2013、2016、またはOutlook for Microsoft 365は、想定どおりに MAPI を使用して EXCHANGE を HTTP 経由で接続しません

元の KB 番号: 2937684

現象

次のような状況で問題が発生します。

  • Microsoft Outlook 2010、Outlook 2013 Service Pack 1 (SP1)、またはそれ以降のバージョンを使用しています。
  • Microsoft Exchange Server 2013 SP1 または Exchange Server 2016 メールボックスに接続しています。
  • 接続しているすべての Exchange メールボックスとクライアント アクセス (CAS) サーバーには、2013 SP1 以降のバージョンExchange Serverインストールされているか、2016 Exchange Server。
  • MapiHttp 接続を確立するために必要なサーバー設定が正しく構成されています。

上記のシナリオでは、[Outlook 接続の状態] ダイアログの [プロトコル] 列に、Outlook 2013 が MAPI/HTTP 以外の接続メカニズムを使用して Exchange サーバーに接続されていることを示しています。 たとえば、次の図は、RPC/HTTP を使用した接続を示しています。

[プロトコル] 列が RPC/HTTP として表示されている [Outlook の接続状態] ダイアログのスクリーンショット。

注:

MAPI/HTTP 接続は、文字列 HTTP を使用して [プロトコル] 列で指定されます。

さらに、MAPI/HTTP が無効になっている場合、Microsoft 365 ユーザーは、先進認証プロンプトではなく基本認証プロンプトを受け取ります。

原因

この問題は、次のレジストリ値を使用して Outlook クライアントで MapiHttp 機能が無効になっている場合に発生する可能性があります。

Key: HKEY_CURRENT_USER\Software\Microsoft\Exchange
DWORD: MapiHttpDisabled
Value: 1

解決方法

この問題を解決するには、 MapiHttpDisabled の値を 0 (ゼロ) に変更するか、 MapiHttpDisabled DWORD 値を削除します。 このレジストリ データは、テストのみを目的としています。

  1. Outlook を終了します。

  2. Windows のバージョンに応じて、次のいずれかの手順を使用してレジストリ エディターを開きます。

    • Windows 10、Windows 8.1、または Windows 8: Windows キーを押しながら R キーを押して [ファイル名を指定して実行] ダイアログ ボックスを開きます。 「regedit.exe」と入力し、[OK] をクリックします。
    • Windows 7: [スタート] をクリックし、検索ボックス に「regedit.exe 」と入力し、 Enter キーを押します。
  3. レジストリで、次のキーを見つけて選択します。

    HKEY_CURRENT_USER\Software\Microsoft\Exchange
    
  4. [MapiHttpDisabled] を右クリックし、[変更] をクリックします。

  5. [値のデータ]0 に変更し、[OK] をクリックします

  6. レジストリ エディターを終了します。

  7. Outlook を起動します。

詳細

HTTP 接続経由の MAPI の要件の詳細については、「HTTP 経由の MAPI」を参照してください。