この記事では、Microsoft Dynamics CRM Web クライアントで開催者フィールドのデータが削除された後に発生する Outlook へのデータの同期中に発生した不明なエラーの解決策について説明します。
適用対象: Microsoft Dynamics CRM 2011
元の KB 番号: 2700417
症状
既定では、Microsoft Dynamics CRM Web クライアントで作成された予定レコードは、作成ユーザーとして開催者フィールドに自動的に設定されます。 ただし、このフィールドのデータは削除でき、必須とは見なされません。
Microsoft Dynamics CRM 2011 Outlook クライアントでは、同期中に次のエラーが発生する可能性があります。
Outlook へのデータの同期中に不明なエラーが発生しました。
原因
同期された予定レコードの開催者フィールドが空白です。
解決方法
この動作を生成する予定レコードに、開催者フィールドが適切に設定されていることを確認します。
さらに、今後発生するこの問題を軽減するために、次のアクションを実行できます。
- 開催者フィールドを予定フォームの必須フィールドにします。
- 開催者フィールドが空白かどうかを確認するために、予定レコードの作成と更新時に実行されるワークフローを作成します。 フィールドが未記入の場合は、アポイントメントの主催者としてレコードの所有者を追加します。
- Outlook で予定を開き、開催者フィールドに入力してから同期します。
- 予定の作成時または更新時に開催者フィールドが設定されるようにするプラグインを作成します。