この記事では、Microsoft Dynamics CRM for Outlook クライアントを構成するときに発生するエラーの解決策について説明します。
適用対象: Microsoft Dynamics CRM 2011、Dynamics CRM 2013、Microsoft Dynamics CRM 2013 Service Pack 1、Microsoft Office Outlook 用 Microsoft CRM client
元の KB 番号: 2986728
症状
Microsoft Dynamics CRM 2011 または CRM 2013 for Outlook クライアントを Microsoft Dynamics CRM Online インスタンスに構成すると、次のエラー メッセージが表示されます。
オブジェクト参照がオブジェクト インスタンスに設定されていない
資格情報を入力した後、組織を選択し、 OKを選択します。
Microsoft Dynamics CRM サーバーとの通信に問題があります。 サーバーが使用不可になっている可能性があります。 後でもう一度試してみてください。 問題が解決しない場合は、システム管理者に問い合わせてください。
オブジェクト参照がオブジェクト インスタンスに設定されていません。
Microsoft.Crm.Passport.IdCrl.OnlineServicesFederationLogOnManager.GetBrowserClientAuthInfo(String redirectEndpoint, String partner, String policy, String& postData) のブラウザクライアント認証情報の取得
at Microsoft.Crm.Outlook.ClientAuth.PassportAuthProvider'1.SignIn()
at Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory'1.SignIn(Uri endPoint, Credential credentials, AuthUIMode uiMode, IClientOrganizationContext context, Form parentWindow, Boolean retryOnError)
at Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory'1.GetAuthProvider(Uri endPoint, Credential credentials, AuthUIMode uiMode, Uri webEndPoint, IClientOrganizationContext context, Form parentWindow)
at Microsoft.Crm.Application.Outlook.Config.ServerInfo.LoadUserId()
Microsoft.Crm.Application.Outlook.Config.ServerInfo.Initialize(Uri 探索URI, OrganizationDetail 選択された組織, String 表示名, Boolean はプライマリ)で
at Microsoft.Crm.Application.Outlook.Config.ServerForm.LoadDataToServerInfo()(サーバー情報にデータをロードする処理)
at Microsoft.Crm.Application.Outlook.Config.ServerForm.<InitializeBackgroundWorkers>b__2(Object sender, DoWorkEventArgs e)
System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e) において
at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object 引数)
原因
この問題は、Microsoft Dynamics CRM 2011 または Microsoft Dynamics CRM 2013 と互換性のないバージョンの Microsoft Online Services サインイン アシスタントを使用している場合に発生します。 Microsoft Dynamics CRM for Outlook クライアントを構成し、Microsoft Dynamics CRM Online インスタンスに接続する場合、サポートされている Microsoft Online Services サインイン アシスタントのバージョンは、7.250.4259.0、7.250.4287.0、および 7.250.4303.0 のみです。
解決方法
この問題を解決するには、次の手順に従います。
- Startを選択し、「appwiz.cpl」と入力し、Enter キーを押してコントロール パネルの Programs and Features 項目を開きます。
- バージョンが 7.250.4259.0、7.250.4287.0、または 7.250.4303.0 と一致しない場合は、Microsoft Online Services サインイン アシスタントをアンインストールします。
- Microsoft Online Services サインイン アシスタントのバージョン 7.250.4303.0 をダウンロード 再インストールします。
- ワークステーションを再起動し、Microsoft Dynamics CRM for Outlook クライアントを構成して問題が解決されたことを確認します。