この記事では、Microsoft Dynamics CRM for Outlook 内の Microsoft Dynamics CRM で Track を選択するときに発生するこれらのレコードにアクセスするアクセス許可がありませんエラーの解決方法について説明します。
適用対象: Microsoft Dynamics CRM 2015、Microsoft Dynamics CRM 2016
元の KB 番号: 3140750
症状
Microsoft Dynamics CRM for Outlook 内の Microsoft Dynamics CRM で Track を選択すると、次のエラーで失敗します。
これらのレコードにアクセスするためのアクセス許可がありません。 Microsoft Dynamics CRM 管理者に問い合わせてください。
原因
Microsoft Dynamics CRM のユーザー レコードに、レコード作成および更新ルール エンティティの読み取りアクセス権がありません。 Microsoft はこの問題を認識しており、メールを追跡するためにこの特権が必要ないように修正プログラムを提供する予定です。 それまでの間は、「解決策」セクションに示されている回避策を使用できます。
解決方法
システム管理者ロールを持つユーザーとして Microsoft Dynamics CRM にサインインします。 ユーザーに割り当てられているセキュリティ ロールを見つけます。 セキュリティ ロールの Service Management タブで、レコードの作成および更新ルール エンティティの読み取りアクセス権を付与します。
詳細
クライアント側の CRM トレースをキャプチャすると、次の情報がログに記録されます。
プリンシパル ユーザー (Id={GUID}、type=8) に prvReadConvertRule 特権がありません (Id=<GUID>) 2015-08-21T15:27:32.0596285Z