問題
次のシナリオを考えてみましょう。ユーザーは、以前シングル サインオン (SSO) 用に設定されていたクラウド サービス ドメインのメンバーであるユーザー ID を使用して、Microsoft 365、Microsoft Azure、Microsoft Intune などの Microsoft クラウド サービスにサインインできません。 このシナリオでは、クラウド サービス管理者が Windows PowerShell のクラウド サービス ポータルまたは Azure Active Directory モジュールを使用してユーザーのパスワードをリセットしようとすると、管理者は次のエラー メッセージを受け取ります。
このユーザーのパスワードをリセットできません。 後でもう一度試してみてください。
原因
この問題は、ユーザーが以前シングル サインオン (SSO) が有効だったクラウド サービス ドメインのメンバーであり、ユーザー ID が標準認証を使用するように変換されていない場合に発生します。
たとえば、この問題は、次の Windows PowerShell コマンドレットが使用された場合に発生する可能性があります。
convert-MSOLDomainToStandard –skipuserconversion:$true
注
Azure AD および MSOnline PowerShell モジュールは、2024 年 3 月 30 日の時点で非推奨となります。 詳細については、非推奨に関するアップデートを参照してください。 この日以降、これらのモジュールのサポートは、Microsoft Graph PowerShell SDK への移行支援とセキュリティ修正に限定されます。 非推奨のモジュールは、2025 年 3 月 30 日まで引き続き機能します。
Microsoft Entra ID (旧称 Azure AD) を使用するには、Microsoft Graph PowerShell に移行することをお勧めします。 移行に関する一般的な質問については、「移行に関する FAQ」を参照してください。 注: MSOnline のバージョン 1.0.x では、2024 年 6 月 30 日以降に中断が発生する可能性があります。
解決策
この問題を解決するには、ユーザー ID を標準 (非フェデレーション) 型に変換します。 この手順を実行するには、以下のステップに従ってください。
- 問題の確認に使用したのと同じ Windows PowerShell コンソールで、次のコマンドレットを入力し、Enter キーを押します。
Convert-MsolFederatedUser -userprincipalname < user ID >
注
このコマンドレットでは、プレースホルダー <user ID> はユーザー ID を表します。
- ユーザーに一時的なパスワードを指定します。 ユーザーが次回クラウド サービスにサインインする場合は、クラウド サービス リソースにアクセスする前に一時的なパスワードを変更する必要があります。
詳細情報
注
この記事の Windows PowerShell コマンドレットには、Windows PowerShell 用の Azure Active Directory モジュールが必要です。
まだ助けが必要ですか? Microsoft コミュニティ または microsoft Entra フォーラム web サイト に移動します。