SharePoint Server での機械翻訳サービスのナレッジ項目
適用対象:2016 2019 Subscription Edition SharePoint in Microsoft 365
System Center Operations Manager (SCOM) の SharePoint Server 2019、2016、2013 管理パックで機械翻訳サービスに関するアラートを解決する方法について説明します。
このセクションの記事は、SharePoint Server の機械翻訳サービスのナレッジ記事です。 通常、これらの記事は、Operations Manager コンソールでアラート内のリンクをクリックすると表示されます。 これらの記事を参照して、機械翻訳サービスに伴う問題のトラブルシューティングと解決に役立てることができます。
ダウンロードしてインストールする:
System Center Management Pack for SharePoint Server 2013 - 日本語
System Center Monitoring Pack for SharePoint Foundation 2013
機械翻訳サービスに関するアラートを解決するには、次を使用します。
機械翻訳サービス: キュー データベースにアクセスできない
**アラート名:**Machine Translation Service: キュー データベースにアクセスできません
概要: このモニターの重大な状態は、機械翻訳サービスが翻訳する必要のあるコンテンツにアクセスできないことを示します。
現象:
新しいジョブを正常に送信できません。
既存のジョブ項目が完了しないか、ジョブ キュー内で "ハングして" 処理が進行していないように見えます。
原因
次の 1 つ以上の問題が原因である可能性があります。
ネットワークまたは物理 SQL Server の稼働状況が原因で、キュー データベースの応答速度が十分ではありません。
カスタム データベースにアクセスする権限が有効ではなくなっています。
キュー データベースにアクセスできません。
解決方法
解決策 1: SQL Server の機械翻訳サービス データベースの状態を確認します。
SharePoint サーバーの全体管理 Web サイトの [ システム設定] セクションで、閲覧ウィンドウから [ このファームのサーバーの管理] をクリックします。
[ ファーム情報] セクションで、 機械翻訳サービス データベース サーバーと、構成データベースの名前とバージョンを確認します。
SQL Server Management Studio を開始し、構成データベース サーバーに接続します。
構成データベースが存在しない場合は、SharePoint 製品とテクノロジ構成ウィザードを実行します。
解決策 2: SQL Server ネットワーク接続を確認します。
サーバーの全体管理 Web サイトの [ システム設定] セクションで、閲覧ウィンドウから [このファームのサーバーの管理] をクリックします。
[ ファーム情報] セクションで、機械翻訳サービス データベース サーバーと、構成データベース情報の名前とバージョンを確認します。
コマンド プロンプト ウィンドウを開き、 ping を入力して、サーバー接続を確認します。
サーバーに接続できない場合は、ネットワーク接続に問題があるか、サーバーからの応答を妨げる問題が他に存在することを示しています。
サーバーにログオンして、問題をトラブルシューティングします。
機械翻訳サービス: 機械翻訳エラー - #1
**アラート名:**機械翻訳サービス: 機械翻訳エラー
概要: このモニターの重大な状態は、オンライン翻訳サービスによる機械翻訳が失敗していることを示します。
現象:
オンライン翻訳サービスへの接続が確立されていない場合、サービスが正常に機能していても、処理されるすべての翻訳項目が失敗します。
原因
次の 1 つ以上の問題が原因である可能性があります。
機械翻訳サービスがインターネットに接続されていません。
オンライン翻訳サービスがダウンしています。
オンライン翻訳サービスで断続的に一定量の (設定されているしきい値を超える) 障害が発生しました。
解決方法
機械翻訳サービス アプリケーションが Web にアクセスできることを確認します。
この手順を実行しているユーザー アカウントが Farm Administrators グループのメンバーであることを確認します。
サーバーの全体管理 Web サイトの [ アプリケーション構成の管理] セクションで、[ サービス アプリケーションの管理] をクリックします。
[ サービス アプリケーションの管理] ページのサービス アプリケーションの一覧で、[ 機械翻訳サービス] をクリックします。
[ オンライン翻訳との接続] セクションの Web プロキシ サーバーのボックスで、次のどちらかの操作を行います。
[ 既定のインターネット設定を使用] をクリックします。
[ 指定したプロキシを使用] で、Web プロキシ サーバーとポート番号を入力します。
機械翻訳サービス アプリケーションの MachineTranslationAddress、MachineTranslationClientId、および MachineTranslationCategory を確認します。
この手順を実行するユーザー アカウントがファーム管理者グループのメンバーであることを確認します。
PowerShell のコマンド プロンプトで次のように入力します。
Get-SPServiceApplication -Name "name" | ft MachineTranslationAddress, MachineTranslationClientId, MachineTranslationCategory
"name" は、機械翻訳サービス アプリケーションの名前です。
返された値を、ドキュメントと比較して、またはテスト呼び出しを行って、検証します。
検証結果に基づいて値を修正します。 値を検証できない場合は、既定値を使用します。
機械翻訳サービス: 機械翻訳エラー - #2
**アラート名:**機械翻訳サービス: 機械翻訳エラー
**概要:**このモニターの重大な状態は、機械翻訳サービス タイマー ジョブが失敗していることを示します。
現象:
新しいジョブは正常にデータベースに入ります。 しかし、そのジョブの翻訳項目は開始しません。
既存のジョブが完了しない可能性がある: アプリケーション サーバーに既に割り当てられている翻訳項目は引き続き成功する可能性がありますが、アプリケーション サーバーに割り当てられない翻訳項目は開始されません。 その場合、ジョブは永続的に不完全になります。
原因
機械翻訳サービスのキュー タイマー ジョブが動作していません。
解決方法
解決策 1: 機械翻訳サービスを再起動します
サーバーの全体管理 Web サイトの [ システム設定] セクションで、閲覧ウィンドウから [ このファームのサーバーの管理] をクリックします。
[ サーバー] 列で、エラーが発生しているアプリケーション サーバーの名前をクリックします。 [ サーバーのサービス] ページが開きます。
[ サービス ] 列で、 機械翻訳サービスを見つけます。 [ 停止] をクリックしたら、再度 [ 開始] をクリックします。
解決策 2: 新しい機械翻訳サービス アプリケーションを作成します
サーバーの全体管理 Web サイトの [ アプリケーション構成の管理] セクションで、閲覧ウィンドウから [ サービス アプリケーションの管理] をクリックします。
[ 種類 ] 列で、失敗したサービス インスタンスを持つ Machine Translation Service アプリケーションの名前をクリックします。
リボンの [ 削除] をクリックします。
[ サービス アプリケーションの削除 ] ダイアログで、[OK] をクリック します。
新しい機械翻訳サービス アプリケーションを作成します。
機械翻訳サービスにアクセスできない
**アラート名:**機械翻訳サービスにアクセスできません
概要: このモニターの重大な状態は、機械翻訳サービスにアクセスできないことを示します。
現象: 機械翻訳サービスのサービス呼び出しが動作していない場合、すぐに処理したりジョブ キューに送信したりするためにジョブをアプリケーション サーバーに送信できません。 つまり、サービスはアクセスできず、機能しません。
原因
次の 1 つ以上の問題が原因である可能性があります。
指定された SharePoint Server アプリケーション サーバーにアクセスできません。
特定のサーバーでネットワーク活動や負荷が過剰になっているため、指定されたアプリケーション サーバーの応答が遅くなっています。
解決方法
解決策 1: エラー ログを確認します。
Windows イベント ビューアーを開きます。
Windows でイベント ID 8049 を検索します。 アプリケーション イベント ログ。
イベントの説明で、エラーが発生しているアプリケーション サーバーを確認します。
解決策 2: アプリケーション サーバーの接続を確認します。
エラーが発生しているアプリケーション サーバーから、SharePoint サーバーの全体管理 Web サイトを開きます。
エラーが発生しているサーバーからサーバーの全体管理サイトにアクセスできない場合は、ネットワーク設定が正しいことと、SharePoint ファームに接続するための適切な権限がサーバーにあることを確認します。
解決策 3: エラーが発生しているサーバーで機械翻訳サービスが実行されていることを確認します。
サーバーの全体管理 Web サイトの閲覧ウィンドウで、[ システム設定] セクションの [ このファームのサーバーの管理] をクリックします。
エラーが発生しているアプリケーション サーバーで機械翻訳サービスが実行されていることを確認します。
エラーが発生しているサービス アプリケーション用のサービス アプリケーション プロキシがある場合は、新しいサービス アプリケーションを作成します。
解決策 4: 機械翻訳サービスを再起動します。
サーバーの全体管理 Web サイトの閲覧ウィンドウで、[ システム設定] セクションの [ このファームのサーバーの管理] をクリックします。
[ サーバー] 列で、エラーが発生しているアプリケーション サーバーの名前をクリックします。 [ サーバーのサービス] ページが開きます。
[ サービス] 列で [ 機械翻訳サービス] を見つけ、[ 停止] をクリックしたら、再度 [ 開始] をクリックします。
解決策 5: 新しい機械翻訳サービス アプリケーションを作成します。
サーバーの全体管理 Web サイトの閲覧ウィンドウの [ アプリケーション構成の管理] セクションで、[ サービス アプリケーションの管理] をクリックします。
[ 種類 ] 列で、失敗したサービス インスタンスを持つ Machine Translation Service アプリケーションの名前をクリックします。
リボンの [ 削除] をクリックします。
[ サービス アプリケーションの削除 ] ダイアログで、[OK] をクリック します。
新しい機械翻訳サービス アプリケーションを作成します。
機械翻訳サービス: コンテンツにアクセスできない
**アラート名:**Machine Translation Service: コンテンツにアクセスできません
概要: このモニターの重大な状態は、バックエンドからフロントエンドへの CSOM 呼び出しが失敗したことを示します。
現象: 処理のためにファイルを取得できず、既に処理済みの項目を書き込むことができません。 つまり、ファイルにアクセスできず、項目が連続して失敗します。
原因
次の 1 つ以上の問題が原因である可能性があります。
サーバー間の認証の構成が正しくありません。
ネットワークまたは物理 SQL Server の稼働状況が原因で、コンテンツ データベースの応答速度が十分ではありません。
コンテンツ データベースにアクセスする権限が有効ではなくなっています。
コンテンツ データベースにアクセスできません。
解決方法
解決策 1: SQL Server のコンテンツ データベースの状態を確認します。
サーバーの全体管理 Web サイトの [ システム設定] セクションで、閲覧ウィンドウから [ このファームのサーバーの管理] をクリックします。
[ ファーム情報] セクションで、コンテンツ データベース サーバーと、構成データベースの名前とバージョンを確認します。
SQL Server Management Studio を開始し、コンテンツ データベース サーバーに接続します。
コンテンツ データベースが存在しない場合は、SharePoint 製品とテクノロジ構成ウィザードを実行します。
解決策 2: SQL Server ネットワーク接続を確認します。
サーバーの全体管理 Web サイトの [ システム設定] セクションで、閲覧ウィンドウから [ このファームのサーバーの管理] をクリックします。
[ ファーム情報] セクションで、コンテンツ データベース サーバーと、コンテンツ データベース情報の名前とバージョンを確認します。
コマンド プロンプト ウィンドウを開き、 ping を入力して、サーバー接続を確認します。
サーバーに接続できない場合は、ネットワーク接続に問題があるか、サーバーからの応答を妨げる問題が他に存在することを示しています。
サーバーにログオンして、問題をトラブルシューティングします。
解決策 3: サーバー間の認証が正しく構成されていることを確認します。
「Configure server-to-server authentication in SharePoint Server」を参照してください。
機械翻訳サービス: ワーカーが失敗する
**アラート名:**Machine Translation Service: Worker エラー
概要: このモニターの重大な状態は、機械翻訳サービスのワーカー プロセスで問題が発生していることを示します。
現象: 一定の時間にわたりエンド ユーザーがすべての項目フェールオーバーを認識しないでの、これらのエラーを監視する必要があります。
原因
次の 1 つ以上の問題が原因である可能性があります。
入力ファイルが壊れています
翻訳ワーカーがクラッシュしています
ローカル ストアへのファイルの保存でエラーが発生しています
解決方法
解決策 1: エラー ログを確認します。
Windows イベント ビューアーを開きます。
Windows アプリケーション イベント ログで、イベント ID 8049 を検索します。
イベントの説明で、エラーが発生しているアプリケーション サーバーを確認します。
解決策 2: アプリケーション サーバーの接続を確認します。
エラーが発生しているアプリケーション サーバーから、 SharePoint サーバーの全体管理 Web サイトを開きます。
エラーが発生しているサーバーからサーバーの全体管理 Web サイトにアクセスできない場合は、ネットワーク設定が正しいことと、SharePoint ファームに接続するための適切な権限がサーバーにあることを確認します。
解決策 3: エラーが発生しているサーバーで機械翻訳サービスが実行されていることを確認します。
サーバーの全体管理 Web サイトの閲覧ウィンドウで、[ システム設定] セクションの [ このファームのサーバーの管理] をクリックします。
エラーが発生しているアプリケーション サーバーで機械翻訳サービスが実行されていることを確認します。
エラーが発生しているサービス アプリケーション用のサービス アプリケーション プロキシがある場合は、新しいサービス アプリケーションを作成します。
解決策 4: 機械翻訳サービスを再起動します。
サーバーの全体管理 Web サイトの閲覧ウィンドウで、[ システム設定] セクションの [ このファームのサーバーの管理] をクリックします。
[ サーバー] 列で、エラーが発生しているアプリケーション サーバーの名前をクリックします。 [ サーバーのサービス] ページが開きます。
[ サービス] 列で [ Machine Translation Service] を見つけ、[ 停止] をクリックしたら、再度 [ 開始] をクリックします。
解決策 5: 新しい機械翻訳サービス アプリケーションを作成します
サーバーの全体管理 Web サイトの閲覧ウィンドウの [アプリケーション構成の管理] セクションで、閲覧ウィンドウから [サービス アプリケーションの管理] をクリックします。
[ 種類 ] 列で、失敗したサービス インスタンスを持つ Machine Translation Service アプリケーションの名前をクリックします。
リボンの [ 削除] をクリックします。
[ サービス アプリケーションの削除 ] ダイアログで、[OK] をクリックします。
新しい機械翻訳サービス アプリケーションを作成します。
関連項目
概念
その他のリソース
System Center Management Pack for SharePoint Foundation 2013 - 日本語
System Center Management Pack for SharePoint Server 2013 - 日本語