SharePoint Server の Visio Services のナレッジ項目

適用対象:yes-img-13 2013yes-img-162016 yes-img-192019 yes-img-seSubscription Edition no-img-sopSharePoint in Microsoft 365

SharePoint Server 2019、2016、2013 の Visio Services のアラート (症状、原因、考えられる解決策) を解決します。

注:

Microsoft Silverlight ベースのレンダリングは、2012 年 10 月 12 日の時点ではサポートされなくなります。 つまり、Silverlight ベースのレンダリングは、SharePoint Server 2019ではサポートされません。 Visio Services では、PNG ベースのテクノロジを使用して Visio ダイアグラムのみがレンダリングされます。

このセクションの記事は、SharePoint Server 2019 および 2016 の Visio Services に関するナレッジ記事です。 通常、これらの記事は、System Center Operations Manager コンソールでアラート内のリンクをクリックすると表示されます。 これらの記事を使用すると、Visio Services の問題のトラブルシューティングと解決に役立ちます。

ダウンロードしてインストールする:

このセクションの内容

ラスタライザーの初期化に失敗したVisio Graphics Service - #1

**アラート名:**Visio Graphics Serviceラスタライザーの初期化に失敗しました

概要: SharePoint Server の Visio Services では、ラスタライザーによって Visio の図を表示する必要があります。 ラスタライザーが Visio Services によって初期化されていない場合、VSDX 図と VSDM ダイアグラムはレンダリングされません。症状: 次の 1 つ以上の症状が表示される場合があります。

  • Visio Services で図が表示されません。

  • "イベント ID: 8076、説明: ラスタライザーの初期化に失敗しました。" というイベントがイベント ログに記録されます。

原因

Visio Graphics Service の内部コンポーネントであるラスタライザーが実行されていないか、または正しく初期化されていません。

解決方法

Visio Services を再起動します。

  1. [ サーバーの全体管理] ページの [ システム設定] セクションで、閲覧ウィンドウから [ このファームのサーバーの管理] をクリックします。

  2. [ サーバー] 列で、エラーが発生しているアプリケーション サーバーの名前をクリックします。 [ サーバーのサービス] ページが開きます。

  3. [ サービス] 列で [ Visio Graphics Service] を見つけます。 [ 停止] をクリックしたら、再度 [ 開始] をクリックします。

ラスタライザーの初期化に失敗したVisio Graphics Service - #2

**アラート名:**Visio Graphics Serviceラスタライザーの初期化に失敗しました

概要: SharePoint Server の Visio Services では、ラスタライザーによって Visio の図を表示する必要があります。 Visio Services によってラスタライザーが初期化されない場合、VSDX および VSDM の図は表示されません。 Visio Graphics Service でラスタライザーの初期化に失敗した場合にこのルールがトリガーされます。

原因

現象: 次に示す現象のうち 1 つ以上が発生します。

  • Visio Services で図が表示されません。

  • "イベント ID: 8076、説明: ラスタライザーの初期化に失敗しました。" というイベントがイベント ログに記録されます。

解決方法

Visio Services を再起動します。

  1. [ サーバーの全体管理] ページの [ システム設定] セクションで、閲覧ウィンドウから [ このファームのサーバーの管理] をクリックします。

  2. [ サーバー] 列で、エラーが発生しているアプリケーション サーバーの名前をクリックします。 [ サーバーのサービス] ページが開きます。

  3. [ サービス] 列で [ Visio Graphics Service] を見つけます。 [停止] をクリックしたら、再度 [開始] をクリックします。

Visio Graphics Service は構成マネージャーを検出できません

**アラート名:**Visio Graphics Service構成マネージャーが見つかりません

概要: SharePoint Server の Visio Services では、アプリケーションの設定を、構成データベースに保存します。 サービスが機能するためには、このデータベースへのアクセスが欠かせません。

Visio Graphics Service で構成マネージャーを検出できない場合にこのルールがトリガーされます。

現象: 次に示す現象のうち 1 つ以上が発生します。

  • Visio Services で図が表示されません。

  • "イベント ID: 8040、説明: 構成マネージャーが見つかりません。" というイベントがイベント ログに記録されます。

原因

次の 1 つ以上の問題が原因である可能性があります。

  • 構成データベースにアクセスできません。

  • ネットワーク アクティビティが過剰に発生しているか、Microsoft SQL Server の負荷が原因で、構成データベースの応答に時間がかかっています。

解決方法

解決策 1: SQL Server 構成データベースの状態を確認します。

  1. SharePoint の [ サーバーの全体管理] Web サイトの [ システム設定] セクションで、閲覧ウィンドウから [ このファームのサーバーの管理] をクリックします。

  2. [ ファーム情報] セクションで、構成データベース サーバーと、構成データベースの名前とバージョンを確認します。

  3. SQL Server Management Studio を起動し、構成データベース サーバーに接続します。

  4. 構成データベースが存在しない場合は、SharePoint 製品とテクノロジ構成ウィザードを実行します。

解決策 2: SQL Server ネットワーク接続を確認します。

  1. [ サーバーの全体管理] Web サイトの [ システム設定] セクションで、閲覧ウィンドウから [ このファームのサーバーの管理] をクリックします。

  2. [ ファーム情報] セクションで、構成データベース サーバーと、構成データベースの名前とバージョンを確認します。

  3. コマンド プロンプト ウィンドウを開き、 ping を入力して、 サーバー接続を確認します。

    サーバーに接続できない場合は、ネットワーク接続に問題があるか、サーバーからの応答を妨げる問題が他に存在することを示しています。

  4. サーバーにログオンして、問題をトラブルシューティングします。

Visio Graphics Service はアプリケーション プロキシから返されたアプリケーション サーバーに接続できません

**アラート名:**Visio Graphics Serviceアプリケーション プロキシによって返されたアプリケーション サーバーに接続できません

概要: SharePoint Server の Visio Services 用のアプリケーションは、プロキシを使用して、フロントエンド サービスとバックエンド サービスとの間の通信を抽象化します。 このプロキシは、サーバー間の負荷分散メカニズムも提供します。 Visio Services が機能するためには、アプリケーション プロキシによって返されるアプリケーション サーバーにフロントエンド サービスが接続されている必要があります。 Visio Graphics Service からアプリケーション サーバーに接続できない場合にこのルールがトリガーされます。

現象: 次に示す現象のうち 1 つ以上が発生します。

  • SharePoint の Visio Services で図が表示されません。

  • "イベント ID: 8049、説明: <説明文>に対する、アプリケーション プロキシの無効なエンドポイントです。" というイベントがイベント ログに記録されます。

原因

次の 1 つ以上の問題が原因である可能性があります。

  • 指定された SharePoint Server アプリケーション サーバーにアクセスできません。

  • 特定のサーバーでネットワーク活動や負荷が過剰になっているため、指定されたアプリケーション サーバーの応答が遅くなっています。

解決方法

解決策 1: エラー ログを確認します。

  1. Windows イベント ビューアーを開きます。

  2. Windows アプリケーション イベント ログで、イベント ID 8049 を検索します。

  3. イベントの説明で、エラーが発生しているアプリケーション サーバーを確認します。

解決策 2: アプリケーション サーバーの接続を確認します。

  1. エラーが発生しているアプリケーション サーバーから、SharePoint の サーバーの全体管理 Web サイトを開きます。

  2. エラーが発生しているサーバーから [サーバーの全体管理] サイトにアクセスできない場合は、ネットワーク設定が正しいことと、SharePoint ファームに接続するための適切な権限がサーバーにあることを確認します。

解決策 3: エラーが発生しているサーバーで Visio Services が実行されていることを確認します。

  1. サーバーの全体管理 Web サイトの [ システム設定] セクションで、閲覧ウィンドウから [ このファームのサーバーの管理] をクリックします。

  2. エラーが発生しているアプリケーション サーバーで、Visio Services が実行されていることを確認します。

エラーが発生しているサービス アプリケーション用のサービス アプリケーション プロキシがある場合は、新しいサービス アプリケーションを作成します。

解決策 4: Visio Services を再起動します。

  1. [ サーバーの全体管理] ページの [ システム設定] セクションで、閲覧ウィンドウから [ このファームのサーバーの管理] をクリックします。

  2. [ サーバー] 列で、エラーが発生しているアプリケーション サーバーの名前をクリックします。 [ サーバーのサービス] ページが開きます。

  3. [ サービス] 列で [ Visio Graphics Service] を見つけ、[ 停止] をクリックしてから [ 開始] をクリックします。

解決策 5: 新しい Visio Services アプリケーションを作成します。

  1. [ サーバーの全体管理] Web サイトの [ アプリケーション構成の管理] セクションで、閲覧ウィンドウから [ サービス アプリケーションの管理] をクリックします。

  2. [ 種類] 列で、エラーが発生しているサービス インスタンスがある Visio Services アプリケーションの名前をクリックします。

  3. リボンの [ 削除] をクリックします。

  4. [ サービス アプリケーションの削除 ] ダイアログで、[OK] をクリック します

  5. 新しい Visio Services アプリケーションを作成します。

関連項目

概念

SharePoint Server で監視を計画する

その他のリソース

SharePoint Server で Visio Services を計画する

SharePoint Foundation の System Center Monitoring Pack

SharePoint Server 2016 の System Center Monitoring Pack

SharePoint Foundation の System Center Monitoring Pack

SharePoint Server の System Center Monitoring Pack