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回復の後に続く Node Not Ready エラーのトラブルシューティング

この記事は、Microsoft Azure Kubernetes Service (AKS) クラスター内のノードがノードの準備ができていない状態を表示した後、正常な状態に自動的に回復するシナリオのトラブルシューティングに役立ちます。

現象

ノードが準備ができていない状態であることを報告している間、アプリケーションの応答が停止していることがわかります。 ただし、ノードは自動的に復旧し、根本原因分析 (RCA) を探しています。

原因

この問題の原因として考えられるのは、次のシナリオです。

  • API サーバーは使用できません。また、デプロイに準備プローブを使用しています。

    ポッドが実行されていても準備ができていない場合、その状況は準備プローブが失敗していることを意味します。 準備プローブが失敗した場合、ポッドはサービスに接続されておらず、トラフィックはポッド インスタンスに転送されません。

  • 仮想マシン (VM) ホストエラーが発生します。 VM ホストエラーが発生したかどうかを判断するには、次の情報ソースをチェックします。

防止

この問題が今後発生しないようにするには、次の 1 つ以上のアクションを実行します。

  • サービス レベルが完全に支払われるようにします。
  • API サーバーへの要求と get 要求のwatch数を減らします。
  • ノード プールを正常なノード プールに置き換えます。

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