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Microsoft Entra IDへのディレクトリ同期が停止するか、同期が 1 日以上登録されていないことが警告されます

この記事では、Azure Active Directory 同期ツールのパフォーマンスの問題について説明します。 このツールは同期を停止するか、同期が 24 時間以上実行されていないレポートを表示します。

元の製品バージョン: Microsoft Entra ID、Microsoft Intune、Azure Backup、Office 365 Identity Management
元の KB 番号: 2882421

注:

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現象

次のいずれかの現象が発生します。

  • Microsoft Azure Active Directory 同期ツールは同期を停止します。
  • 過去 24 時間Microsoft Entra ID同期試行を登録しなかったという電子メール メッセージが表示されます。
  • ツールでは MIISClient.exe 、"Stopped-Server-Down" メッセージまたは "Stopped-Extension-DLL-Exception" メッセージが表示されます。
  • 1 つ以上のディレクトリ同期サービスを開始できません。

注:

既定では、ディレクトリ同期は 3 時間ごとに実行されます。

原因

この問題は、次の条件の 1 つ以上が当てはまる場合に発生する可能性があります。

  • ディレクトリ同期を設定するために構成ウィザードで使用された職場または学校アカウントには、次のいずれかの問題があります。

    • アカウントが削除されました。
    • アカウントが無効になりました。
    • アカウント パスワードの有効期限が切れています。
  • 1 つ以上のディレクトリ同期サービスのログオン アカウントには、次のいずれかの問題があります。

    • アカウントが削除されました。
    • アカウントが無効になりました。
    • アカウント パスワードの有効期限が切れています。

    注:

    ディレクトリ同期サービスのログオン アカウントは自動的に構成され、変更しないでください。

  • ディレクトリ同期に使用される管理者アカウントが変更されました。

  • ネットワーク接続に問題があります。

  • ディレクトリ同期サービスが停止しています。

解決方法

方法 1: サービスが開始されていることと、管理者アカウントがサインインできることを手動で確認する

  1. [ スタート] を選択し、[ 実行] を選択し、「 Services.msc」と入力して、[ OK] を選択します

  2. Microsoft Entra同期アプライアンス サービスを見つけて、サービスが開始されているかどうかをチェックします。 サービスが開始されていない場合は、サービスを右クリックし、[開始] を選択 します

    • Azure Active Directory 同期ツールを使用している場合は、 Azure Active Directory 同期サービスを探します。
    • Microsoft Entra Connect を使用している場合は、Microsoft Azure AD同期を探します。
  3. ディレクトリ同期に使用されている管理者アカウントがまだ存在することを確認します。 また、アカウントのサインインが許可されていることを確認します。 アカウントがまだ存在する場合は、パスワードをリセットし、サインインできることを確認します。 メッセージが表示されたら、パスワードを変更します。

    ディレクトリ同期の構成に使用されるグローバル管理者アカウントがわからない場合は、ディレクトリ同期アプライアンスをインストールしたサーバーで次の手順を実行します。

    1. %ProgramFiles%\Microsoft Azure AD Sync\UIShell\移動し、Miisclient.exe を実行します。

      注:

      Microsoft Entra Connect または Azure Active Directory 同期サービスを使用している場合は、[スタート] を選択し、同期サービスを検索して開きます。

    2. [コネクタ] を選択し、Microsoft Entra コネクタをダブルクリックします。

    3. [ 接続] を選択します

    4. UserName 値を書き留めます。 ディレクトリ同期の構成に使用されるグローバル管理者アカウントです。

  4. ディレクトリ同期サーバーで、Microsoft Entra同期アプライアンス構成ウィザードを実行します。 ディレクトリ同期に使用する管理者アカウントの新しいパスワードを入力し、ウィザードの残りの手順に従います。

  5. メッセージが表示されたら、[ディレクトリ同期のチェックを強制する] ボックスを選択します。

方法 2: ディレクトリ同期サービスのログオン アカウントに関する問題を解決する

  1. [ スタート] を選択し、[ 実行] を選択し、「Services.msc」と入力して、[ OK] を選択します

  2. Microsoft Entra同期アプライアンス サービスを見つけます。

    • Azure Active Directory 同期ツールを使用している場合は、 Azure Active Directory 同期サービスを探します。
    • Microsoft Entra Connect を使用している場合は、Microsoft Azure AD同期を探します。サービスを右クリックし、[プロパティ] を選択します。 [ログオン] タブ 、一覧表示されているアカウント名をメモします。

    注:

    ローカル システム アカウントとしてログオンするディレクトリ同期サービスの再構成はサポートされていないため、問題が発生する可能性があります。

  3. ドメイン コントローラーまたは管理ツールがインストールされているコンピューターで、Active Directory ユーザーとコンピューター (Dsa.msc) を開き、ドメイン名を右クリックし、[検索] を選択します。 手順 2 で説明したアカウントの名前を入力し、[ 今すぐ検索] を選択します。

    • アカウントが見つかる場合は、手順 4 に進みます。
    • アカウントが見つからない場合は、削除されている可能性があります。 このアカウントを復元する方法の詳細については、「 Active Directory ごみ箱のステップ バイ ステップ ガイド」を参照してください。 アカウントを復元できない場合は、ディレクトリ同期クライアントをアンインストールしてから再インストールする必要があります。
  4. アカウントを右クリックし、[プロパティ] を選択 します。 [ アカウント ] タブの [ アカウント オプション ] で、次の手順を実行します。

    1. [パスワードの有効期限が切れないことを確認チェック] ボックスがオンになっていることを確認します。
    2. [アカウント] ボックスがオフになっていることを確認チェック。 次に、次のいずれかのアクションを実行します。
    • [アカウントが無効になっているチェック] ボックスがオンになっている場合は、オフにしてアカウントを有効にします。 次に、Microsoft Entra同期アプライアンス サービスを再起動します。 これを行うには、[ スタート] を選択し、[ 実行] を選択し、「Services.msc」と入力して、[ OK] を選択します。 サービスを見つけて右クリックし、[再起動] を選択 します
      • Azure Active Directory 同期ツールを使用している場合は、 Azure Active Directory 同期サービスを探します。
      • Microsoft Entra Connect を使用している場合は、Microsoft Azure AD同期を探します。
    • [アカウントが無効になっているチェック] ボックスが既にオフになっている場合は、手順 5 に進みます。
  5. [アカウントが無効になっているチェック] ボックスが既にオフになっている場合は、アカウントのパスワードが手動で変更された可能性があります。 新しいパスワードを設定するには、Active Directory ユーザーとコンピューター開き、アカウントを見つけて右クリックし、[パスワードのリセット] を選択してパスワードをリセットします。 次の手順でパスワードを使用する必要があるため、設定したパスワードに注意してください。

  6. ディレクトリ同期サービスのログオン アカウントにパスワードを設定します。

    1. [ スタート] を選択し、[ 実行] を選択し、「Services.msc」と入力して、[ OK] を選択します

    2. 使用しているクライアントに応じて、次のサービスのパスワードを設定します。 これを行うには、適切なサービスを右クリックし、[ プロパティ] を選択し、[ ログオン ] タブを選択し、パスワードを入力します。

      Microsoft Entra同期クライアント Microsoft Entra Connect

      Forefront Identity Manager Synchronization Service
      SQL Server (MOSONLINE) (存在する場合)
      Azure Active Directory Sync Service

      Azure AD Sync
    3. 新しいパスワードを設定したサービスまたはサービスを開始します。

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