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Azure Windows VM で失敗した信頼関係のトラブルシューティング

適用対象: ✔️ Windows VM

この記事では、Azure Windows 仮想マシン (VM) 内のワークステーションとプライマリ ドメインの間の信頼関係の失敗をトラブルシューティングする方法について説明します。

この記事で Azure の問題に対処できない場合は、MSDN および Stack Overflow の Azure 関連フォーラムを参照してください。 問題をこれらのフォーラムに投稿するか、または Twitter の @AzureSupport に投稿できます。 Microsoft Azure サポート 要求送信することもできます

サポートリクエストを送信するには、Azure サポートページに移動しGet サポートを選択します。

症状

VM へのリモート デスクトップ プロトコル (RDP) 接続を完了できず、"このワークステーションとプライマリ ドメインの間の信頼関係が失敗しました" というエラーが表示されます。

このワークステーションとプライマリ ドメインの間の信頼関係が失敗したエラーのスクリーンショット。このスクリーンショットには、[OK] ボタンも含まれています。

原因

この VM とプライマリ ドメインの間の Active Directory セキュリティで保護されたチャネルが壊れています。 このエラーは、シークレット パスワードがドメイン コントローラーで同じ値に設定されていないため、コンピューターがドメイン内のドメイン コントローラーとのセキュリティで保護された通信を確立できないことを示しています。

解決策

VM で次の手順を完了します。 使用可能な場合は、ローカル ユーザーを使用して、リモート デスクトップ接続 (RDC) 経由で VM に接続してみてください。 RDC を使用して VM に接続できない場合は、Azure VM の代替 リモートトラブルシューティング ツールを試してください

ドメイン コントローラーへの接続を確認する

  1. VM が使用しているドメイン コントローラーを見つけるには、CMD.exeに次のコマンドを入力します。

    set | find /i "LOGONSERVER"

  2. ドメイン コントローラーへのネットワーク接続を確認します。 たとえば、 Test-Connection コマンドレットを使用して、手順 1 で識別したドメイン コントローラーの完全修飾ドメイン名 (FQDN) への接続をテストできます。

  3. VM からドメイン コントローラーへの接続がない場合は、ネットワーク パスのトラブルシューティングを行います。 Network Watcher 診断 はこのトラブルシューティングに役立つ場合があります。

セキュリティで保護されたチャネルの正常性を確認する

  1. PowerShell を使用して、'Test-ComputerSecureChannel' コマンドレットを実行して、セキュリティで保護されたチャネルが正常かどうかを確認します。

    例:

    Test-ComputerSecureChannel -verbose

  2. セキュリティで保護されたチャネルが正常な場合は、ドメイン ユーザーを使用して VM への RDP 接続を試みます。 セキュリティで保護されたチャネルが正常でない場合は、セキュリティで保護されたチャネルの修復を試みます。

セキュリティで保護されたチャネルを修復する

セキュリティで保護されたチャネルが正常でない場合は、修正を試みるか、VM をドメインに再度参加させます。

  1. PowerShell を使用して、'Test-ComputerSecureChannel' コマンドレットを実行して、セキュリティで保護されたチャネルを修復します。

    Test-ComputerSecureChannel -Repair

  2. セキュリティで保護されたチャネルが修復されない場合は、コンピューターのパスワードをリセットします。

コンピューターのパスワードをリセットする

セキュリティで保護されたチャネルを修復できなかった場合は、コンピューターのパスワードをリセットしてみてください。

  1. PowerShell を使用して、'Reset-ComputerMachinePassword' コマンドレットを実行して、VM のマシン パスワードをリセットします。

    例:

    $cred = Get-Credential
    Invoke-Command -ComputerName "Server01" -ScriptBlock {Reset-ComputerMachinePassword -Credential $using:cred}
    
  2. セキュリティで保護されたチャネルが再確立されない場合は、ドメインから VM を削除し、ドメインに再参加します。

ドメインから VM を削除し、ドメインに再参加する

最後のオプションとして、ドメインから VM を削除し、ドメインに再参加します。

  1. PowerShell を使用して、"Remove-Computer" コマンドレットを実行して、ドメインから VM を削除します。

    例:

    'Remove-Computer -UnjoinDomaincredential Domain01\Admin01 -PassThru -Verbose -Restart'
    
  2. PowerShell を使用して、"コンピューターの追加" コマンドレットを実行して、VM をドメインに再参加させます。

    例:

    'Add-Computer -ComputerName Server01 -LocalCredential Server01\Admin01 -DomainName Domain02 -Credential Domain02\Admin02 -Restart -Force'
    

その他のリソース

詳細な概念: セキュリティで保護されたチャネルの説明

お問い合わせはこちらから

質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。