Share via


「Windows はシステムの構成を完了できませんでした」のトラブルシューティング

この記事では、Sysprep プロセスが Azure 仮想マシン (VM) の起動を妨げる問題を解決する手順について説明します。

現象

ブート 診断を使用して VM のスクリーンショットを表示すると、Windows セットアップの実行中に Windows のインストール エラーが表示されます。 このエラーでは、次のメッセージが表示されます。

Windows でシステムの構成を完了できませんでした。 構成を再開するには、コンピューターを再起動します。 セットアップがサービスを開始しています。

Windows セットアップがサービスを開始しているときに Windows をインストールするエラーを示すスクリーンショット。

原因

このエラーは、オペレーティング システム (OS) が Sysprep プロセスを完了できない場合に発生します。 このエラーは、一般化された VM の初期起動を試みた場合に発生します。 この問題が発生した場合は、イメージが展開不可能な状態にあり、復旧できないため、一般化されたイメージを再作成します。

ソリューション

ヒント

VM の最新のバックアップがある場合は、そのバックアップから VM の復元を試行して、起動の問題を修正することができます。

この問題を解決するには、 イメージの準備/キャプチャに関する Azure ガイダンスに 従い、新しい一般化されたイメージを準備します。

お問い合わせはこちらから

質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。