この記事は、Internet Explorer で Secure Sockets Layer (SSL) を使用して Web ブラウザーが Web サイトに接続できない問題を解決するのに役立ちます。
元の製品バージョン: インターネット インフォメーション サービス 8.0、Internet Explorer 10、Internet Explorer 9
元の KB 番号: 2744241
現象
Windows ベースのオペレーティング システムを実行しているコンピューターに Web ブラウザーがインストールされている。 Web ブラウザーを使用して、セキュリティで保護された Secure Sockets Layer (SSL)/Hypertext Transfer Protocol Secure (HTTPS) 接続経由で Web サイトを表示しようとするとします。 この構成では、SSL/HTTPS 経由で Web サイトに接続できません。 問題が発生すると、Web ブラウザーのバージョンによっては、次のようなエラー メッセージが表示されることがあります。
サーバーまたは DNS エラーが見つかりません
または
この Web サイトのセキュリティ証明書には問題があります。 セキュリティ証明書の問題は、ユーザーをだましたり、サーバーに送信したデータを傍受しようとしたりすることを示している可能性があります
または
Internet Explorer で Web ページを表示できない
問題が発生すると、標準のハイパーテキスト転送プロトコル (HTTP) 接続 (SSL を使用しない) 経由で同じ Web サイトを表示でき、SSL/HTTPS 接続経由で他の Web サイトを表示できる場合があります。
原因
この問題は、クライアントが SSL 経由で参照しようとしている Web サイトに、1024 ビット未満の暗号化キーを使用する RSA セキュリティ証明書があるために発生します。 KB2661254による変更に関連するセキュリティへの影響の詳細については、「 Microsoft セキュリティ アドバイザリ 2661254」を参照してください。
解決方法
この問題を解決するには、 Microsoft セキュリティ アドバイザリ 2661254 を参照してください。
Web サイト管理者であり、Web サイトが Microsoft インターネット インフォメーション サービス (IIS) で実行されている場合は、SSL 証明書の取得とインストールの詳細については、後述の「詳細情報」セクションを参照してください。