Microsoft Dynamics 365 メールボックスに "Http server returned Forbidden exception" エラーが表示される

この記事では、Dynamics 365のメールボックス レコードの [メールボックスのテスト & 有効にする] ボタンを選択したときに発生するエラーの解決策について説明します。

適用対象:Microsoft Dynamics 365
元の KB 番号: 4483440

現象

Dynamics 365のメールボックス レコードで [テスト & メールボックスを有効にする] ボタンを選択すると、テスト結果セクションに [失敗] と表示され、次のアラートがログに記録されます。

電子メール サーバーへのセキュリティで保護された接続の確立中にエラーが発生したため、「メールボックスがDynamics 365に接続されました」というメール メッセージを送信できません。 メールボックス [メールボックス名] が同期されませんでした。 電子メール サーバー プロファイルMicrosoft Exchange Onlineの所有者に通知されました。
Email サーバー エラー コード: Http サーバーから Forbidden 例外が返されました。

[詳細] を選択すると、次の詳細が表示されます。

"エラー: System.Net.WebException: 要求が HTTP 状態 403: Forbidden で失敗しました。
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage メッセージ, WebResponse 応答, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
at Microsoft.Crm.Async.EmailConnector.ExchangeServiceBinding.EndCreateItem(IAsyncResult asyncResult)
at Microsoft.Crm.Async.EmailConnector.ExchangeOutgoingEmailProvider.EndCreateItem()"

原因

Dynamics 365 Exchange Web Services (EWS) 要求を使用して Microsoft Exchange と通信します。 EWS が無効になっている場合、このエラーが発生します。 次の内容は、EXCHANGE で EWS が無効または制限される可能性のあるいくつかの方法です。

  1. EWS がメールボックスに対して無効になっている
  2. EWS は、organization全体で無効になっています
  3. EwsApplicationAccessPolicyEnforceAllowList に設定されており、the EwsAllowListDynamics 365 (CRM) からのアクセスは許可されません。
  4. EwsApplicationAccessPolicyEnforceBlockList に設定され、the EwsBlockListDynamics 365 (CRM) が含まれます。

解決方法

問題が一部のメールボックスでのみ発生する場合は、メールボックスに対して EWS が無効になっている場合にチェックします。

  1. 最初にチェック、EWS がメールボックスに対して無効になっているかどうかを確認します。 次の PowerShell コマンドを使用します。

    Get-CASMailbox <mailbox-alias> | ft EwsEnabled
    
  2. EwsEnabledFalse に設定されている場合は、次の PowerShell コマンドを使用して、メールボックスの Exchange Web サービス (EWS) を有効にします。

    Set-CASMailbox <mailbox-alias> -EwsEnabled $True
    

    重要

    このコマンドを実行した後、設定の変更が有効になるまでに最大 120 分かかる場合があります。

すべてのメールボックスで問題が発生した場合は、EWS が organization レベルで無効になっているか、EWSAllowList を使用して EWS トラフィックが許可される内容を制限している場合にチェックします。

  1. EWS 設定のいずれかが構成されているかどうかを確認するには、次の PowerShell コマンドを使用します。

    Get-OrganizationConfig |ft Name, EwsEnabled,EwsApplicationAccessPolicy,EwsBlockList,EwsAllowList
    
  2. EwsEnabled が False に設定されていないことを確認します。 現在 False に設定されている場合は、次のコマンドを使用して EwsEnabledTrue に設定できます。

    Set-OrganizationConfig -EwsEnabled $True
    

    重要

    このコマンドを実行した後、設定の変更が有効になるまでに最大 120 分かかる場合があります。

  3. EnforceAllowList に設定されていて、 EwsAllowList に CRM (例: CRM/*) の値が含まれていない場合EwsApplicationAccessPolicyは、Dynamics 365 (CRM) が Exchange と通信できなくなります。 次のコマンドを使用して、CRM/* と許可するその他のアプリケーション (<次の例では PreviousAllowList> ) を含むようにリストを更新します。

    Set-OrganizationConfig -EwsApplicationAccessPolicy:EnforceAllowList -EwsAllowList:CRM/*,<PreviousAllowedList>
    

    重要

    このコマンドを実行した後、設定の変更が有効になるまでに最大 120 分かかる場合があります。

  4. EnforceBlockList に設定されていて、EwsAllowList に CRM (例: CRM/*) の値が含まれている場合EwsApplicationAccessPolicy、Dynamics 365 (CRM) が Exchange と通信できなくなります。 CRM を含めなくなったリストを更新するには、次のコマンドを使用します。

    Set-OrganizationConfig -EwsApplicationAccessPolicy:EnforceBlockList -EwsBlockList:<PreviousBlockList WITH CRM REMOVED>
    

    重要

    このコマンドを実行した後、設定の変更が有効になるまでに最大 120 分かかる場合があります。

詳細

PowerShell を使用して Exchange 設定を変更し、EWS へのアクセスを制御する方法の詳細については、次の記事を参照してください。