この記事では、Microsoft Dynamics GP の [払い戻しチェックの作成] ウィンドウで Process を選択したときに発生するエラーの解決策について説明します。
適用対象: Microsoft Dynamics GP
元の KB 番号: 933027
重要
この記事の手順に従う前に、問題が発生した場合に復元できるデータベースの完全なバックアップ コピーがあることを確認してください。
症状
[払い戻しチェックの作成] ウィンドウで Process を選択し、 Transferを選択すると、次の問題が発生する可能性があります。
シナリオ 1
次のエラー メッセージが表示されます。
データ入力エラーは、バッチ RMPMXFR UserID に存在します。 [バッチ回復] ウィンドウを使用して、このバッチを処理します。
注意
UserID は、払い戻しチェックを処理しているユーザーのログオン名のプレースホルダーです。 このログオン名はバッチ名の一部です。
[払戻チェックの設定] ウィンドウで [買掛金の支払チェックを自動で開く] チェック ボックスがオンになっている場合、[買掛金の印刷チェック] ウィンドウが表示される前に、このエラー メッセージが表示されます。
エラー メッセージが表示されたら、 OK を選択します。 チェック バッチを印刷し続ける場合は、次のエラー メッセージが表示されます。
このチェック バッチでエラーが見つかりました。 印刷前にエラーを修正してください。
注意
払戻チェックで使用されている GL アカウントのいずれかに対して多次元分析 (MDA) を有効にしていて、MDA 分析グループが必須に設定されていても、既定の MDA コード ID が定義されていない場合は、同じエラーが発生し、PM20000 テーブルに空白レコードも作成されます。 その後、破損したレコードをPM20000テーブルから手動で削除する必要があります。 この問題を回避するには、MDA アカウント/分析グループの既定の MDA 分析コード ID を 100% に設定するか、アカウントに割り当てられた MDA 分析グループ ID を Required ではなく Optional に設定します。
シナリオ 2
- 仕入先トランザクションは、[買掛金トランザクション照会 - 仕入先] ウィンドウで表示します。
- 仕入先の行を選びます。
- Tab キーを押してフィールドから移動します。
このシナリオでは、次のエラー メッセージが表示されます。
ストアド プロシージャ createSQLTmpTable は、DBMS 2627、Microsoft Dynamics GP:0 の結果を返しました。
[買掛金トランザクション照会 - 仕入先] ウィンドウには、払戻チェックの処理に起因する次の 2 つの作業ドキュメントが含まれています。
- 払い戻しの小切手支払い
- その他の料金
注意
[買掛金トランザクション照会 - 仕入先] ウィンドウに重複する伝票が表示されません。
[ Work ] チェック ボックスと [ History ] チェック ボックスをオフにし、[ Redisplayを選択すると、別のその他の請求伝票が表示されます。 このドキュメントの状態は [開く] で、重複するエラー メッセージは表示されません。 現在開いている文書をドリルダウンすると、雑費に金額が含まれていないため、破損しているようです。 次のチェック ボックスを同時に選択した場合、このドキュメントは表示されません。
- 作業
- オープン
- HISTORY
原因
シナリオ 1 の原因
この問題は、次のいずれかの理由により、Microsoft Dynamics GP の買掛金管理での雑費の転記が中断された場合に発生します。
- 買掛金勘定は仕入先勘定メンテナンスウィンドウに割り当てられておらず、また、伝票勘定設定ウィンドウにも割り当てられていません。
- 会社はアカウント レベルのセキュリティに登録されています。 また、払戻チェックを処理しているユーザーには、仕入先勘定メンテナンスウィンドウまたは転記勘定設定ウィンドウで、指定された買掛金勘定を使用する権限がありません。
- Microsoft Dynamics GP の買掛金勘定で払戻が行われる会計期間が終了します。
- 払い戻し小切手の処理は、処理中断またはネットワーク接続の中断に遭遇しました。
原因またはシナリオ 2
この問題は、小切手が支払っている雑費の転記が中断された場合に発生します。 その他の料金は金額なしで部分的に転記され、トランザクションはバッチに残ります。
解決方法
シナリオ 1 の解決策
この問題を解決するには、「 Cause 」セクションのシナリオ 1 で考えられる原因の一覧から原因を特定し、問題を修正します。 問題を解決するには、次の手順に従います。
- Microsoft Dynamics GP で購入用に既定の買掛金勘定が設定されていること、およびアカウントが [転記勘定設定] ウィンドウの Display 一覧に表示されていることを確認します。
- ユーザーが[組織構造一括割当]ウィンドウで買掛金勘定にアクセスできることを確認します。 [組織構造の一括割り当て] ウィンドウを開くには、カード メニューの システム にカーソルを合わせ、組織の割り当てを選択します。
- 通常のセキュリティまたは高度なセキュリティを使用して、ユーザーが買掛金勘定ウィンドウにアクセスできることを確認します。
- ドキュメントが転記される会計期間が、購買管理の [会計期間の設定] ウィンドウで [開く] の状態になっていることを確認します。 [会計期間の設定] ウィンドウを開くには、Tools メニューの Setup をポイントし、Company をポイントして、Fiscal Periods を選択します。
- チェック バッチを使用可能にしてから、RMPMXFR バッチを使用可能にします。 これを行うには、Microsoft Dynamics GP の [転記]、[受信]、[ビジー]、[マーク済み]、[ロック済み]、[編集済み] のいずれかの状態でバッチが保持される場合の手順に従ってください。
- シナリオ 2 で問題が発生した場合は、シナリオ 2 の解決策に進みます。
シナリオ 2 の解決策
この問題を解決するには、次の手順に従ってください。
チェック バッチをまだ使用できない場合は、チェック バッチを使用できるようにします。 これを行うには、KB - バッチは、Microsoft Dynamics GP の [転記]、[受信]、[ビジー]、[マーク済み]、[ロック済み]、[編集済み] のいずれかの状態に保持されますの手順に従います。
ドキュメントが検証されたら、重複するドキュメントを削除します。
メモ
ステータスが [開く] のドキュメントが正しく転記され、ステータスが [作業] のドキュメントが修正されない場合は、バッチを削除して重複するドキュメントを削除します。 状態が [開く] のドキュメントが破損している場合は、状態が [開く] のドキュメントを削除し、ステータスが [作業] のドキュメントを転記できるようにします。 (金額がない場合、またはドキュメントの日付が 00/00/0000 の場合、ドキュメントが破損している可能性があります)。このドキュメントを削除するには、SQL Query Analyzer で次の削除スクリプトを使用するか、サポート管理者コンソールを使用します。
Delete PM20000 where Dex_Row_ID = XX
注記
XX は、その他の料金の Dex 行 ID のプレースホルダーです。
その他の請求伝票を転記する必要がある場合は、伝票を転記します。
チェックバッチを復旧した後、チェックバッチを印刷してから、チェックバッチを転記します。 詳細については、「Microsoft Dynamics GP の 転記中、受信中、ビジー中、マーク済み、ロック済み、または編集済みの状態で保持されるバッチに関する KB」を参照してください。
詳細
払い戻しチェックを使用するには、次の要件に注意してください。
- 払戻チェック機能を登録する必要があり、Microsoft Dynamics GP で買掛金勘定と売掛金勘定の両方を購入している必要があります。
- [払戻チェックのセットアップ] ウィンドウを構成する必要があります。
- 仕入先レコードは、顧客に対して作成する必要があります。
- 顧客と仕入先の間のリレーションシップは、[顧客/仕入先関係] ウィンドウで確立する必要があります。
払い戻しチェックが処理されると、Microsoft Dynamics GP は、顧客が請求書を過剰に支払ったと見なし、会社が余分な現金支払いを返金することを要求しています。 払い戻しを処理すると、デビットメモが作成されます。 デビットメモは、超過現金支払に適用されます。 その後、その他の料金が作成されます。 その他の料金は、仕入先に直ちに転記されます。 このその他の請求伝票は、小切手を使用して支払のために選択されます。