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Integration Manager を削除またはインストールするときの初期化エラーのトラブルシューティング

この記事では、Microsoft Dynamics GP で Integration Manager を削除またはインストールするときに初期化エラーが発生する問題の原因に対応する解決策について説明します。

適用対象: Microsoft Dynamics GP
元の KB 番号: 861816

症状

Integration Manager を削除またはインストールすると、セットアップの初期化中に次のエラーが発生することがあります。

  • サポート ファイルの抽出中にエラーが発生しました
  • Ikernel.exeのインストール中にエラーが発生しました (任意の数の 0x)
  • アクセスが拒否されました
  • タイプ ライブラリ/DLL の読み込み中にエラーが発生しました

原因

セットアップの初期化エラーは、多くの要因によって発生する可能性があります。 これは、考えられる原因の完全な一覧ではありません。

  • コンピューターに対する十分なアクセス許可がありません。
  • InstallShield セットアップを実行したばかりの場合、インストールの最後にエンジンがクリーンアップされるまでに数秒かかります。
  • Ikernel.exeがメモリ内にあります。
  • 一時フォルダーには追加のファイルがあります。
  • Program Files\Common Files\InstallShield\Engine フォルダーが存在します。
  • コア Windows ファイルが破損しているか、見つかりません。
  • Stdole32.tlb ファイルがありません。
  • 十分な COM アクセス許可がありません。

解決方法

この問題を解決するには、問題の原因に対応する方法を使用します。

  • コンピューターに対する十分なアクセス許可がありません。

    Microsoft Windows 2000 ベースのコンピューター、Windows XP ベースのコンピューター、または Windows 2003 ベースのコンピューターを使用している場合は、InstallShield Professional 6.x セットアップを実行するための管理アクセス許可が必要です。 正しいアクセス許可があることを確認します。

  • InstallShield セットアップを実行したばかりの場合、インストールの最後にエンジンがクリーンアップされるまでに数秒かかります。

    この間、Ikernel.exe (エンジン ファイル) は前のプロセスのメモリ内で実行されています。そのため、別のセットアップを開始することはできません。 数秒待ってから、セットアップをもう一度実行します。

  • Ikernel.exeがメモリ内にあります。

    Ikernel.exeがメモリ内にないことを確認します。 それである場合は、その時点でセットアップが実行されていない場合、そのタスクを停止します。

  • 一時フォルダーには追加のファイルがあります。

    一時フォルダーをクリーンアップします。

  • Program Files\Common Files\InstallShield\Engine フォルダーが存在します。

    Program Files\Common Files\InstallShield\Engine フォルダーを削除し、セットアップをもう一度実行します。

  • コア Windows ファイルが破損しているか、見つかりません。

    Internet Explorer 6.x 以降のバージョンを再インストールすると、コンピューターから破損している、または不足しているコア Windows ファイルの多くが修復されます。 そのため、Internet Explorer 6.x 以降のバージョンと最新の Windows Service Pack を再インストールすることをお勧めします。

  • Stdole32.tlb ファイルがありません。

    これは、コア Windows ファイルであり、コンピューターに存在する必要があります。 このファイルがあることを確認するか、対象のコンピューターと同じオペレーティング システムを実行している別のコンピューターからこのファイルを取得します。

  • 十分な COM アクセス許可がありません。

    Ikernel.exeのインストール時に「アクセスが拒否されました」エラーが表示された場合は、以下の手順に従って必要な権限を付与してください。

    1. コマンド プロンプト ウィンドウで、「 dcomcnfg.exe」と入力します。 この手順では、 Distributed COM 構成プロパティ ダイアログ ボックスを開きます。
    2. [既定のセキュリティ] タブを選択します。
    3. [既定のアクセス許可] セクションで、[既定の 編集 ] ボタンを選択します。
    4. ユーザー名の横に [アクセスを許可する] が表示されていることを確認します。 ユーザー名の横に [アクセスを許可する] が表示されない場合は、既存のプロファイルを変更します。 または、必要なアクセス許可を持つ新しいプロファイルを作成します。
    5. すべての変更を適用し、セットアップをもう一度実行します。