この記事では、Microsoft Dynamics 365 でメールボックスをテストして有効にしようとしたときに発生するエラーの解決策について説明します。
適用対象: Microsoft Dynamics 365
元の KB 番号: 4513810
現象
Dynamics 365 で メールボックスをテストして有効に しようとすると、テスト結果セクションに エラーが表示され、次のいずれかのアラートがログに記録されます。
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"メールボックスが Dynamics 365 に接続されました" という電子メール メッセージを送信しているときに、メールボックスの場所を特定できませんでした。 メールボックス <メールボックス名> は同期されませんでした。 関連付けられた電子メール サーバー プロファイル <電子メール サーバー プロファイル名> の所有者に通知されました。
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メールの受信中にメールボックス <Mailbox Name> の場所を特定できませんでした。 関連付けられた電子メール サーバー プロファイル <電子メール サーバー プロファイル名> の所有者に通知されました。 システムは、後でもう一度電子メールを受信しようとします。
原因
アラートは、Exchange オンプレミスに接続し、Dynamics 365 の電子メール サーバー プロファイル レコードが [ サーバーの場所の自動検出 ] 設定を [はい] に設定して構成されている場合に発生する可能性があります。 このオプションを有効にすると、Exchange Web Services (EWS) の URL を指定する必要はありません。 代わりに、Dynamics 365 は Exchange の自動検出 を使用して正しい場所を取得しようとします。 自動検出サービスに問題がある場合、または正しく構成されていない場合は、アラートが発生する可能性があります。
解決方法
この問題を解決するには、Exchange の自動検出の問題を修正するか、[サーバーの場所の 自動検出 ] 設定を [いいえ ] に変更し、EWS URL を指定します。
自動検出サーバーの場所の設定を変更するには、次の手順に従います。
"システム管理者" セキュリティ ロールを持つユーザーとして Dynamics 365 Web アプリケーションにサインインします。
設定>Email 構成>Email サーバー プロファイルに移動します。
Exchange オンプレミス構成の電子メール サーバー プロファイル レコードを開きます。
[ サーバーの場所の自動検出 ] 設定を [いいえ] に変更します。
[ 受信サーバーの場所 ] フィールドと [送信サーバーの 場所 ] フィールドに EWS URL を入力します。 たとえば、
https://mail.yourdomain.com/EWS/Exchange.asmx
のようにします。[保存] を選択します。