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UI 要素が強調表示されていないか、UI または Web 要素の上にマウス ポインターを置くとエラーが発生する

この記事は、Citrix や Microsoft リモート デスクトップ プロトコル (RDP) 環境などの仮想デスクトップで UI 要素ピッカーを使用するときに発生する可能性がある問題を解決するのに役立ちます。

現象

UI 要素ピッカー が有効になっている Citrix または RDP ウィンドウ内のアプリケーションまたは Web ページの UI または Web 要素の上にマウス カーソルを置くと、次の情報が表示されることがあります。

  1. 要素が強調表示されていません。

  2. 仮想デスクトップで Power Automate エージェントを有効にすることに関するエラー メッセージ。

    仮想デスクトップで UI オートメーションを有効にする
    仮想デスクトップでの UI 要素の使用を自動化するには、仮想デスクトップ用の Power Automate エージェントがリモート コンピューターにインストールされ、実行されていることを確認します。

    仮想デスクトップで UI オートメーションを有効にするエラーのスクリーンショット。

原因

リモート エージェント コンポーネントとの通信が機能しません。

解決策

  1. Power Automate Citrix または RDP プラグインが登録されていることを確認します。

    1. 仮想デスクトップ プラットフォーム (Citrix Desktop、Citrix Virtual Apps、リモート デスクトップ アプリ、または Windows RDP 通信を使用したリモート デスクトップ) がアクティブな場合は、Power Automate のヘルプ>トラブルシューティング ツールに移動してトラブルシューティング ツールを実行します。

      ヒント

      トラブルシューティング ツールは、コンソールとフロー デザイナーを使用して、 ヘルプ>下の専用メニューから手動で開くことができます。 また、プロセス ファイル PAD.Troubleshooter.exeを使用して開くこともできます。これは、Power Automate for desktop のインストール フォルダーにあります。

    2. UI/Web オートメーションの問題のトラブルシューティングを実行して、通信の診断を表示します。 Citrix または RDP セクションにエラーが表示された場合は、それを展開して詳細と解決策を確認します。

    3. エラーの詳細が "アクセスが拒否されました" と示されている場合、リモート コンピューター上のポリシーは、ユーザー プロファイル フォルダーから特定のエージェント コンポーネントを実行することを禁止します。 これらのディレクトリからの実行可能ファイルの実行を許可するには、管理者に問い合わせてください。

      Access が拒否されたエラーの詳細を示す Power Automate トラブルシューティング ツールのスクリーンショット。

  2. トラブルシューティング ツールでリモート エージェントが実行されていないことが示されている場合は、Citrix セッションまたは RDP セッションでエージェントが実行されているかどうかを確認します。

    仮想デスクトップ プラットフォームがアクティブな場合は、エージェント アイコンのトレイ アイコンを確認します。 アイコンが存在する場合は、そのアイコンの上にマウス ポインターを合わせて、まだ実行中であることを確認します。 表示されている場合は、トレイ アイコンを右クリックしてメニューを開き、[ 状態] を選択します。 エージェントの状態とエラーの理由が表示されます。

    仮想デスクトップの Power Automate エージェントが切断されていることを示すエージェント アイコンのスクリーンショット。

  3. エージェントが実行されていないことが確認され、Citrix が使用中の場合は、すべての Citrix サーバーにエージェントがインストールされていることを確認します。

  4. エージェントが実行されている場合は、エージェントのトレイ アイコンの状態に基づいて次の条件を確認します。

    • システム上のデバイスが機能していない: Citrix プラグインがホスト システムに読み込まれていません。

      この問題をトラブルシューティングするには、仮想デスクトップ プラットフォームがアクティブな状態で トラブルシューティング ツール を実行し、 UI オートメーション セクションでエラーを確認します。

    • Citrix 仮想チャネル ポリシーが有効: Citrix仮想チャネル許可リスト ポリシーが [有効] または [既定] に設定されています。

      このポリシーの既定の設定は [有効] または [既定値] です。 ただし、このポリシーが無効になっていない場合、Power Automate エージェントはデスクトップ用 Power Automateと通信できません。 通信の問題を解決するには、Citrix 管理者と協力してポリシーを [無効] に設定し、ポリシーの適用後に Citrix マシンが再起動されるようにします。

    • Citrix VDA バージョン < 2407: Citrix の仮想チャネル許可リスト ポリシーが [有効] または [既定] に設定されています。

      このポリシーの既定の設定は [有効] または [既定値] です。 ただし、このポリシーが無効になっていない場合、Power Automate エージェントはデスクトップ用 Power Automateと通信できません。 通信の問題を解決するには、Citrix 管理者と協力してポリシーを [無効] に設定し、ポリシーの適用後に Citrix マシンが再起動されるようにします。

    • Citrix VDA バージョン >= 2407: 以前の 仮想チャネル許可リスト ポリシーは 既定のままですが、別のポリシーを設定する必要があります。

      次の値を使用 して、DVC ポリシーの仮想チャネル許可リスト を設定します。

      • C:\Program Files (x86)\Power Automate agent for virtual desktops\PAD.RDP.ControlAgent.exe,Microsoft.Flow.RPA.Desktop.UIAutomation.RDP.DVC.Plugin,PAD\CONTROL

      • C:\Users\*\AppData\Local\Microsoft\Power Automate Desktop\RDP Automation Agents\*\PAD.RDP.AutomationAgent.exe,Microsoft.Flow.RPA.Desktop.UIAutomation.RDP.DVC.Plugin,PAD\UIA

      ポリシーを適用した後、Citrix マシンが再起動されていることを確認します。

詳細

仮想デスクトップでの自動化

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