次の方法で共有


フローの実行履歴に表示される "フローのトリガーに問題があります" というエラーが表示される

この記事では、フローの実行履歴に フローのトリガー エラーに問題がある可能性がある問題の解決策を示します。

適用対象: Power Automate
元の KB 番号: 4540228

現象

フローの実行履歴に次のバナーが表示される場合があります。

フローの実行履歴のエラーのスクリーンショット。

原因

フローのトリガーでエラーが発生すると、バナーが表示されます。 バナーの目的は、フローが実行されない問題のあるトリガーをユーザーに通知することです。 バナーは、フローに最初の実行がなく、実行履歴が使用できない場合に特に役立ちます。

解決方法

トリガーが失敗した理由と問題を解決する方法を理解するには:

  1. トリガーの修正リンクを選択します。

  2. 失敗したトリガーが表示されます。 トリガーを選択して、基になるエラー メッセージを調べます。

    基になるエラー メッセージを検査するトリガーを選択するスクリーンショット。

上記の例では、指定したフォルダーが SharePoint ライブラリに見つからなかったため、トリガーが失敗しました。 修正するには、フォルダー名を有効な名前に更新します。

4xx 状態コードによるトリガーエラーは、通常、ユーザーが修正する必要があるエラーです。 一般的な問題は次のとおりです。

  • フローが使用している接続の変更 (パスワードの有効期限切れなど)。
  • 無効なトリガー入力。
  • Webhook トリガーの登録に失敗しました。

5xx ステータス コードを使用したトリガー エラーは、通常、システムの問題であり、一時的なイベントが原因で発生する可能性があります。 これらのエラーは最終的に自己修復されます。

既知の問題

現在、次のトリガー イベントが正常に実行された場合でも、バナーが表示され続ける可能性があります。 製品チームは、問題の解決に向けて取り組んでいます。 バナーが存在していてもフローが正常に実行され続ける場合は、この問題が発生している可能性があります。