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サーバー間フローを使用して Salesforce にアクセスするときに発生するエラー

この記事は、ユーザーがサーバー間フローを使用して Salesforce にアクセスしようとした場合、または管理者が Microsoft Copilot for Sales で Salesforce のサーバー間フローを設定したときに発生する可能性があるエラーのトラブルシューティングと解決に役立ちます。

誰が影響を受けますか?

要件タイプ 説明
クライアント アプリ Copilot for Sales Outlook アドイン
プラットフォーム Web およびデスクトップ クライアント
OS Windows および Mac
デプロイ ユーザー管理と管理者管理
CRM セールスフォース
ユーザー すべてのユーザーまたは管理者

このユーザーのアクセスが拒否されました

症状

ユーザーがサーバー間フローを使用して Salesforce にアクセスしようとすると、次のエラー メッセージが表示されます。

このユーザーのアクセスが拒否されました。

次のメッセージも表示される場合があります。

ユーザーには、接続されているアプリにアクセスするための管理者アクセス許可がありません。

原因

このエラーは、統合ユーザーが Salesforce で接続されているアプリにアクセスすることが承認されていない場合に発生します。 サーバー間フローのセットアップ中に、接続されたアプリがデプロイされ、統合ユーザーに関連付けられます。 統合ユーザーに必要なアクセス許可がない場合、アクセスは拒否されます。

解決策

この問題を解決するには、Salesforce で接続されているアプリ構成を更新します。

  1. Salesforce CRM に管理者としてサインインします。

  2. 設定>プラットフォーム ツール>アプリ>接続されたアプリ>マネージドの接続されたアプリ の順に移動します。

  3. [ 接続済みアプリ ] ページで、[ Sales Connected App の Copilot] を選択します。

  4. [カスタム接続アプリ ハンドラー] で、[実行ユーザーとして] の値が Copilot for Sales Integration User に設定されていることを確認します。

  5. Administration>Users>Users に移動し、統合ユーザーのプロファイルが CopilotForSalesIntegrationProfile であることを確認します。

さらに、接続されているアプリ構成に意図しない変更が加えられたかどうかを確認します。 "はい" の場合は、変更を元の構成に戻します。

サーバー間認証に失敗しました

症状

ユーザーがサーバー間フローを使用して Salesforce にアクセスしようとすると、次のエラー メッセージが表示されます。

サーバー間認証に失敗しました。

次のいずれかのメッセージが表示される場合もあります。

  • Salesforce では、クライアント資格情報フローが無効になっています。

  • Salesforce でクライアント資格情報フローのアクセス トークンを取得できませんでした。

原因

このエラーは、接続されているアプリまたは統合ユーザーが正しく構成されていない場合に発生します。 サーバー間フローのセットアップ中に、接続されたアプリが Salesforce 組織にデプロイされ、統合ユーザーに関連付けられます。 アクセス トークンは、接続されているアプリの資格情報を使用して取得されます。 構成が正しくない場合、認証は失敗します。

解決策

この問題を解決するには、接続されているアプリと統合ユーザーの構成が正しいことを確認します。

  1. Salesforce CRM に管理者としてサインインします。

  2. セットアップ>プラットフォーム ツール>Apps>App Manager に移動します。

  3. [Copilot for Sales Connected App] 行で下矢印を選択し、[編集] を選択します。

  4. [API (OAuth 設定の有効化)] で、[クライアント資格情報フローの有効化] が選択されていることを確認します。

  5. [ アプリ>接続されたアプリ>管理された接続済みアプリ] に移動します。

  6. [ 接続済みアプリ ] ページで、[ Sales Connected App の Copilot] を選択します。

  7. [カスタム接続アプリ ハンドラー] で、[実行名] の値が Copilot for Sales Integration User に設定されていることを確認します。

  8. Copilot for Sales Integration User ユーザーのユーザーの詳細を開き、次を確認します。

    1. 統合ユーザーのプロファイルは CopilotForSalesIntegrationProfile です
    2. ユーザーは、 Copilot for Sales 接続アプリのアクセス許可セットに関連付けられています
    3. ユーザーは、 Salesforce API 統合 アクセス許可セットのライセンス割り当てに関連付けられています。

さらに、接続されているアプリまたは統合ユーザー構成に意図しない変更が加えられたかどうかを確認します。 "はい" の場合は、変更を元の構成に戻します。

サーバー間の承認に失敗しました

症状

ユーザーがサーバー間フローを使用して Salesforce にアクセスしようとすると、次のエラー メッセージが表示されます。

サーバー間の承認に失敗しました。

次のいずれかのメッセージが表示される場合もあります。

エラー 1: Salesforce にアクセスするためのクライアント資格情報を取得できませんでした

原因

Salesforce サーバー間フローのセットアップ中に、接続されたアプリが Salesforce 組織にデプロイされます。 接続されているアプリは、統合ユーザーに関連付けられています。 アクセス トークンは、接続されているアプリのクライアント ID とシークレットを使用して取得されます。 このエラーは、シークレットが無効な場合に発生します。

解決策

この問題を解決するには、 Microsoft サポート に連絡し、次の情報を入力してください。

  • "Copilot for Sales Connected App" 接続済みアプリが誤って更新されたかどうか。
  • 接続されているアプリがまだ使用可能な場合は、その ID を指定します。

エラー 2: セッション ID は Salesforce で REST API アクセスを使用できません

原因

このエラーは、Salesforce サーバー間フローのセットアップ中に、接続されているアプリに適切な OAuth スコープが設定されていない場合に発生します。

解決策

この問題を解決するには、管理者に連絡して、接続されているアプリの適切な OAuth スコープを設定し、管理者設定で接続がまだアクティブであることを確認します。

  1. Salesforce CRM に管理者としてサインインします。

  2. セットアップ>プラットフォーム ツール>Apps>App Manager に移動します。

  3. [Copilot for Sales Connected App] 行で下矢印を選択し、[編集] を選択します。

  4. [API (OAuth 設定の有効化)] で、選択した OAuth スコープの一覧で [API を使用したユーザー データの管理 (api)] が選択されていることを確認します。 選択されていない場合は、誤って設定が手動で変更されているかどうかを確認します。 "はい" の場合は、変更を元に戻します。

    API (API) を使用したユーザー データの管理が選択されていない場合、接続されているアプリは Salesforce データにアクセスできません。

Salesforce への接続に関する問題

症状

ユーザーがサーバー間フローを使用して Salesforce にアクセスしようとすると、次のエラー メッセージが表示されます。

Salesforce への接続に関する問題。

次のメッセージも表示される場合があります。

Salesforce からアクセス トークンを取得するためのクライアント ID を取得できませんでした。 接続されているアプリが正しく構成されていない可能性があります。

原因

このエラーは、Salesforce 接続アプリのクライアント ID が無効な場合に発生します。 サーバー間フローのセットアップ中に、接続されたアプリが Salesforce にデプロイされ、統合ユーザーにリンクされます。 アクセス トークンは、このアプリのクライアント ID とシークレットを使用して取得されます。 クライアント ID が見つからないか、正しくない場合、認証は失敗します。

解決策

この問題を解決するには、 Microsoft サポート に連絡し、次の情報を入力してください。

  • "Copilot for Sales Connected App" 接続済みアプリが誤って削除されたかどうか。
  • 接続されているアプリがまだ使用可能な場合は、その ID を指定します。

もう一度お試しください

症状

管理者として、Salesforce のサーバー間フローを設定しようとすると、次のいずれかのエラー メッセージが表示されることがあります。

  • やり直してください。

  • これは一時的なエラーである可能性があります。 やり直してください。 動作しない場合は、5 ~ 10 分で確認してください。

原因

Salesforce のサーバー間フローを設定すると、システムは Salesforce との接続を確立しようとします。 セットアップ中に、いくつかの一時的な問題が発生する可能性があります。

解決策

この問題を解決するには、数分待ってからやり直してください。 問題が解決しない場合は、エラーの詳細を収集し、 Microsoft サポートにお問い合わせください。

承認されていないアクセスが拒否されました

症状

ユーザーがサーバー間フローを使用して Salesforce にアクセスしようとすると、次のエラー メッセージが表示されます。

承認されていないアクセスが拒否されました。

次のメッセージも表示される場合があります。

アクセス トークンの有効期限が切れているか、無効です。 もう一度保存して更新してください。

原因

認証に使用されるアクセス トークンの有効期限が切れているか、無効です。

解決策

この問題を解決するには、10 分から 15 分後にもう一度やり直してください。 この問題が解決しない場合は、管理者に問い合わせて、接続がまだアクティブかどうかを確認してください。

詳細情報

問題がまだ解決しない場合は、 Copilot for Sales - Microsoft Community Hub にアクセスして、エキスパートと交流してください。

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