Data Protection Manager または Azure Backup Server で BMR バックアップが失敗する

この記事は、Microsoft Azure Backup Server または System Center Data Protection Manager (DPM) の入出力 (I/O) 待機時間が長いためにベア メタル復旧 (BMR) バックアップが失敗する問題を解決するのに役立ちます。

元の製品バージョン: System Center 2016 Data Protection Manager
元の KB 番号: 4512842

現象

Azure Backup Server または System Center Data Protection Manager を使用して BMR バックアップを実行すると、バックアップは失敗します。 DPM サーバーで次のいずれかのエラー メッセージが表示されます。

保護されたコンピューター上の Windows Server Backup (WSB) でエラー (WSB イベント ID: 517、WSB エラー コード: 0x6B48C3A0) が発生したため、DPM でバックアップを作成できません。 (ID 30229 詳細: 内部エラー コード: 0x80990ED0)

ログ名: DPM アラート
ソース: DPM-EM
日付: <日付><時刻>
イベント ID: 3106
タスク カテゴリ: なし
レベル: エラー
キーワード: クラシック
ユーザー: N/A
コンピューター: <サーバー名>
説明: サーバー名>上<の非 VSS データソース ライターのレプリカが、保護されたデータ ソースと一致しません。 データ ソースのすべての保護アクティビティは、レプリカが整合性チェックと同期されるまで失敗します。 (ID: 3106)
現在の操作に関係するストレージを、読み取りまたは書き込みできませんでした。 (ID: 40003)

次のエラー エントリは、保護されたサーバーに記録されます。

ログ名: Microsoft-Windows-Backup
ソース: Microsoft-Windows-Backup
日付: <日付><時刻>
イベント ID : 5
タスク カテゴリ: なし
レベル: エラー
キーワード:
ユーザー: SYSTEM
コンピューター: <サーバー名>
説明:
'<Time>' で開始されたバックアップ操作は、次のエラー コード '0x8078015B' で失敗しました (Windows バックアップリモート共有フォルダーにアクセスするときにエラーが発生しました。リモート共有フォルダーが使用可能でアクセス可能であることを確認した後、操作を再試行してください。)。 ソリューションのイベントの詳細を確認し、問題が解決されたらバックアップ操作を再実行してください。

ログ名: Microsoft-Windows-SmbClient/Connectivity
ソース: Microsoft-Windows-SMBClient
日付: <日付><時刻>
イベント ID: 30809
タスク カテゴリ: なし
レベル: エラー
キーワード: (64)
ユーザー: N/A
コンピューター: <サーバー名>
説明:
サーバーからの応答がないため、要求がタイムアウトしました。

サーバー名: <サーバー名>
セッション ID: <セッション ID>
ツリー ID:0x1
メッセージ ID:0x4000015
コマンド: フラッシュ
指導:
サーバーは TCP 経由で応答していますが、SMB 経由では応答しません。 サーバー サービスが実行されていて応答性が高く、ディスクの IO ごとの待機時間が長くないことを確認します。これにより、ディスクが SMB に応答しなくなります。 また、サーバー全体の応答性が高く、一時停止されていないことを確認します。たとえば、ログオンできることを確認します。

ログ名: Microsoft-Windows-SMBServer/Operational
ソース: Microsoft-Windows-SMBServer
日付: <日付><時刻>
イベント ID: 1020
タスク カテゴリ: (1020)
レベル: 警告
キーワード: (8)
ユーザー: SYSTEM
コンピューター: <ServerName>
説明:
ファイル システムの操作に予想より長い時間がかかった。
クライアント名: <IP>
クライアント アドレス: <IP:Port>
ユーザー名: <ユーザー名>
セッション ID: <セッション ID>
共有名: <sharename>
ファイル名: WINDOWSIMAGEBACKUP\<Servername>\<Backupdate>\<GUID>。.vhdx
コマンド: 7
期間 (ミリ秒単位): 353151
警告しきい値 (ミリ秒単位): 120000
指導:
基になるファイル システムが操作に応答するのに時間がかかりすぎます。 これは通常、SMB ではなくストレージに問題があることを示します。

原因

Windows バックアップ サーバーは、バックアップ中に DPM または Azure Backup サーバー共有に直接書き込みます。 この問題は、入力/出力 (I/O) 待機時間が標準の SMB タイムアウト (60 秒) を超える場合に発生します。

解決方法

重要

このセクション、方法、またはタスクには、レジストリの編集方法が記載されています。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 レジストリを変更する際には十分に注意してください。 保護を強化するため、レジストリを変更する前にレジストリをバックアップします。 こうしておけば、問題が発生した場合にレジストリを復元できます。 レジストリをバックアップおよび復元する方法の詳細については、「Windows でレジストリをバックアップおよび復元する方法」を参照してください。

この問題を解決するには、次の手順を実行します。

  1. 保護されたサーバーで、Registry エディターを開き、次のサブキーのSessTimeout下に示すようにレジストリ エントリを追加します。

    サブキー 名前 データ
    HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters SessTimeout REG_DWORD 1200

    注:

    推奨される値は、1,200 秒 (20 分) のタイムアウトです。 必要に応じて値を調整します。 DPM または Azure Backup Server サーバーの回復性ファイル システム (ReFS) イベント ログを確認して、I/O 待機時間が疑われるかどうかを確認できます。

  2. 保護されたサーバーを再起動します。

    保護されたサーバーを再起動できない場合は、ワークステーション (Lanmanworkstation) サービスを停止して再起動します。

    注:

    ワークステーション (Lanmanworkstation) サービスの依存関係の一覧を必ずチェックしてください。 このサービスに依存するサービスも再起動する必要があります。

詳細

BMR バックアップを使用する場合は、次の前提条件が満たされていることを確認します。